Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Fehler in Anwendung auf Windows Server 2003 R2

Frage Microsoft Windows Netzwerk

Mitglied: JanX

JanX (Level 1) - Jetzt verbinden

03.05.2013 um 10:40 Uhr, 1734 Aufrufe, 14 Kommentare

Hallo,

hier läuft virtualisiert unter VMWare ein Terminalserver unter Windows 2003 R2 Standard x64 Edition, Service Pack 2.

Soweit so gut.

Der wird eigentlich nur remote aufgerufen, also z. B. von entfernten Arbeitsplätzen über einen Tunnel.

Vorgestern hatte ich folgendes Problem: Ich bin über den Tunnel auf den Server, und habe ein Programm starten wollen, das auf einem gemapten Laufwerk auf einem Server 2008 liegt. Das gab die Windows-Fehlermeldung: "Die Anwendung konnte nicht richtig initialisiert werden (0x00000f0). Klicken Sie auf 'OK', um die Anwendung zu beenden."

Drei Punkte sind dabei irritierend:
- Alle anderen Programme auf diesem gemapten Laufwerk lassen sich einwandfrei starten.
- Auch alle älteren Versionen dieses Programms erzeugen die gleiche Meldung.
- Geht man nicht über den Terminalserver auf das gemappte Laufwerk, sondern direkt über einen Desktop vor Ort auf das gemapte Laufwerk, dann läuft das Programm einwandfrei.

Dabei ist es egal, ob man über den Tunnel auf den Terminalserver geht, oder per Remotedesktopverbindung von einem Desktop vor Ort - dieses Programm erzeugt immer diese Meldung. Es dürfte also an dem Terminalserver liegen.

Hat jemand eine Idee, was da schief laufen könnte? Tante Google hat da leider nicht wirklich weitergeholfen.

JanX

Mitglied: goscho
03.05.2013 um 11:00 Uhr
Moin Jan,

hast du dich mal an zur Konsole (mstsc /console /v Dein_TS) angemeldet?
Passiert dann das selbe?
Bitte warten ..
Mitglied: Enric0
03.05.2013 um 11:14 Uhr
Moin,

ich schätze mal das entsprechende Programm möchte gern temporäre Daten irgendwo hinschreiben, wo ein User auf der Terminalserver keine Berechtigung hat. Auf Deinem PC hast Du halt das Recht. Schau Dir mal an was das Programm genau macht mit "Filemon" o.ä.
Bitte warten ..
Mitglied: JanX
03.05.2013 um 11:31 Uhr
Hallo goscho,

keine Änderung

JanX
Bitte warten ..
Mitglied: Enric0
03.05.2013 um 11:35 Uhr
Hast Du Dich mal als lokaler Admin an TS angemeldet und dann versucht das Prog zu starten?
Bitte warten ..
Mitglied: JanX
03.05.2013 um 11:36 Uhr
Hallo Enric0,

nein, temporäre Dateien werden nicht angelegt. Das kann ich auch ohne filemon sagen, da ich alle die betreffenden Programme selber geschrieben habe.

Will denn 0x00000f0 auf fehlende Rechte hinweisen?

JanX
Bitte warten ..
Mitglied: JanX
03.05.2013 um 11:38 Uhr
Enrico0

gleicher Fehler, egal ob remote oder per mstsc

JanX
Bitte warten ..
Mitglied: Enric0
03.05.2013 um 11:42 Uhr
0x00000f0 ist kein Windows Error Code. Jedenfalls steht dieser nicht in der von MS veröffentlichten Error Code Page.
Bitte warten ..
Mitglied: JanX
03.05.2013 um 11:59 Uhr
Kann man hier irgendwelche Screnshots einstellen? Ich bin mal mit dem ProcessMonitor drüber gegangen.

JanX
Bitte warten ..
Mitglied: goscho
03.05.2013 um 12:17 Uhr
Zitat von JanX:
Kann man hier irgendwelche Screnshots einstellen? Ich bin mal mit dem ProcessMonitor drüber gegangen.
Ja, hier ist eine bebilderte Anleitung dazu
Bitte warten ..
Mitglied: JanX
03.05.2013 um 13:16 Uhr
In der Anleitung reden die aber irgendwie von einem anderen Forum. Bei mir sieht das alles komplett anders aus, wenn ich eine Antwort schreibe. Und selbst wenn ich einen bestehenden Beitrag öffne, habe ich oben zwar drei Schaltflächen, aber nicht die abgebildete vierte "Bilder".

JanX
Bitte warten ..
Mitglied: goscho
03.05.2013, aktualisiert um 13:47 Uhr
Zitat von JanX:
In der Anleitung reden die aber irgendwie von einem anderen Forum. Bei mir sieht das alles komplett anders aus, wenn ich eine
Antwort schreibe. Und selbst wenn ich einen bestehenden Beitrag öffne, habe ich oben zwar drei Schaltflächen, aber nicht
die abgebildete vierte "Bilder".
Das ist hier ein wenig verzwickter.
Du musst die Bilder in deinen Eröffnungsbeitrag hochladen (diesen kannst du immer bearbeiten).
Anschließend kannst du diesen Bilderlink in Antworten verwenden (Copy&Paste).
Bitte warten ..
Mitglied: JanX
03.05.2013 um 13:51 Uhr
Hallo goscho,

na, da muß man aber auch erstmal drauf kommen...

So, hier also der Screenshot:2be4415194d46cf41bf2ad9f893a8a7f - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: Enric0
03.05.2013 um 14:07 Uhr
Für mich sieht das so aus als hättest Du in Visual Studio entwickelt. Ist das Richtig?
Sind auf dem Server bzw. Deinem PC .Net gleich?

Schau mal ob die wow64log.dll auf Deinem Rechner vorhanden ist.
Bitte warten ..
Mitglied: JanX
03.05.2013 um 15:16 Uhr
Neenee, so'ne MS-Programmiersprache kommt mir nicht ins Haus Und .Net erst recht nicht.

Aber nein, diese Datei gibt es nicht auf dem Server. Eine Reihe anderer wow64*.dll ja, aber genau diese nicht. Warum auch immer nicht.

Ich frage mich nur, warum die wichtig ist. Wie gesagt, alle Programme sind von mir geschrieben. Alle in der gleichen Sprache. Kein MS, kein .Net. Warum sollte also genau dieses eine dll haben wollen, die alle anderen nicht brauchen?

Muß da mal etwas tiefer graben ...

JanX
Bitte warten ..
Ähnliche Inhalte
Windows Systemdateien
WerFault.exe Fehler in der Anwendung (12)

Frage von Loco75 zum Thema Windows Systemdateien ...

Windows Server
gelöst Windows Server 2012 R2 unbekannter unregelmäßiger Fehler (8)

Frage von soundso zum Thema Windows Server ...

Microsoft
gelöst Windows Server R2-Version (6)

Frage von MiSt zum Thema Microsoft ...

Windows Server
gelöst Windows Server 2003 unter HyperV 2012 R2: Keine Maus (2)

Frage von StefanMUC zum Thema Windows Server ...

Neue Wissensbeiträge
Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Viren und Trojaner

CNC-Fräsen von MECANUMERIC werden (ggf.) mit Viren, Trojanern, Würmern ausgeliefert

(4)

Erfahrungsbericht von anteNope zum Thema Viren und Trojaner ...

Windows 10

Windows 10: Erste Anmeldung Animation deaktivieren

(3)

Anleitung von alemanne21 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Linksys wrt1200ac v2 mit dd-wrt: keine vlan-einstellungen im GUI (15)

Frage von Pixi123 zum Thema Router & Routing ...

E-Business
Wo tragt ihr eure privaten Termine ein? (13)

Frage von honeybee zum Thema E-Business ...

Batch & Shell
Batch zum suchen und verschieben von Verknüpfungen (12)

Frage von zeroblue2005 zum Thema Batch & Shell ...

Windows Server
Terminalserver starten willkürlich neu (12)

Frage von thaefliger zum Thema Windows Server ...