Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Fehler in Batchdatei mit Sprungmarke

Frage Entwicklung Batch & Shell

Mitglied: brunsbuettel

brunsbuettel (Level 1) - Jetzt verbinden

04.06.2012 um 15:40 Uhr, 2514 Aufrufe, 4 Kommentare

Hallo zusammen,

ich erhalte immer die Datei McAfee_8_80.txt und die 8_80_1.txt obwohl er sobald die 8_80.txt vorhanden ist, doch lediglich die McAfee_ENDE.txt erstellt werden dürfte oder? Er springt also nach dem if exist nicht in :ENDE

Wo ist der Fehler in meiner Überlegung?


if exist C:\Programme\McAfee_8_80.txt goto Ende

:DeployMcAfee
CREATE >C:\Programme\McAfee_8_80.txt
CREATE >C:\Programme\McAfee_8_80_1.txt

REM If 0 or other was returned, the product was found or another error occurred. Do nothing.

:Ende
CREATE >C:\Programme\McAfee_ENDE.txt


Endlocal
Mitglied: Skyemugen
04.06.2012, aktualisiert um 16:28 Uhr
Aloha,

sieht für mich wie ein Stück aus einem Werk aus, oder anders gesagt: Etwas ruft bereits DeployMcAfee auf, wodurch logischerweise kein if exist mehr ausgeführt wird.

greetz André

@schlumpf, das macht nur Sinn, wenn Leerzeichen vorkommen sollten ... davon ausgehend, dass das Beispiel realitätsnah gehalten wurde also eher nicht der Fehler.
Wobei wir kennen das OS ja nicht, ist bei den neueren nicht Programme == Program Files in der Bearbeitung? Dann würde das doch wieder Sinn machen
echo on FTW
Bitte warten ..
Mitglied: ITSchlumpf
04.06.2012 um 16:23 Uhr
Hoi bruensbuettel,

probier mal

if exist "C:\Programme\McAfee_8_80.txt" goto Ende


gruß
Schlumpf
Bitte warten ..
Mitglied: der-blob
05.06.2012 um 10:42 Uhr
Mojnsn,

also an den hochkomma dürfe es nicht liegen, da programme ein link auf program files ist (und der link funktioniert auch im deutschen OS [soweit ich weis]) - nur wenn man über %programfiles% geht, dann benötigt man die hochkomma

also tippe ich mal wie Skye drauf das das nur ein schnipsel von dem ganzen ist, wenn nicht, dann ist es klar das beide erstellt werden, denn wenn deine 8_80 nicht da ist, werden beide gleich erzeugt

gruß
Bitte warten ..
Mitglied: brunsbuettel
13.06.2012, aktualisiert um 11:01 Uhr
Hallo,

hier mal das komplette Script. Also meine Überlegung war halt, das er beim ersten Lauf das Programm installiert und dabei eine Datei anlegt. Beim nächsten mal soll er halt prüfen ob die Datei existiert und dann die Installation nicht noch einmal durchführen.

Danke für die Hilfe


setlocal

REM *
REM Benutzerdefinierte Einstellungen des Pfades
REM *


REM Set DeployServer to a network-accessible location containing the Office source files.
set DeployServer=\\xxx\Software\_Softwareverteilung_per_Script\McAfee_870

REM Set LogLocation to a central directory to collect log files.
set LogLocation=\\xxx\Software\_Softwareverteilung_per_Script\McAfee_870\Logfile

REM *
REM Ausführungscode startet hier
REM *

if not exist C:\Programme\McAfee_870 goto DeployMcafee else End

:DeployMcAfee
start /wait %DeployServer%\SetupVSE.Exe
echo %date% %time% Setup ended with error code %errorlevel%. >> %LogLocation%\%computername%.txt

CREATE >C:\Programme\McAfee_870

REM If 0 or other was returned, the product was found or another error occurred. Do nothing.
:End

Endlocal
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Windows Server
gelöst BackupExec 2016 Fehler beim Backup von Windows 2016 (1)

Frage von Looser27 zum Thema Windows Server ...

Switche und Hubs
gelöst Trunk für 2xCisco Switch. Wo liegt der Fehler? (43)

Frage von JayyyH zum Thema Switche und Hubs ...

Vmware
Veeam für VM Ware Backup Fehler (2)

Frage von JoergN1968 zum Thema Vmware ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...