Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Fehler in einfachem Script

Frage Entwicklung PHP

Mitglied: Nippie

Nippie (Level 2) - Jetzt verbinden

14.06.2006, aktualisiert 22:46 Uhr, 3831 Aufrufe, 6 Kommentare

Yo Leute...
Ich habe vor kurzem mal was gepostet...Ich habe mir noch externe Informationen hinzugeholt und den ganzen Nachmitag geknobelt... Hier ist das script:

<html>
<form name="form" method="post" action="">
<div align="center">
<input type="text" name="$antwort">
<input name="$button" type="submit" id="$button" value="Senden">
</div>
</form>
<?
if ($button) {
$fp = fopen('http://nippie.ni.funpic.de/form/wm.txt', 'a');
$antwort = $antwort."\n";
fputs($fp, $antwort, strlen($antwort));
fclose($fp);
}
?>
</html>

Kann mir jemand sagen wo der fehler liegt???

Mfg Nippie

Thread gelöst und geschlossen! 21.06.2007
masterG
Mitglied: Dani
14.06.2006 um 19:10 Uhr
Hi,
nächstes mal, vielleicht den Fehlercode mitposten!!
Probier mal das:
01.
<html> 
02.
<form name="form" method="post" action=""> 
03.
<div align="center"> 
04.
<? 
05.
echo "<input type='text' name='$antwort'>"; 
06.
echo "<input name='$button' type='submit' id='$button' value='Senden'>"; 
07.
echo "</div>"; 
08.
echo "</form>"; 
09.
 
10.
if ($button) 
11.
12.
  $fp=fopen('http://nippie.ni.funpic.de/form/wm.txt', 'a'); 
13.
  $antwort=$antwort."\n"; 
14.
  fputs($fp, $antwort, strlen($antwort)); 
15.
  fclose($fp); 
16.
17.
?> 
18.
</html>

Gruß
Dani
Bitte warten ..
Mitglied: Nippie
14.06.2006 um 20:45 Uhr
Entschuldugung,
Mein Problem ist, das der eingegebene text nicht in die "wm.txt" geschrieben wird......Das eben ging auch nicht.

Danke schon einmal
Bitte warten ..
Mitglied: Dani
14.06.2006 um 20:51 Uhr
Hi,
soll der Text am Ende oder am Anfang eingefügt werden??


Gruß
Dani
Bitte warten ..
Mitglied: Dani
14.06.2006 um 20:56 Uhr
Hi,
dann probier Das mal:
01.
<? 
02.
echo "<html>"; 
03.
if($_POST['submit'] <> "") 
04.
05.
  $antwort=$_POST['text']; 
06.
  $antwort = $antwort."\n"; 
07.
  $fp = fopen("'http://nippie.ni.funpic.de/form/wm.txt", "a"); 
08.
  fwrite ($fp,$antwort); 
09.
  fclose($fp); 
10.
11.
else 
12.
13.
  echo "<form name='form' method='post'>"; 
14.
  echo "<div align='center'>"; 
15.
  echo "<input type='text' name='text'>"; 
16.
  echo "<input name='submit' type='submit' value='Senden'>"; 
17.
  echo "</div>"; 
18.
  echo "</form>"; 
19.
20.
echo "</html>"; 
21.
?>
Hast du die Datei schon angelegt und mit den entsprechenden Rechten versehen?!


Gruß
Dani
Bitte warten ..
Mitglied: Nippie
14.06.2006 um 20:58 Uhr
Ich habs schon:

<html>
<form name="form1" method="post" action="<? echo $PHP_SELF; ?>">
<div align="center">
<input type="text" name="antwort">
<input name="button" type="submit" id="button" value="Senden">
</div>
</form>
<?
if($_REQUEST['button']) {
$fp = fopen('wm.txt', 'a');
$antwort = $_POST["antwort"]."\n";
fputs($fp, $antwort, strlen($antwort));
fclose($fp);
}
?>
</html>


Mfg Nippie
Danke für die Hilfe
Bitte warten ..
Mitglied: filippg
14.06.2006 um 22:46 Uhr
Hallo,

in der PHP-Doku habe ich da spontan nichts zu gefunden, aber ich könnte mir vorstellen, dass ein append bei einer http-Ressource nicht verfügbar ist. Zumindest sieht http dafür ja keinen Befehl vor (mit einem entsprechenden Wrapper liesse sich das aber evtl regeln.

Filipp
Bitte warten ..
Ähnliche Inhalte
Exchange Server
SBS 2011 - Outlook Web App - Kritischer Fehler im Script (4)

Frage von Antshit zum Thema Exchange Server ...

Server
Fehler in jQuery (7)

Frage von Yanmai zum Thema Server ...

LAN, WAN, Wireless
Per Script auf UniFi-controller zugreifen und WPA2-Key ändern (11)

Frage von Winfried-HH zum Thema LAN, WAN, Wireless ...

Batch & Shell
gelöst PC nach einem Kopiervorgang herunterfahren - PowerShell Script? (4)

Frage von Stefan007 zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Verschlüsselung & Zertifikate
gelöst Festplattenverschlüsselung im Ausland (13)

Frage von Nicolaas zum Thema Verschlüsselung & Zertifikate ...

Festplatten, SSD, Raid
gelöst Fehlerhafte Blöcke im RAID 10 (12)

Frage von Kojak-LE zum Thema Festplatten, SSD, Raid ...

Windows Server
gelöst Microsoft-Lizenz CALs und passendes Server-Betriebssystem (12)

Frage von planetIT2016 zum Thema Windows Server ...

Netzwerkgrundlagen
gelöst Cisco SG500 Series LAG hat sich von selbst umgestellt (11)

Frage von Ex0r2k16 zum Thema Netzwerkgrundlagen ...