Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Fehler beim Einrichten einer lokalen Domain unter OS X und MAMP

Frage Apple Mac OS X

Mitglied: bolshi

bolshi (Level 1) - Jetzt verbinden

12.03.2013 um 13:46 Uhr, 2900 Aufrufe, 12 Kommentare

Moin,

hier läuft MAMP unter OS X 10.8.2.

In der httpd.conf folgendes aktiviert

  1. Virtual hosts
Include /Applications/MAMP/conf/apache/extra/httpd-vhosts.conf

Die httpd-vhost.conf:

NameVirtualHost *:8080

  1. VirtualHost example:
  2. Almost any Apache directive may go into a VirtualHost container.
  3. The first VirtualHost section is used for all requests that do not
  4. match a ServerName or ServerAlias in any <VirtualHost> block.
<VirtualHost *:8080>
DocumentRoot "/Applications/MAMP/htdocs/intro4523"
ServerName ippw.local
ServerAlias www.ippw.local
</VirtualHost>

In der /etc/hosts

127.0.0.1 ippw.local

eingetragen.

Apache restart ...

Ups! Google Chrome konnte keine Verbindung zu ippw.local:8080 herstellen.


Apache und MySQL laufen, Domainaufruf zeigt die Website nicht an.



Mitglied: infowars
12.03.2013 um 14:08 Uhr
Was passiert wenn du 127.0.0.1:8080 eintippst ?
Bitte warten ..
Mitglied: bolshi
12.03.2013 um 14:13 Uhr
Zitat von infowars:
Was passiert wenn du 127.0.0.1:8080 eintippst ?

Dasselbe. Im Browser kommt

Ups! Google Chrome konnte keine Verbindung zu 127.0.0.1:8080 herstellen.
Bitte warten ..
Mitglied: infowars
12.03.2013, aktualisiert um 14:36 Uhr
Mit OS X kenn ich mich nicht aus, aber kann es sein dass das Verzeichnis geschützt ist ?
Was sagt denn die Logdatei ?
Läuft der normale Host ?

EDIT:
Ich glaube du darfst in der httpd.conf nicht den absoluten Pfad angeben, sondern nur:

  1. Virtual hosts
Include "conf/extra/httpd-vhosts.conf"
Bitte warten ..
Mitglied: bolshi
12.03.2013 um 15:17 Uhr
Zitat von infowars:
EDIT:
Ich glaube du darfst in der httpd.conf nicht den absoluten Pfad angeben, sondern nur:

  1. Virtual hosts
Include "conf/extra/httpd-vhosts.conf"

Das Ding ist die httpd.conf liegt in:

/Applications/MAMP/conf/apache/httpd.conf

Meinst du ich sollte das Verzeichnis als relativen Pfad angeben?
Bitte warten ..
Mitglied: infowars
12.03.2013, aktualisiert um 15:24 Uhr
Genau, in der httpd.conf nur
01.
# Virtual hosts 
02.
Include "conf/extra/httpd-vhosts.conf" 
und in der httpd-vhost.conf den absoluten Pfad angeben:
01.
<VirtualHost *:8080> 
02.
DocumentRoot "/Applications/MAMP/htdocs/intro4523" 
03.
ServerName ippw.local 
04.
ServerAlias www.ippw.local 
05.
</VirtualHost>
Bitte warten ..
Mitglied: bolshi
12.03.2013, aktualisiert um 16:26 Uhr
Funktioniert leider nicht.

Macht für mich insofern keinen Sinn, da die httpd.conf in

01.
/Applications/MAMP/conf/apache/httpd-vhosts.conf
liegt. Zum Erreichen der httpd-vhost.conf bei relativer Pfadangabe quasi nur noch

01.
/extra/httpd-vhosts.conf
benötigt würde. Geht aber leider auch nicht. Im Anschluss startet der Apache nicht mehr. Sobald der statische Pfad wieder aktiv ist startet auch der Apache.
Bitte warten ..
Mitglied: infowars
12.03.2013 um 16:40 Uhr
Dann probier doch mal
01.
Include "conf/extra/httpd-vhosts.conf" 
Bitte warten ..
Mitglied: bolshi
12.03.2013 um 16:55 Uhr
Zitat von infowars:
Dann probier doch mal
01.
> Include "conf/extra/httpd-vhosts.conf" 

Hab's: Unter MAMP -> Einstellungen war der Apache Port auf '80'. Auf '8080' geändert klappt's auch mit dem Anzeigen der Website via 'ippw.local'

Nur zeigt 127.0.0.1:8080 jetzt auch die Website an, die normalerweise nur unter 'ippw.local' erscheinen soll.

Muss jeder VirtualHost seinen eigenen Port bekommen?
Bitte warten ..
Mitglied: bolshi
12.03.2013 um 17:08 Uhr
Hab grad mal probiert der 2ten Entwicklungsumgebung Port als 8090 zu geben

01.
<VirtualHost *:8090> 
02.
        DocumentRoot "/Applications/MAMP/htdocs/intro6021" 
03.
        ServerName 6021.local 
04.
        ServerAlias www.6021.local 
05.
</VirtualHost>
01.
Ups! Google Chrome konnte keine Verbindung zu 6021.local:8090 herstellen.
Bei 8080 landet die URL ebenso auf der ersten Entwicklungsumgebung.
Bitte warten ..
Mitglied: bolshi
12.03.2013 um 17:11 Uhr
Muss mich verbessern: Alles klappt auch mit dem 2ten CMS, sobald ich in den MAMP-Einstellungen den Port anpasse. Muss mal recherchieren, ob sich das irgendwie komfortabler konfigurrieren lässt.
Bitte warten ..
Mitglied: bolshi
16.03.2013 um 09:24 Uhr
Kurzfristig hatte ich mit folgender Konfiguration Erfolg:

01.
02.
# Use name-based virtual hosting. 
03.
04.
NameVirtualHost * 
05.
 
06.
<VirtualHost *> 
07.
        DocumentRoot "/Applications/MAMP/htdocs/senchaTouch2" 
08.
        ServerName senchaTouch2examples.local 
09.
        ServerAlias www.SenchaTouch2examples.local 
10.
</VirtualHost> 
11.
<VirtualHost *> 
12.
        DocumentRoot "/Applications/MAMP/htdocs/intro4523" 
13.
        ServerName ippw.local 
14.
        ServerAlias www.ippw.local 
15.
</VirtualHost> 
16.
 
17.
<VirtualHost *> 
18.
        DocumentRoot "/Applications/MAMP/htdocs/intro6021" 
19.
        ServerName 6021.local 
20.
        ServerAlias www.6021.local 
21.
</VirtualHost> 
22.
<VirtualHost *> 
23.
        DocumentRoot "/Applications/MAMP/htdocs/sencha" 
24.
        ServerName sencha.local 
25.
        ServerAlias www.sencha.local 
26.
</VirtualHost>
Sodass ich alle Projekte gleichzeitig/parallel im Browser öffnen konnte. Das geht jetzt nicht mehr.

Hast du eine Idee warum?
Bitte warten ..
Mitglied: bolshi
16.03.2013 um 09:47 Uhr
Hab's: Nach ändern der httpd-vhost DNS-Cache leeren

https://support.apple.com/kb/HT5343?viewlocale=de_DE&locale=de_DE ;)

Gruß und Dank,

bolshi
Bitte warten ..
Ähnliche Inhalte
Heiß diskutierte Inhalte
Windows 7
gelöst BOOTMGR is missing (auch nach bootrec -RebuildBcd) (20)

Frage von Mipronimo zum Thema Windows 7 ...

Router & Routing
Tipps für Router (ca. 100 clients, VPN) (19)

Frage von oel-auge zum Thema Router & Routing ...

Windows Userverwaltung
Windows Freigabe: Zugriff auf alle Ordner trotz Sicherheitseinstellungen (17)

Frage von Pandreas zum Thema Windows Userverwaltung ...

TK-Netze & Geräte
gelöst Convert von TAPI auf CAPI gesucht (13)

Frage von StefanKittel zum Thema TK-Netze & Geräte ...