Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Bei Fehler email versenden

Frage Linux

Mitglied: sharth

sharth (Level 1) - Jetzt verbinden

06.01.2007, aktualisiert 09.01.2007, 7598 Aufrufe, 13 Kommentare

Hallo allerseits,

ich habe mir für meinen Bastel-Server zu Hause ein automatisches Backup eingerichtet. Falls dieses Backup fehlschlägt, möchte ich, dass eine email an mich versendet wird. Muss ich dazu einen eigenen email Server einrichten oder wie lässt sich das realisieren. Es mangelt mir ein wenig an Erfahrung auf diesem Gebiet.

Vielen Dank für eure Hilfe.

Gruß


Sharth
Mitglied: ghofmann
06.01.2007 um 20:05 Uhr
Erst mal eine generelle Empfehlung: eine Mail *ausschließlich* im Fehlerfall zu generieren, ist keine gute Idee. Denn die Tatsache, dass keine Mail kommt, könnte ja verschiedenes bedeuten:
- es hat alles geklappt
- Backup hat nicht geklappt und die Fehlermail kommt nicht an, weil Maildienst grad nicht funktioniert

Jetzt aber zu der Frage:
Wie machst denn Dein Backup? Mit irgendeiner Software, die ein Datensicherungslogfile erzeugt? In dem Fall könntest Dir dieses Logfile zumailen lassen. Ich nehm an, Du redest hier über Windows? Dann ist der Kommandozeilen-Mailer blat geeignet (www.blat.net)

Eigenen Mailserver musst Du nicht aufsetzen. Registrier Dir doch ein Emailkonto bei einem Freemailer, also vielleicht datensicherungslog@gmx.de, blat müsste damit umgehen können.
Bitte warten ..
Mitglied: sharth
06.01.2007 um 20:22 Uhr
Entschuldigung für die spartanischen Infos, die ich hinterlassen habe. Als Betriebssystem verwende ich Debian und für die Backups das Tool rsnapshot. Wie gesagt, es ist ein "Bastel-Server". Habe wenig Ahnung auf dem Gebiet, deshalb benötige ich einen Tipp, wie ich soetwas realisieren könnte. Die email soll an den Mail-Server meines Providers geschickt werden.


Danke schon mal für eure Antworten!

Gruß

sharth
Bitte warten ..
Mitglied: ghofmann
06.01.2007 um 20:47 Uhr
Ach so, Du hast Linux...
Ändert ab nix großartiges an den Aussagen aus meinem vorigen Mail. Ich denke ja mal, rsnapshot legt ein Logfile an oder kann das zumindest tun.

Versenden von Mails per Kommandozeile geht mit dem Kommando mail.

Versuch doch vielleicht einfach mal als ersten Test, Deine /etc/hosts Datei an Deine eigene Email-Adresse zu senden:
cat /etc/hosts | mail -S "Testmail" myaccount@mycompany.com

Ggf. in einem zweiten Terminal mit
tail -f /var/log/mail.log
beobachten, ob irgendwelche Fehler beim Senden der Email auftreten.
Bitte warten ..
Mitglied: sharth
07.01.2007 um 15:17 Uhr
Hallo,

leider hat das Senden der Testmail nicht funktioniert. Alle Emails befinden sich noch in der Warteschleife (mit "mailq" überprüft). Muss ich nicht vorher den MTA (in meinem Fall exim4) konfigurieren, bevor das funktionieren kann? Da liegt nämlich auch mein eigentliches Problem,weil ich nicht weiß, welche Einstellungen ich vornehmen muss. Ich hoffe jemand kann mir einen Tipp geben.

Danke im Voraus

sharth
Bitte warten ..
Mitglied: ghofmann
07.01.2007 um 15:35 Uhr
Du müsstest Deinem MTA wahrscheinlich sagen, dass ausgehende Mails an den SMTP-Server Deines Providers weitergereicht werden müssen.

Vielleicht mal hier schauen:
http://debiananwenderhandbuch.de/email.html

Da wird was zu eximconfig beschrieben...
Bitte warten ..
Mitglied: 6890
07.01.2007 um 17:13 Uhr
hi,

also du rufst einfach base-config auf, danach gehst du auf den punkt MTA konfigurieren und dann wählst du Email versenden über Smart-Relay-Host (oder so ähnlich).

danach nur einstellen für wenn auf dem rechner empfangen werden soll, dann den smtp server deines providers oder so eintragen und unter /etc/aliases/ hinter root also so root: meine@mail.de eintragen. das wars, das kannste ja dann mit mail -s TEST root testen.

Mit freundlichen Grüßen godlike P
Bitte warten ..
Mitglied: Maik87
08.01.2007 um 14:46 Uhr
cat /etc/hosts | mail -S
"Testmail" myaccount@mycompany.com

Der Parameter -s muss klein geschrieben werden!!
Bitte warten ..
Mitglied: ghofmann
08.01.2007 um 14:50 Uhr
ups, sorry...
Stimmt, es muss -s (klein) heißen.
Bitte warten ..
Mitglied: sharth
08.01.2007 um 16:43 Uhr
Hallo zusammen,

leider komme ich nicht weiter, weil ich wenig Ahnung von der Thematik habe.
Folgende Felder müssen während der Konfiguration ausgefüllt werden:

E-mailname des Systems: servus.de

IP-Adresse auf welche Exim eingehende SMTP-Verbindungen beantwortet: ??? (habe keine feste IP)

Weitere Domänen für die Email angenommen werden soll: -

Rechner für die ausgehende mail weitergeleitet wird: ?

Rechner, der die Weiterleitung ausgehender E-Mail vornimmt (Smarthost): smtp.meinprovider.de

Wäre sehr nett, wenn mir nochmal jemand beschreiben könnte wie eine funktionierende Konfig aussehen müsste. Unter var/log/exim4/mainlog bekomme ich folgende Fehlermeldung:

root@servus.de R=smarthost T=remote_smtp_smarthost:
SMTP error from remote mailer after RCPT TO:<root@servus.de>:
host smtp.1und1.de [212.227.15.183]: 550 must be authenticated

Aber auch die interne Mail-Zustellung funktioniert nicht.
Bin dankbar für jede Anregung oder Hilfestellung.

Gruß,

sharth
Bitte warten ..
Mitglied: ghofmann
08.01.2007 um 17:04 Uhr
Ich glaub, Du bist beim Versenden von Mail nach extern nicht mehr weit weg.

Vielleicht müsstest beim mail Befehl noch den -r Schalter mitgeben, um eine gültige Absender-Email-Adresse zu spezifizieren.

Oder vielleicht müsstest Du erst mal von 1und1 Email abrufen, bevor Du senden darfst (POP-before-SMTP oder sowas...)
Bitte warten ..
Mitglied: 6890
08.01.2007 um 19:29 Uhr
Hallo zusammen,

leider komme ich nicht weiter, weil ich
wenig Ahnung von der Thematik habe.
Folgende Felder müssen während der
Konfiguration ausgefüllt werden:

E-mailname des Systems: servus.de

IP-Adresse auf welche Exim eingehende
SMTP-Verbindungen beantwortet: ??? (habe
keine feste IP)

127.0.0.1

Weitere Domänen für die Email
angenommen werden soll: -

keine

Rechner für die ausgehende mail
weitergeleitet wird: ?

default-wert lassen

Rechner, der die Weiterleitung ausgehender
E-Mail vornimmt (Smarthost):
smtp.meinprovider.de

richtig

Wäre sehr nett, wenn mir nochmal jemand
beschreiben könnte wie eine
funktionierende Konfig aussehen müsste.
Unter var/log/exim4/mainlog bekomme ich
folgende Fehlermeldung:

root@servus.de R=smarthost
T=remote_smtp_smarthost:
SMTP error from remote mailer after RCPT
TO:<root@servus.de>:
host smtp.1und1.de [212.227.15.183]: 550
must be authenticated

du hast doch einen benutzernamen und ein passwort und dieses verlangt der smtp-server. is ja auch logisch sonst würde der smtp server ja als spam schleuder dienen

Aber auch die interne Mail-Zustellung
funktioniert nicht.
Bin dankbar für jede Anregung oder
Hilfestellung.

könnte sein das daran liegt das wir smart relay host eingestellt haben.
du kannst ja mal folgendes probieren:
erstell dir ma 2 nutzer, log dich mit einen ein und sende eine an den zweiten.
probier mal ob das funktioniert.

Gruß,

sharth

Mit freundlichen Grüßen godlike P
Bitte warten ..
Mitglied: sharth
08.01.2007 um 19:52 Uhr
Hallo,

das mit der Authentifizierung hatte ich mir schon fast gedacht aber "Wo" muss ich Benutzername und Passwort eingeben, wenn ich diese email manuell verschicke?
Das mit den zwei Benutzern werde ich umgehend ausprobieren.
Danke für die Tipps.

Schönen Abend

sharth
Bitte warten ..
Mitglied: sharth
09.01.2007 um 16:41 Uhr
Hat keiner eine Idee???

Gruß,

sharth
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Apache Server
gelöst OsTicket Email versenden klappt nicht (5)

Frage von ClepToManix zum Thema Apache Server ...

Visual Studio
gelöst Email Versenden Mit VB (2)

Frage von UltraZz zum Thema Visual Studio ...

Datenbanken
gelöst Access Report per Email versenden, hat jemand zufällig einen Code dafür(VBA) (7)

Frage von Dr.Cornwallis zum Thema Datenbanken ...

Server-Hardware
gelöst DL380 G7 Warnungen via email versenden (8)

Frage von franksig zum Thema Server-Hardware ...

Heiß diskutierte Inhalte
Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

DSL, VDSL
DSL-Signal bewerten (12)

Frage von SarekHL zum Thema DSL, VDSL ...

Windows Server
Mailserver auf Windows Server 2012 (8)

Frage von StefanT81 zum Thema Windows Server ...

Backup
Clients als Server missbrauchen? (8)

Frage von 1410640014 zum Thema Backup ...