Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Fehler in JSP sagt mir nix

Frage Entwicklung Java

Mitglied: Dipps

Dipps (Level 2) - Jetzt verbinden

10.03.2009, aktualisiert 11.03.2009, 5089 Aufrufe, 4 Kommentare

Fehler in JSP sagt mir nix

Hallo ich hoffe das mir dieses mal jemand helfen kann da in den meisten fragen die ich hier gestellt habe keiner geantwortet hat.

Ich habe in JSP keine großartige ahnung und kann auch nicht im Quellcode rumfuschen.

Ich habe eine Applikation mit einer webapp den Ordner webapp wollte ich ins intranet stellen da eine index.jsp drin ist als fehler kommt bei der darstellung

01.
HTTP Status 500 - 
02.
 
03.
type Exception report 
04.
 
05.
message 
06.
 
07.
description The server encountered an internal error () that prevented it from fulfilling this request. 
08.
 
09.
exception 
10.
 
11.
org.apache.jasper.JasperException: /weka/webapp/index.jsp(3,0) The absolute uri: http://myfaces.apache.org/tomahawk cannot be resolved in either web.xml or the jar files deployed with this application 
12.
	org.apache.jasper.compiler.DefaultErrorHandler.jspError(DefaultErrorHandler.java:40) 
13.
	org.apache.jasper.compiler.ErrorDispatcher.dispatch(ErrorDispatcher.java:407) 
14.
	org.apache.jasper.compiler.ErrorDispatcher.jspError(ErrorDispatcher.java:88) 
15.
	org.apache.jasper.compiler.Parser.processIncludeDirective(Parser.java:345) 
16.
	org.apache.jasper.compiler.Parser.parseIncludeDirective(Parser.java:378) 
17.
	org.apache.jasper.compiler.Parser.parseDirective(Parser.java:486) 
18.
	org.apache.jasper.compiler.Parser.parseElements(Parser.java:1444) 
19.
	org.apache.jasper.compiler.Parser.parse(Parser.java:138) 
20.
	org.apache.jasper.compiler.ParserController.doParse(ParserController.java:216) 
21.
	org.apache.jasper.compiler.ParserController.parse(ParserController.java:103) 
22.
	org.apache.jasper.compiler.Compiler.generateJava(Compiler.java:154) 
23.
	org.apache.jasper.compiler.Compiler.compile(Compiler.java:315) 
24.
	org.apache.jasper.compiler.Compiler.compile(Compiler.java:295) 
25.
	org.apache.jasper.compiler.Compiler.compile(Compiler.java:282) 
26.
	org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:586) 
27.
	org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:317) 
28.
	org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:342) 
29.
	org.apache.jasper.servlet.JspServlet.service(JspServlet.java:267) 
30.
	javax.servlet.http.HttpServlet.service(HttpServlet.java:717) 
31.
 
32.
note The full stack trace of the root cause is available in the Apache Tomcat/6.0.18 logs.
nun habe ich die web.xml in den selben Ordner gelegt und da kommt
01.
HTTP Status 500 - 
02.
 
03.
type Exception report 
04.
 
05.
message 
06.
 
07.
description The server encountered an internal error () that prevented it from fulfilling this request. 
08.
 
09.
exception 
10.
 
11.
org.apache.jasper.JasperException: org.apache.jasper.JasperException: Unable to load class for JSP 
12.
	org.apache.jasper.servlet.JspServletWrapper.getServlet(JspServletWrapper.java:156) 
13.
	org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:329) 
14.
	org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:342) 
15.
	org.apache.jasper.servlet.JspServlet.service(JspServlet.java:267) 
16.
	javax.servlet.http.HttpServlet.service(HttpServlet.java:717) 
17.
 
18.
root cause 
19.
 
20.
org.apache.jasper.JasperException: Unable to load class for JSP 
21.
	org.apache.jasper.JspCompilationContext.load(JspCompilationContext.java:620) 
22.
	org.apache.jasper.servlet.JspServletWrapper.getServlet(JspServletWrapper.java:144) 
23.
	org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:329) 
24.
	org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:342) 
25.
	org.apache.jasper.servlet.JspServlet.service(JspServlet.java:267) 
26.
	javax.servlet.http.HttpServlet.service(HttpServlet.java:717) 
27.
 
28.
root cause 
29.
 
30.
java.lang.ClassNotFoundException: org.apache.jsp.weka.webapp.index_jsp 
31.
	java.net.URLClassLoader$1.run(Unknown Source) 
32.
	java.security.AccessController.doPrivileged(Native Method) 
33.
	java.net.URLClassLoader.findClass(Unknown Source) 
34.
	org.apache.jasper.servlet.JasperLoader.loadClass(JasperLoader.java:134) 
35.
	org.apache.jasper.servlet.JasperLoader.loadClass(JasperLoader.java:66) 
36.
	org.apache.jasper.JspCompilationContext.load(JspCompilationContext.java:618) 
37.
	org.apache.jasper.servlet.JspServletWrapper.getServlet(JspServletWrapper.java:144) 
38.
	org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:329) 
39.
	org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:342) 
40.
	org.apache.jasper.servlet.JspServlet.service(JspServlet.java:267) 
41.
	javax.servlet.http.HttpServlet.service(HttpServlet.java:717) 
42.
 
43.
note The full stack trace of the root cause is available in the Apache Tomcat/6.0.18 logs.
kann mir jemand sagen was ich noch machen muss da mir die fehler nix sagen
Mitglied: 60730
20.03.2009 um 14:37 Uhr
Servus,

Hallo ich hoffe das mir dieses mal jemand helfen kann da in den meisten fragen die ich hier gestellt habe keiner geantwortet hat.

Aber gerne doch - obwohl ich da auch mal die Fehlerquelle hinter der eigenen Nase suchen würde
Nicht jeder hat immer Lust und eine frisch polierte Kristallkugel herumfliegen, daran solltest du denken, wenn du eine Frage stellst und auf Antwort wartest.

The absolute uri: http://myfaces.apache.org/tomahawk cannot be resolved in either web.xml or the jar files deployed with this application.

Ich hab ja (wie fast alle anderen auch) - keinen Plan, was du und wie du was installiert hast - sieht auf den ersten Blick so aus, als ob du Samples benutzt, die auf "http://myfaces.apache.org/tomahawk" zugreifen, obwohl Sie vielleicht besser auf deinem Server sein sollten?

Unable to load class for JSP
"Hört sich auch nach dem gleichen "Bock" an.
findClass(Unknown Source)
"unbekannte quelle" *grübel* - nee sorry - dafür sind meine englisch Kentnisse nicht ausreichend
Also im Zweifel gilt das gleiche - wie oben

kann mir jemand sagen was ich noch machen muss da mir die fehler nix sagen
RTFM?

Gruß
Bitte warten ..
Mitglied: Dipps
20.03.2009 um 15:01 Uhr
ich habe das Programm ja nicht gemacht und wollte eigentlich auch nicht im Code rum fuschen.

Das ist ja ein Programm was ich auf den Rechner installiert habe und dann unter .../Programme/Software/ ist eine start.exe weiterhin ist da ein webapp ordner den ich auf den intranetserver geladen habe doch da kommt dann immer diese Fehler wie oben geschrieben
Bitte warten ..
Mitglied: 60730
20.03.2009 um 23:20 Uhr
Servus,

Nicht jeder hat immer Lust und eine frisch polierte Kristallkugel herumfliegen, daran solltest du denken, wenn du eine Frage stellst und auf Antwort wartest.

Zitat von Dipps:
ich habe das Programm mit unbekanntem Namen ja nicht gemacht und wollte eigentlich auch nicht im Code rum fuschen.

schade, den Wink mit dem Zaunpfahl aka Kristallkugel - hast du nicht verstanden...

Das ist ja ein Programm mit unbekanntem Namen was ich auf den Rechner installiert habe und
dann unter .../Programme/Software/ ist eine start.exe weiterhin ist da
ein webapp ordner den ich auf den intranetserver mit unbekanntem Betriebsystemgeladen habe doch da
kommt dann immer diese Fehler wie oben geschrieben.

Ergo entweder Hilfe annehmen, RTFM oder doch Gelbe Seiten.
Und bitte never ever eine Frage mit :
"Hallo ich hoffe das mir dieses mal jemand helfen kann da in den meisten fragen die ich hier gestellt habe keiner geantwortet hat."
beginnen - ist ja fast genauso schlimm - wie Grußlos drauf loszutippen.

Gruß
Bitte warten ..
Mitglied: Dipps
23.03.2009 um 13:14 Uhr
das meine ich damit auf solche sinnlosen Antworten kann ich verzichten. das heißt es gibt wieder keinen der mir helfen kann.
und Timo schau schön weiter in deine kristallkugel..
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Hyper-V
gelöst HyperV - VMs weg finde nix mehr (6)

Frage von Nemonautilus zum Thema Hyper-V ...

Windows Server
gelöst BackupExec 2016 Fehler beim Backup von Windows 2016 (1)

Frage von Looser27 zum Thema Windows Server ...

Switche und Hubs
gelöst Trunk für 2xCisco Switch. Wo liegt der Fehler? (43)

Frage von JayyyH zum Thema Switche und Hubs ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (18)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...