Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Fehler bei Replikation

Frage Entwicklung Datenbanken

Mitglied: mastertulle

mastertulle (Level 1) - Jetzt verbinden

15.02.2011 um 18:06 Uhr, 5404 Aufrufe, 1 Kommentar

Hallo liebe Community,

habe folgendes Problem:

Ich will eine Transaktionsreplikation zwischen 2 Datenbanken auf einem Server machen.

Hierzu habe ich den Verteiler/Verleger bereits eingerichtet, jedoch noch keinen Abonnenten.

Der Snapshot-Agent läuft problemlos durch.
Der Protokolllese-Agent hingegen schreibt immer folgenende Fehlermeldung:

Der Prozess konnte 'sp_replcmds' nicht auf 'Server_1'ausführen.


Dazu steht im Replikationsmonitor folgende Fehlermeldung:

Der Prozess konnte 'sp_replcmds' nicht auf 'Server_1' ausführen. (Quelle: MSSQL_REPL, Fehlernummer: MSSQL_REPL20011)
Hilfe abrufen: http://help/MSSQL_REPL20011
Die Ausführung als Datenbankprinzipal ist nicht möglich, weil der Prinzipal 'dbo' nicht vorhanden ist, für diesen Typ von Prinzipal kein Identitätswechsel möglich ist, oder Sie nicht die erforderliche Berechtigung haben. (Quelle: MSSQLServer, Fehlernummer: 15517)
Hilfe abrufen: http://help/15517
Der Prozess konnte 'sp_replcmds' nicht auf 'Server_1'ausführen. (Quelle: MSSQL_REPL, Fehlernummer: MSSQL_REPL22037)
Hilfe abrufen: http://help/MSSQL_REPL22037

Ich hoffe es kann mir jemand helfen!

Grüße

Sven
Mitglied: blade999
25.07.2014 um 11:20 Uhr
Thema ist zwar schon 3 Jahre alt, ich habe aber aktuell mit meinem 2012er Server das selbe Problem.

Einer eine Lösung parrat?
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
Windows Server
gelöst Nach Ausfall FSMO-Rollen "Seize" nun fehler bei SYSVOL Replikation DFS-R (17)

Frage von CengizPirasa zum Thema Windows Server ...

Drucker und Scanner
Laserjet 3600N Fehler PCL Error (1)

Frage von grillinator95 zum Thema Drucker und Scanner ...

SAN, NAS, DAS
S.M.A.R.T Fehler QNAP (11)

Frage von Hendrik2586 zum Thema SAN, NAS, DAS ...

Heiß diskutierte Inhalte
Linux Netzwerk
gelöst DHCP vergibt keine Adressen (31)

Frage von Maik82 zum Thema Linux Netzwerk ...

Exchange Server
gelöst Bestehende eMails autoamatisch weiterleiten (22)

Frage von metal-shot zum Thema Exchange Server ...

Apache Server
gelöst Lets Encrypt SSL mit Apache2 (20)

Frage von banane31 zum Thema Apache Server ...

Switche und Hubs
LAG zwischen SG300-Switches macht Probleme. Wer weiß Rat? (20)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...