Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Fehlermeldung bei Ausführung einer Batchdatei

Frage Entwicklung Batch & Shell

Mitglied: imebro

imebro (Level 2) - Jetzt verbinden

07.02.2008, aktualisiert 29.05.2008, 3690 Aufrufe, 7 Kommentare

Hallo an Alle,

bei folgender Batchdatei erhalte ich eine Fehlermeldung, obwohl eine ähnliche Batch mit fast gleichem Befehl (nur eben andere Verzeichnisangaben) einwandfrei funktioniert.

Hier die Batchdatei:
01.
@ECHO OFF 
02.
  
03.
ECHO Sicherung FOTOARCHIV 1>>D:\Daten\LOG\Sicherung_Fotoarchiv-LOG.txt 2>>&1 
04.
  
05.
ECHO SICHERUNG GESTARTET! 
06.
ECHO. 
07.
  
08.
xcopy "S:\ARCHIV\™A\Materialien für ™A\Fotoarchiv"\*.* G:\Fotoarchiv_Backup /S /D /E /Y /I /R 1>>D:\Daten\LOG\Sicherung_Fotoarchiv-LOG.txt 2>>&1 
09.
  
10.
ECHO. 
11.
ECHO Kopiervorgang beendet! 1>>D:\Daten\LOG\Sicherung_Fotoarchiv-LOG.txt 2>>&1 
12.
ECHO SICHERUNG FOTOARCHIV BEENDET! - Bitte Log-Datei einsehen (Sicherung_Fotoarchiv-LOG.txt) 
13.
start D:\Daten\LOG\Sicherung_Fotoarchiv-LOG.txt
Anschließend erscheint folgende Fehlermeldung in der Log-Datei:
01.
Sicherung FOTOARCHIV  
02.
Datei *.* nicht gefunden. 
03.
0 Datei(en) kopiert 
04.
Kopiervorgang beendet! 
Bereits versucht habe ich folgendes:
  1. Ich habe die Zeichen "*.*" auch schon vom letzten Backslash durch ein Leerzeichen getrennt... auch ohne Erfolg.
  2. Auch mit "robocopy" funktioniert es nicht.
  3. Auch habe ich schon das Verzeichnis "Materielien für ÖA" einfach in "Materialien" geändert, um zu vermeiden, dass Leerzeichen dazwischen sind... auch ohne Erfolg. Deshalb steht jetzt der komplette Pfad in Anführungsstrichen.

Übrigens steht hinter "S:\ARCHIV\" ein ASCII-Zeichen, da dort normalerweise ein "Ö" steht (und in der gleichen Zeile nochmal).

Wie oben bereits geschrieben, funktioniert es mit folgender Zeile in einer anderen Batchdatei einwandfrei:
01.
xcopy D:\Daten\DAS\*.* G:\Backup_Laufwerk_S /S /D /E /Y /I /R 1>>D:\Daten\LOG\Sicherung_S-LOG.txt 2>>&1
Hat jemand eine Idee, wieso die Batch so nicht funktioniert?

Danke & Gruss
Ingo
Mitglied: stbewo
07.02.2008 um 09:10 Uhr
Hallo Ingo,

mach mal dein " hinter *.*

Beispiel:
Fotoarchiv\*.*"

Gruß
Stefan
Bitte warten ..
Mitglied: 60730
07.02.2008 um 11:29 Uhr
Hi Ingo,

das liegt an den Sonderzeichen im Pfad...

Probier mal folgendes:

cd "S:\ARCHIV\?A\Materialien für ?A\Fotoarchiv"
s:
copy *.* G:\Fotoarchiv_Backup /S /D /E /Y /I /R 1>>D:\Daten\LOG\Sicherung_Fotoarchiv-LOG.txt 2>>&1

Ist nicht hübsch, aber bestimmt selten - Umlaute machen Umstände *gg*
Bitte warten ..
Mitglied: imebro
07.02.2008 um 13:51 Uhr
Hallo,

habe beide Möglichkeiten und etliche Varianten davon ausprobiert (also mit und ohne "" oder mit Ö, mit ? mit ASCII-Zeichen) - leider hat nichts funktioniert.

Jetzt erhalte ich folgende Fehlermeldung:

Sicherung FOTOARCHIV
Syntaxfehler.
Kopiervorgang beendet!

Hat noch jemand Ideen?

Gruss
Ingo
Bitte warten ..
Mitglied: 60730
07.02.2008 um 13:53 Uhr
Hallo,

habe beide Möglichkeiten und etliche
Varianten davon ausprobiert (also mit und
ohne "" oder mit Ö, mit ? mit
ASCII-Zeichen) - leider hat nichts
funktioniert.

Jetzt erhalte ich folgende Fehlermeldung:

> Sicherung FOTOARCHIV
> Syntaxfehler.
> Kopiervorgang beendet!

Hat noch jemand Ideen?

Gruss
Ingo

Upps...

da hab ich beim copy & paste ein x verschlampert...

Xcopy
Bitte warten ..
Mitglied: imebro
07.02.2008 um 16:21 Uhr
Jetzt erscheint:

Die Syntax für den Dateinamen, Verzeichnisnamen oder die Datenträgerbezeichnung ist falsch.

Hmmm....???
Bitte warten ..
Mitglied: 60730
07.02.2008 um 16:55 Uhr
Bei dir steht /R 1 drin????
Ob /S und /E beide drin sein müssen, sei dahingestellt.

Was deine "2>>&1" sollen, verstehe ich nicht, ohne die gehts (wie soll die Batch aufgerufen werden)

Gruß

Probier doch bitte mal das ganze da unten...


@ECHO OFF
@ECHO Sicherung FOTOARCHIV 1>>D:\Daten\LOG\Sicherung_Fotoarchiv-LOG.txt
@ECHO SICHERUNG GESTARTET!
ECHO.
cd "S:\ARCHIV\?A\Materialien für ?A\Fotoarchiv"
s:
xcopy *.* G:\Fotoarchiv_Backup /S /D /E /Y /I /R >>D:\Daten\LOG\Sicherung_Fotoarchiv-LOG.txt
ECHO.
@ECHO Kopiervorgang beendet! >>D:\Daten\LOG\Sicherung_Fotoarchiv-LOG.txt
@ECHO SICHERUNG FOTOARCHIV BEENDET! - Bitte Log-Datei einsehen (Sicherung_Fotoarchiv-LOG.txt)
start D:\Daten\LOG\Sicherung_Fotoarchiv-LOG.txt
Bitte warten ..
Mitglied: 56223
29.05.2008 um 08:08 Uhr
Hallo zusammen,

ich will nicht extra was neues Verfassen deshalb schreib ich mal mein Problem hier rein.

Ich hab folgendes vor:

Ich will ein Ordner unter C:\Dokumente~und~Einstellungen\All Users\Startmenue\Programme

ein Program Löschen.
Befehl:

rmdir /s /q C:\Dokumente~und~Einstellungen\All Users\Startmenue\Programme\gotomaxx

Fehlermeldung:

C:\Dokumente und Einstellungen\meinusername\Desktop>echo
ECHO ist eingeschaltet (ON).

C:\Dokumente und Einstellungen\meinusername\Desktop>rmdir /s /q C:\Dokumente~und~
instellungen\All Users\Startmenue\Programme\gotomaxx
Das System kann den angegebenen Pfad nicht finden.
Das System kann den angegebenen Pfad nicht finden.

C:\Dokumente und Einstellungen\meinusername\Desktop>PAUSE
Drücken Sie eine beliebige Taste . . .
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
Batchdatei auf einem Server ausführen mit psexec.exe (18)

Frage von imebro zum Thema Batch & Shell ...

Batch & Shell
gelöst Batchdatei für Aufgabenplanung zum Löschen von Backups (2)

Frage von Winuser zum Thema Batch & Shell ...

Batch & Shell
gelöst Hilfe bei der Erstellung einer Batchdatei (10)

Frage von peterhart zum Thema Batch & Shell ...

Neue Wissensbeiträge
Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

(2)

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Viren und Trojaner

CNC-Fräsen von MECANUMERIC werden (ggf.) mit Viren, Trojanern, Würmern ausgeliefert

(4)

Erfahrungsbericht von anteNope zum Thema Viren und Trojaner ...

Windows 10

Windows 10: Erste Anmeldung Animation deaktivieren

(3)

Anleitung von alemanne21 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Netzwerkprotokolle
Leiten "dumme" Switches VLAN-Tags mit durch? (23)

Frage von coltseavers zum Thema Netzwerkprotokolle ...

Windows Server
gelöst Neues KB für W10 1607 und W2K16 wieder mal nicht im WSUS 3.0, hat das noch jemand? (15)

Frage von departure69 zum Thema Windows Server ...

Batch & Shell
Batch zum suchen und verschieben von Verknüpfungen (12)

Frage von zeroblue2005 zum Thema Batch & Shell ...

Router & Routing
FTTH bzw FTTB Router (11)

Frage von ukulele-7 zum Thema Router & Routing ...