Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Fehlermeldungen beim Start von QMail

Frage Linux Suse

Mitglied: matsahm

matsahm (Level 1) - Jetzt verbinden

16.10.2012, aktualisiert 20:38 Uhr, 2387 Aufrufe, 4 Kommentare

Hallo Admins,

Ich habe Probleme mit QMail. Immer wenn ich qmail starte mit 'qmailctl start' erhalte ich in /var/log/messages folgende Fehler. Diese beiden Fehler wiederholen sich etwa sekündlich:
Oct 16 18:43:07 server svscan[1]: multilog: fatal: unable to lock directory /var/log/qmail/smtpd: temporary failure
Oct 16 18:43:07 server svscan[1]: tcpserver: fatal: unable to bind: address already used

Wie kann ich das beheben? Der Server ist mit SuSE Linux 12.2 64 Bit ausgestattet.


Gruß
Mathias Sahm
Mitglied: Deepsys
17.10.2012 um 12:04 Uhr
Moin,

Zitat von matsahm:
Oct 16 18:43:07 server svscan[1]: multilog: fatal: unable to lock directory /var/log/qmail/smtpd: temporary failure
= Das Verzeichnis konnte nicht gelocked werden

Oct 16 18:43:07 server svscan[1]: tcpserver: fatal: unable to bind: address already used
= Auf dem Port den QMail benutzen will, läuft schon wer ...

Kann es sein das sa noch ein anderer MTA (Postfix, sendmail, ....) läuft?
Solltest du unter den Prozessen (ps -afx) sehen...

VG
Deepsys
Bitte warten ..
Mitglied: matsahm
18.10.2012 um 09:17 Uhr
Hallo,

Vielen Dank erstmal. Ich konnte den Fehler damit nicht finden, bin aber trotzdem schon weiter.

Ich habe die Scripte auseinander genommen. Folgende Zeile funktioniert nicht mit dem qmaild-Benutzer. Als root hingegen schon. Wie kann ich das beheben?

/usr/local/bin/tcpserver -v -R -l "$LOCAL" -x /etc/tcp.smtp.cdb -c 20 -u 89 -g 89 0 smtp /usr/local/bin/spamdyke -f /etc/spamdyke.conf /usr/local/bin/recordio /var/qmail/bin/qmail-smtpd $LOCAL /home/vpopmail/bin/vchkpw /bin/true 2>&1


Gruß
Mathias Sahm
Bitte warten ..
Mitglied: AndiEoh
21.10.2012 um 22:03 Uhr
Hallo

ich kenne QMail eigentlich überhaupt nicht aber folgendes zum prüfen:

Das Belegen der Ports <1024 ist unter Unix üblicherweise nur mit "root" Rechten möglich. Deshalb werden z.B. viele Services (daemons) per (x)inetd oder ähnlichem gestartet. Eventuell ist dort bereits etwas eingetragen was Port 25 haben will. Desweiteren wie bereits von Deepsys angemerkt prüfen ob zusätzlich Postfix/Sendmail oder Exim installiert/aktiviert ist.

Gruß

Andi
Bitte warten ..
Mitglied: matsahm
22.10.2012 um 16:50 Uhr
Hallo,

Vielen Dank für die Hilfe. Das Problem ist behoben, nur nicht von mir. Ich kann nicht sagen, was es war.


Gruß
Mathias Sahm
Bitte warten ..
Ähnliche Inhalte
Outlook & Mail
Fehlermeldung in Outlook 2013 (5)

Frage von alpardac zum Thema Outlook & Mail ...

Windows Server
gelöst Fehlermeldung Gruppenrichtlinieneditor (1)

Frage von anak1m zum Thema Windows Server ...

Windows Server
gelöst Fehlermeldungen bei dcdiag (6)

Frage von Zippo97 zum Thema Windows Server ...

Neue Wissensbeiträge
Windows Installation

Unorthodoxer Weg, um an einen Offline-Installer für Adobe Flash zu kommen

(14)

Tipp von beidermachtvongreyscull zum Thema Windows Installation ...

Datenschutz

Gefährdeter Datenschutz: Firefox löscht lokale Datenbanken nicht

(1)

Information von BassFishFox zum Thema Datenschutz ...

Firewall

PfSense OpenVPN beschleunigen

Tipp von Dobby zum Thema Firewall ...

Heiß diskutierte Inhalte
Utilities
CCleaner 5.33 mit Malware infiziert (27)

Information von SeaStorm zum Thema Utilities ...

Windows Systemdateien
Windows bootet nicht mehr Fehlermeldung 0xc0000098 (19)

Frage von franzgoerlich zum Thema Windows Systemdateien ...

LAN, WAN, Wireless
gelöst 802.1X-Authentifizierung (17)

Frage von Alex29 zum Thema LAN, WAN, Wireless ...

Exchange Server
gelöst Proxy Server Settings Cloud + EWS (15)

Frage von SomebodyToLove zum Thema Exchange Server ...