Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Fenster öffnen sich nur im Hintergrund der Anwendung

Frage Microsoft Windows Server

Mitglied: vanTast

vanTast (Level 1) - Jetzt verbinden

13.09.2012 um 15:38 Uhr, 6990 Aufrufe, 2 Kommentare

Moin,

nachdem wir unseren TS W2003R2 gegen einen neuen mit W2008R2 (beides über Hyper-V)getauscht haben stellt sich folgendes Problem:
Sobald sich der User am TS anmeldet öffnet sich unser Warenwirtschaftssystem. Hier haben wir die Möglichkeit Daten an Excel zu übergeben. Dies geschieht auch, jedoch öffnet sich das Excel-Fenster im Gegensatz zum alten Server nur im Hintergrund. Der User denkt also zunächst, es hätte nicht funktioniert und versucht es erneut.
Auch die Windows Fehlermeldungen öffnen sich nur im Hintergrund.
Das ist natürlich blöd, weil der User die Fehlermeldung nicht mitbekommt. Dass er auf Excel zugreifen kann, in dem er das Anwendungsfenster der Warenwirtschaft minimiert weiss der User mittlerweile.
Der Hersteller des Warenwirtschaftssystems ist ratlos, aber ich vermute auch dass der Fehler irgendwo im Windows vergraben ist.
Was könnte dazu führen, dass das Fenster der Warenwirtschaft immer im Vordergrund läuft?
Wir haben schon den Key HKCU/Control Panel/Desktop/ForegroundLockTimeOut auf 0 gesetzt (eingestellt war 20000),
hat aber nichts gebracht. Der Hersteller des Warenwirtschaftssystems meint, beim der Wert sollte 0 sein.
MS empfiehlt für Foreground Lock Timeout den Wert 20000 und für ForegroundFlashCount den Wert 3.
Letzterer ist auch so eingestellt.

Hat noch jemand eine Idee woran es liegen könnte?

Besten Dank im Voraus.

Gruss vanTast
Mitglied: goscho
13.09.2012 um 15:56 Uhr
Hallo vanTast,
ich kenne dein Problem (nicht nur auf dem TS sondern auch auf vielen PCs.
Es handelte sich dabei auch immer im Warenwirtschaftssysteme, die diese Probleme verursacht haben.
Mir ist kein Fall bekannt, wo das nicht durch ein Bugfix des jeweiligen Herstellers gelöst wurde.

Ist das Problem auf den TS beschränkt?
Gab es mit der Umstellung auf W2K8 eine neuere Version des WWS?
Sorry, dass ich dir sonst nicht weiterhelfen konnte.

Gruß Goscho
Bitte warten ..
Mitglied: vanTast
13.09.2012 um 16:14 Uhr
Moin Goscho,

sorry, hab vergessen zu erwähnen dass das Problem bei Clients, die das WWS lokal auf dem Rechner haben, nicht auftritt. Es tritt also nur bei den TS-Usern auf.
Würde mich ja mal brennend interessieren wie das Bugfix aussieht, denn die Aussage vom Hersteller unseres WWS ist, man kenne das Problem nicht.
Ich habe jetzt mal ein paar Versuche unternommen und werde den TS heute abend mal durchstarten.
Die genannten Keys sollen ja beeinflussen wie oft das Symbol in der Taskleiste (die ja für die TS-User nicht sichtbar ist) blinkt und wie lange das Programm im Hintergrund zurückgehalten wird.
Also Standard scheint zu sein 3 x blinken und dann 20s warten, was ich für deutlich zu lange ansehe.
Kurioserweise hat es mit diesen Werten unter W2003 funktioniert, wobei es da keine 20s gedauert hat.

Gruss vanTast
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
Windows XP
WordPad zeigt beim Öffnen keine RTF-Dateien mehr an (1)

Frage von Sinzal zum Thema Windows XP ...

Windows Server
Sharepoint - öffnen im Windows Explorer geht nicht (5)

Frage von DerWoWusste zum Thema Windows Server ...

HTML
HTML, CSS: Mapping auf dynamischen Hintergrund (2)

Frage von Judo99 zum Thema HTML ...

Linux
gelöst Schmaler Scrollbalken in Python-Anwendung (14)

Frage von indi955 zum Thema Linux ...

Heiß diskutierte Inhalte
CPU, RAM, Mainboards
Kaufberatung für mind. 8 verschiedene HighEnd-Mainboards (23)

Frage von yperiu zum Thema CPU, RAM, Mainboards ...

Mac OS X
Mac kann nicht im LAN pingen alle anderen schon (19)

Frage von smartino zum Thema Mac OS X ...

Hardware
gelöst PCI-Express-Adapterfrage (14)

Frage von DerWoWusste zum Thema Hardware ...

Linux Netzwerk
DHCP IP-vergabe erst nach 1-2 Minuten (11)

Frage von Maik82 zum Thema Linux Netzwerk ...