Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Fernwartung mit DynDNS

Frage Netzwerke LAN, WAN, Wireless

Mitglied: edvmaedchenfueralles

edvmaedchenfueralles (Level 1) - Jetzt verbinden

22.07.2008, aktualisiert 24.07.2008, 8677 Aufrufe, 10 Kommentare

Hallo Leute!
Habe Zuhause folgende Konstellation:

9a5f437afd5a137cd445e3c509af7066-konstellation - Klicke auf das Bild, um es zu vergrößern

Möchte nun eine Fernwartung mittels Remote Desktop übers Internet (mit DynDNS-Name) auf den „Server“ (WinXP-Prof. SP3) 192.168.1.10 realisieren!
Um das hin zu kriegen, müsste es doch reichen, das Port 3389 in der Firewall freizuschalten und das Port-Forwarding folgendermaßen einzutragen:
Auf Speedtouch: Port 3389 auf 10.0.0.140 (WLAN-Router) weiterleiten und vom WLAN-Router auf 192.168.1.10!
Hab ich da einen Denkfehler, oder warum funktioniert das so nicht?
Mitglied: Arch-Stanton
22.07.2008 um 11:22 Uhr
Moin,

ich würde an der Einfachheit arbeiten und den Speedport zum Modem mit PPOE-passthrough degradieren, so daß der Netgear-Router für den Internetaufbau zuständig ist.

Gruß, Arch Stanton
Bitte warten ..
Mitglied: tacker
22.07.2008 um 11:29 Uhr
salü edvmädchenfürales

entweder du machst es so wie arch-stanton dir rät oder ansonsten könntest du auf dem speedtouch direkt die portweiterleitung auf die End-IP 192.168.1.10 leiten - dafür musst du beim speedtouch router jedoch noch eine statische route eintragen, damit dieser weiss, hinter welchem router sich das netz 192.168.1.0 befindet! diese würde dann wie folgt aussehen:

Netz: 192.168.1.0 Subnetmaske: 255.255.255.0 Gateway: 192.168.0.140

gruss tacker
Bitte warten ..
Mitglied: edvmaedchenfueralles
22.07.2008 um 11:53 Uhr
Danke für die schnellen Antworten! Werde jedenfalls beides probieren!

Kann mir jemand erklären, warum das so nicht funktioniert, wie ich es mir gedacht habe?
Gibts da Probleme mit dem Port-Forwading zu einem anderen Router?

Danke!
Bitte warten ..
Mitglied: aqui
22.07.2008 um 12:49 Uhr
@tacker
Diese Route ist kompletter Unsinn, denn ein Netzwerk 192.168.0.0 /24 gibt es gar nicht in seinem Netz !! Das Bild zeigt das eindeutig und es empfiehlt sich vor dem Tippen nachzudenken !
Am Speedtouch ist lokal ein 10er Netz dran ! Wenn, dann muss die Route richtig lauten:

Netz: 192.168.1.0 Subnetmaske: 255.255.255.0 Gateway: 10.0.0.140

So oder so ist sie aber auch vollkommen überflüssig, denn edvmädch.. macht auf dem NetGear NAT. Er maskiert also sein gesamtes WLAN auf die LAN IP Adresse 10.0.0.140.
Das WLAN Netzwerk 192.168.1.0 taucht also gar nicht mehr im 10er Netz auf sondern alle Packete aus diesem Netz werden geNATtet auf die 10.0.0.140 und tauchen deshalb NUR mit dieser IP auf.
Das ist gewissermaßen eine "DMZ des kleinen Mannes" wie sie auch hier beschrieben ist:
http://www.heise.de/netze/DMZ-selbst-gebaut--/artikel/78397

In der Beziehung ist die Route ziemlich sinnlos, denn der Speedtouch weiss deshalb gar nicht das sich hinter der 10.0.0.140 ein anderes Netz verbirgt.

Eigentlich müsste die dopplete Port Weiterleitung funktionieren ! Der Speedtouch sollte TCP 3389 (RDP) lokal auf die 10.0.0.140 weiterleiten und der NetGear dann lokal auf die 192.168.1.10.
Es ist aber möglich das das an einer MTU Problematik scheitert oder an der fehlerhaften Implementation der Port Weiterleitung.

Das kannst du aber ganz einfach mal prüfen:
Hänge einen PC mit einem Packet Sniffer in das 10.0.0.0er Netz und prüfe einmal ob der Speetouch diese eingehenden Packete wirklich lokal in das Netz weiterreicht !!
Irgendeiner deine Router macht das vermutlich nicht.
Als Sniffer verwendest du den
www.wireshark.org
oder den MS Net Monitor:
http://www.microsoft.com/downloads/details.aspx?FamilyID=18b1d59d-f4d8- ...

Um dir aber das Leben nicht schwer zu machen und wenn du diese DMZ Lösung im WLAN nicht wirklich unbedingt benötigst aus Sicherheitsgründen, dann mache den NetGear Router einfach zum dummen WLAN Accesspoint und gut is....!
Wie das geht wird in diesem Tutorial in der Alternative 3 genau beschrieben:

http://www.administrator.de/Kopplung_von_2_Routern_am_DSL_Port.html

Dann hast du die NAT Problematik nicht mehr und arbeitest transparent im 10.0.0.0 /24 er Netzwerk und dann reicht ein einfaches Port Forwarding von TCP 3389 auf das WLAN Endgerät dann in diesem Netz um RDP problemlos zum Laufen zu bringen !!!
Bitte warten ..
Mitglied: edvmaedchenfueralles
22.07.2008 um 17:12 Uhr
danke, danke!
mir ist gerade selbst (beim betrachten meiner Skizze) eingefallen, dass es vieleicht ratsam wäre, da der XP-"Server" (192.168.1.10) später eventuell auch FTP-Server spielen soll, diesen gleich ins 10.0.0.0 - Netz zu hängen!
Dann ist er vom Heim-LAN (192.168.1.0 Netz) getrennt und durch eine weiter Firewall abgeschottet (Netgear WLAN Router) (= das ist dann die DMZ, oder?).
Und das Problem mit dem Remote Desktop hab ich auch nicht mehr (Anfragen ans Port 3389 an den "Server" im 10.0.0.0 Netz weiterleiten).

So könnte es doch auch gehen, oder?
Bitte warten ..
Mitglied: aqui
22.07.2008 um 20:49 Uhr
So wird es sogar ganz sicher gehen wenn du den NetGear nach dem o.a. Turorial als AP installierst
Bitte warten ..
Mitglied: edvmaedchenfueralles
22.07.2008 um 23:00 Uhr
warum muss ich den netgear trotzdem als ap installieren? ich komme dann doch auch vom 192er netz ins 10er netz, oder?

und das port-forwarding für das rdp mach ich ja vom speedtouch direkt zum server (sind ja dann beide im 10er netz)
ich häng den server im prinzip auf den speedtouch mit z.b. der IP 10.0.0.110

versteh ich das jetzt falsch? verwirrung macht sich breit...

danke
Bitte warten ..
Mitglied: aqui
23.07.2008 um 09:01 Uhr
Nein, das kommst du nicht ?? Wie soll das gehen, das sind 2 unterschiedliche IP Netze !! Ausserdem schreibst du nicht ob dein PC nur per WLAN erreichbar ist oder nicht.
Wenn du kein WLAN benötigst und ein Kabel nutzen kanns, dann brauchst du den NetGear gar nicht mehr...das ist klar.

Deine Zeichnung lässt nur vermuten, das der PC nur per WLAN angebunden ist und der Router selber kein WLAN hat....

Deine Alternativen sähen dann so aus:

8a9cc2b4d18d0adb31068a673d579c15-serverwlan - Klicke auf das Bild, um es zu vergrößern

Das 192.168er Netz kommt in so einem Szenario gar nicht mehr vor wenn der NetGear als reiner AP läuft !
Natürlich bist du nicht gezwungen den PC per WLAN anzubinden, eine Kabelverbindung klappt natürlich auch !
Im hellblauen Kreis siehst du die WLAN Alternative. Alles ohne Kreis ist die Kabellösung !!
Bitte warten ..
Mitglied: edvmaedchenfueralles
23.07.2008 um 16:01 Uhr
Danke!
Ich glaub, jetzt hab ich's!
Ich werds jedenfalls probieren und dann hier berichten!

Wie sicher ist eigentlich die direkte Verbindung mit RDP?
Hab ja in meiner Konstellation nicht wirklich die Möglichkeit zuerst ein VPN aufzubauen, oder?
Welche Sicherheitsvorkehrungen sollte ich noch treffen?

Mit freundlichen Grüßen
Bitte warten ..
Mitglied: aqui
24.07.2008 um 16:37 Uhr
Ein Problem natürlich der dann offene RDP Zugang. Ggf. macht es Sinn diesen Zugang etwas zu verscheiern indem du dem RDP auf dem Server einen anderen TCP Port zuweist. Das hilft Scanner usw. in die Irre zu führen, da diese meist nur die default Ports scannen

Das Anpassen des RDP Zielports geht über die Registry mit
Start -> Ausführen regedit im Wert HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp wo du dann im Wert PortNumber einfach den TCP Port einträgst.
Z.B. TCP 53389 statt des Default Werts 3389.

Wenn du nun den Client aufmachst dann gibst du als Ziel an name.dyndns.org:53389 Also immer den Port mit :53389 übergeben. So kannst du einigermassen sicher sein das nicht jeder Script Kiddie dir die Maschine kompromitiert

Das Port Forwarding musst du dann natürlich entsprechend auf diesen neuen TCP Port anpassen !!
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Router & Routing
gelöst Zwei DSL Leitungen, Zwei Fritzboxen, Zwei Dyndns Accounts - Portweiterleitung klappt nicht (4)

Frage von caravandriver zum Thema Router & Routing ...

Internet
gelöst Strato MX eintrag DYNDNS (5)

Frage von bootloader zum Thema Internet ...

Internet Domänen
gelöst Dyndns mit Strato und DrayTek Vigor2925 (6)

Frage von itsk-robert zum Thema Internet Domänen ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...