Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Fiber Channel HBA im Loop oder Point-To-Point Modus

Frage Hardware Festplatten, SSD, Raid

Mitglied: 43292

43292 (Level 1)

05.12.2011 um 19:22 Uhr, 5880 Aufrufe, 11 Kommentare

Hallo community,

ich habe einen Host, in welchem eine QLA2342 FC HBA Karte verbaut ist. Diese ist mit einer SAN verbunden. Die Verbindung ist ok, alles läuft soweit. In den BIOS-Einstellungen der Qlogic-Karte gibt es unter "Connection Option" folgende Einstellmöglichkeit:

Integer Type Mode
Range 0–2:
0 = loop only
1 = point-to-point only (QLA22xx/QLA23xx only)
2 = loop preferred, else point-to-point (QLA22xx/QLA23xx only)
Default 2
Description This parameter specifies the connection mode used by the driver
firmware. When connecting the QLogic HBA to a switch port with automode
sensing capability (a G port), QLogic recommends that this
parameter be set to 0 or 1, not 2. Setting this parameter to 2 when
connected to a G port on a switch may cause the device to be lost or the
system to hang.

Ich habe auf Wikipedia gelesen, dass der Loop-Modus einen Bus darstellt, innerhalb dessen die Bandbreite zwischen den Teilnehmern aufgeteilt wird. Dies würde ich natürlich vermeiden wollen. Meine SAN ist an zwei Servern angeschlossen, denn sie hat zwei unabhängige Ports hierfür. Deshalb würde ich es gerne so einstellen, dass eine Punkt-Zu-Punkt-Verbindung zur SAN stattfindet. Wenn ich nun aber in der Qlogic-BIOS-Einstellung auf "1" gehe (point-2-point only) dann findet der DEVICE LOOP SCAN natürlich meine SAN nicht. Müsste ich nicht irgendwie meiner Qlogic-Karte sagen können, welche WWN er kontaktieren soll für seine Point2Point Verbindung? Auf meiner SAN kann ich zwei "Initiator Mode" auswählen. Endweder lunmapped, oder auto. Momentan ist lunmapped aktiv.

Wie müsste ich das richtigerweise angehen?
Mitglied: Anton28
06.12.2011 um 08:46 Uhr
Guten Morgen SloopGER,

was bitte ist eine SAN ???

SAN steht in diesem Zusammenhang für Storage Area Network.

LOOP bedeutet alles Teilnehmer dieses Speichernetze hängen an einer Schleife.

Point-to-Point meint nicht anderes, als dass eine FC-Switch oder Director mit beteiligt ist.

Mal wieder eine kleine nervige Bitte von Mir.

Mach eine Skizze, wie was miteinander verbunden ist, dann wissen alle die Dir helfen sollen von was gesprochen wird.

Aus Deinen dürren Beschreibungen geht nicht hervor was in Deinem Sprech eine SAN ist ?

EMC Specihersilo ?
EVA-Specihersilo ?
NAS-Büchse ?
DELL- ???


Gruß

Anton
Bitte warten ..
Mitglied: 43292
06.12.2011 um 09:49 Uhr
Morgen Anton,

meine SAN ist eine IBM DS400, also ein Festplattenverbund mit SAS-Festplatten. Dieses managebare Komplettsystem hat hinten zwei FC-Ports. An diesen zwei Ports sind ganz einfach ServerA und ServerB angeschlossen. Somit sind meine zwei Server mit dieser DS400 verbunden. Den Grund, warum ich nach nach der FC-AL und FC-SW gefragt habe, habe ich ja bereits gepostet. Ich habe keinen Switch dazwischengeschaltet. Aber der Director könnte ja in diesem Zusammenhang die SAN selbst sein? Ich konnte leider auch keine Infos finden, was der Befehl auf der DS400 genau bewirkt.

Ich kann "initiator mode lunmapped" oder "initiator mode auto" wählen. Momentan war lunmapped ausgewählt, und ich schätze mal dass alles im Loop-Modus funktionierte. Was würde 'auto' bedeuten?
Bitte warten ..
Mitglied: Anton28
06.12.2011 um 09:57 Uhr
Guten Morgen SloopGer,

Wenn ich Dich richtig verstehe, hängen die Server mit je einem Port direkt an der DS400. Das würde ich dann als Point-2-Point bezeichnen wollen. Oder handelt es sich um ein BladeCenter mit 2 Blades ?
Ich denke mal, das System wurde durch ein Systemhaus geliefert und installiert.
Was hindert Dich daran, dem Systemhaus Deine Fragen zu stellen ?
Oder noch besser:
Geh auf die IBM-Seite im Web, suche nach Redbooks und dort dann nach DS400.
In der Regel findest Du dort sehr gute Beschreibungen, die in einem klar verständlichem Englisch geschrieben sind.

Gruß

Anton

PS:

Hast Du Probleme mit dem Durchsatz des Systems, oder warum fragst Du ?
Was läuft auf den Servern ?
Bitte warten ..
Mitglied: 43292
06.12.2011 um 10:09 Uhr
Och Anton, bei allem Respekt. Aber meinst du ich hätte das nicht vorher schon erledigt? Ich möchte nochmals auf deine Fragen eingehen, die leider meine Frage auch nicht beantwortet.

a) Nein, es handelt sich nicht um BladeCenter mit 2 Blades, ich wüßte auch nicht wie du darauf kommst
b) Nein, es wurde nicht durch ein Systemhaus geliefert und installiert.
c.) Siehe b!
d.) Auf Redbooks habe ich die PDF downgeloadet. Auf Seite 613 ist der springende Punkt. Und wie es der Zufall so will, da steht absolut GAR NICHTS über diesen Modus. Es steht lediglich auf Seite 613, dass hier der mode eingestellt werden kann. Keine detaillierten Infos, was überhaupt da angestellt wird.
e.) Hast du meine Ursprungsfrage überhaupt gelesen oder antwortest du wild darauf los?

Bitte gehe auf die Frage ein, wenn du helfen kannst. Deine Antworten helfen mir kein bisschen weiter, sorry. Trotzdem danke für deine Bemühungen.
Bitte warten ..
Mitglied: Anton28
06.12.2011 um 10:45 Uhr
Hallo,

wenn Du nicht dazu schreibst, was Du bisher unternommen hast, brauchst Du Dich über Fragen nicht zu wundern.

Wenn mann keine Fragen stellen darf, dann lass ich es eben.

Gruß

Anton
Bitte warten ..
Mitglied: 43292
06.12.2011 um 10:51 Uhr
Meine Fragen stehen deutlich im Ursprungspost. Du frägst mich was auf den Servern läuft. Was um alles in der Welt spielt es für eine Rolle, WAS auf den Servern läuft? Das hat absolut nichts mit der Fragestellung zu tun und hilft auch kein bisschen weiter. Meine Fragen beziehen sich doch ganz deutlich auf diesen Loop-, bzw. P2P-Modus. Ich würde gerne wissen, wie richtigerweise eine P2P-Verbindung hergestellt wird. In der QLogic HBA-Karte habe ich das ja bereits explizit ausgewählt. Wie sieht die richtige Vorgehensweise eine P2P-Verbindung aus, müssen da nicht die Punkt-Zu-Verbindungen explizit als eindeutige ID (z.B. durch die WWN) angegeben werden?

Wenn du helfen kannst, gerne. Dafür bin ich jedem -auch dir- sehr dankbar! Wenn nicht, lass es bitte, es kostet nur dir und mir Zeit, und hilft keinem weiter.
Bitte warten ..
Mitglied: Anton28
06.12.2011 um 11:09 Uhr
Hallo nochmal,

also lt. Deiner Beschreibung hast Du nur eine Loop.

Also brauchts Du nichts umzustellen.

Und nein, Deine DS400 ist keine Direktor und wird auch nie einer sein.

Gruß

Anton
Bitte warten ..
Mitglied: 43292
06.12.2011 um 11:54 Uhr
Ok. Aber kann ich -und wenn ja WIE?- auf Point-to-Point umstellen, ohne den Einsatz eines Switches?
Bitte warten ..
Mitglied: Anton28
06.12.2011 um 12:04 Uhr
Hallo SloopGER,

was soll Dir das bringen ?

Nach Deiner Beschreibung hast Du nur 2 Server, die Du an je einen Port der DS400 angeschlossen hast.

Dabei ist es reichlich egal, ob Loop oder Point-2-Point.

Gruß

Anton
Bitte warten ..
Mitglied: 43292
06.12.2011 um 12:05 Uhr
Es bringt mir was, indem ich dazulerne. Ob es egal ist und angebracht ist in meinem Szenario, das lass mal dann bitte meine Sorge sein. Wenn ich dich als Berater erwünschen würde, dann hätte ich dich explizit darauf angesprochen. Hier geht es um eine andere Frage, und zwar "Wie würde das gehen, kann ich in diesem Setup eine P2P-Verbindung herstellen?" und nicht ob es "deiner Meinung nach SINNVOLL wäre oder nicht" !
Bitte warten ..
Mitglied: 43292
09.12.2011 um 10:26 Uhr
Ich habs das jetzt endlich gelöst und erfolgreich eine Point-To-Point-Verbindung herstellen können. Anbei noch eine Info an Interessierte, die evtl. vor dem ähnlichen Problem stehen und. Das Problem war meine SAN. Dort lag eine ältere Firmware vor, die mir nicht erlaubte einen anderen als "Loop" Modus zu wählen. Nachdem die neue Firmware eingespielt wurde, konnte ich den Modus jedes einzelnen Ports abändern. Defaultmässig wird natürlich der Loop-Modus verwendet, er ist also als FL_port konfiguriert. (http://www.itwissen.info/definition/lexikon/FL-Port-fabric-loop-port.ht ...)

. Ich habe also den Port der SAN umkonfiguriert, und als Topologie "F_port" gewählt. (http://www.itwissen.info/definition/lexikon/F-Port-fabric-port.html). Selbstverständlich muss man die HBA FC Card auch entsprechend konfigurieren und ihr sagne, dass sie P2P verwenden sollte. Die Loop IDs und sonstige Loop-Einstellungen sind daher wirkungslos.

Problem daher als gelöst markiert.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
LAN, WAN, Wireless
gelöst Zweiter Access Point welcher Modus ? (3)

Frage von satfun22 zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
Access Point: Ubiquiti UAP AC PRO Einschätzung Reichweite (4)

Frage von TimMayer zum Thema LAN, WAN, Wireless ...

Linux
UCS 4.1-4: Viertes Point-Release veröffentlicht

Link von Marenaba zum Thema Linux ...

Router & Routing
Zyxel Support, Zyxel W-Lan Access Point NWA1100-NH (2)

Erfahrungsbericht von ThomasBIT zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...