Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

find befehl geht nicht so wie er soll

Frage Entwicklung Batch & Shell

Mitglied: JohnCoffey

JohnCoffey (Level 1) - Jetzt verbinden

10.03.2009, aktualisiert 18:28 Uhr, 4171 Aufrufe, 3 Kommentare

hallo,

ich habe mir zuHause ein kleines batch Programm zusammengeschrieben, dass auch wunderbar funktioniert
nun habe ich dieses Programm auf einen anderen PC gepackt und versucht es dort auszuführen
auf beiden PCs sind die gleichen Windows Versionen
also wenn ich cmd starte steht beide Male dort: Microsoft Windows XP [Version 5.1.2600] und beide PCs haben SP3
beim Ausführen meines Programms ist dann auf jeden Fall nicht viel passiert, also hab ich mir mal Gedanken gemacht woran das liegt und
habe dann recht schnell rausgefunden, dass es am find Befehl liegen muss
wenn ich auf dem PC auf dem es nicht läuft nämlich help find oder find /? oder was auch immer mit find eingebe, kommt folgende Meldung:
"find: '/?': No such file or directory"
Kann das daran liegen, dass ich vielleicht aus versehen eine bestimmte Einstellung gesetzt habe und das darum nicht mehr geht?
Wenn ja kann ich irgendwie auf die Standart Einstellungen zurück kommen?
Oder kann es sein dass ich vielleicht eine andere DOS Version auf diesem PC habe?
Ich kenne mich da leider nicht so genau aus und wäre froh wenn mir jemand helfen kann
Auf dem PC auf dem ich es programmiert habe kam bei Eingabe von help find auf jeden Fall die ganz normale Hilfe

mfg JohnCoffey
Mitglied: GuentherH
10.03.2009 um 18:35 Uhr
Hallo.

- überprüfe, ob find.exe überhaupt vorhanden ist. Sollte in Windows\system32 sein.
- wenn ja, dann stimmt der Pfad für die Umgebungsvariablen (Systemvariablen) nicht

LG Günther
Bitte warten ..
Mitglied: 60730
10.03.2009 um 18:37 Uhr
Servus,

dir %windir%\find.* /s

Wenn da nicht "windows\system32" aufgezählt wird - hat "irgenjemand" Find "irgendwohin" / Mülleiner? geschoben.
No such file or directory"
bedeutet im klartext - keine datei / Verzeichnis mit dem Namen "find" gefunden.

Gruß
edit - zu lansaaaaaam /edit
Bitte warten ..
Mitglied: JohnCoffey
10.03.2009 um 18:48 Uhr
ich habe gerade danach gesucht und die Datei ist vorhanden

@Guenther H
wo du grade Umgebungsvariablen geschrieben hast, da hatte ich einen Geistesblitz
und zwar habe ich mal irgendwann im Rahmen der Installation von cygwin (wenn das einem was sagt) die Systemvariable path etwas abgeändert und die Änderung habe ich gerade rückgängig gemacht und siehe da es geht wieder

danke für die schnellen Antworten
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
gelöst Mehrzeiligen Powershell-Befehl mit Batch ausführen (3)

Frage von 133202 zum Thema Batch & Shell ...

Windows Netzwerk
gelöst Copy Befehl in einer batch funktioniert nicht. (3)

Frage von Pauli-H zum Thema Windows Netzwerk ...

Batch & Shell
gelöst Batch Syntaxfehler, aber finde ihn nicht :( (5)

Frage von PinkFLuffyUnicorn zum Thema Batch & Shell ...

RedHat, CentOS, Fedora
Linuxbefehl - resizepart - wofür verwendet man diesen Befehl (8)

Frage von mic.we zum Thema RedHat, CentOS, Fedora ...

Neue Wissensbeiträge
Windows Update

Novemberpatches und Nadeldrucker bereiten Kopfschmerzen

(14)

Tipp von MettGurke zum Thema Windows Update ...

Windows 10

Abhilfe für Abstürze von CDPUsersvc auf Win10 1607 und 2016 1607

(7)

Tipp von DerWoWusste zum Thema Windows 10 ...

RedHat, CentOS, Fedora

Fedora 27 ist verfügbar

Information von Frank zum Thema RedHat, CentOS, Fedora ...

Heiß diskutierte Inhalte
Server
Bilder aus dem Web mit CSV runterladen (30)

Frage von Yannosch zum Thema Server ...

LAN, WAN, Wireless
Gebäudeverkabelung 10Gigabit LWL (28)

Frage von raffzwo zum Thema LAN, WAN, Wireless ...

Windows Update
Novemberpatches und Nadeldrucker bereiten Kopfschmerzen (14)

Tipp von MettGurke zum Thema Windows Update ...