Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Ich find den OpenVPN Wurm nicht, bitte um Hilfe

Frage Netzwerke Router & Routing

Mitglied: panguu

panguu (Level 2) - Jetzt verbinden

09.08.2012 um 11:27 Uhr, 2690 Aufrufe, 5 Kommentare

Hallo Leute,

ich such schon etliche Zeit nach dem Fehler, kann ich aber wirklich nicht finden. Vielleicht habt ihr einen Tip für mich? Folgendes Szenario:

zwei Linksys-WRT54 mit OpenWRT sollen zwei Standorte über VPN (durch Internet) verbinden. Ich hab schon mehrere solche Configs installiert, aber momentan sitz ich grad auf dem Schlauch.

Die SiteA ist das 192.168.1.0/24 Netz
/etc/openvpn/zusiteB.conf:
dev tun
remote siteB-example.dyndns.org
ifconfig 10.60.68.238 10.60.68.237
tun-mtu 1400
up /etc/openvpn/zusiteB.up
secret mein.key
port 1193
user nobody
comp-lzo
ping 8
ping-restart 20
ping-timer-rem
persist-tun
persist-key

/etc/openvpn/zusiteB.up:
#!/bin/sh
route add -net 192.168.1.0 netmask 255.255.255.0 tun0
iptables -A FORWARD -p all -s 10.60.68.237 -j ACCEPT
iptables -A FORWARD -p all -d 192.168.1.0/24 -j ACCEPT
exit 0


Die SiteB ist das 10.4.40.0/24 Netz und sieht so aus
/etc/openvpn/zusiteA.conf:
dev tun
ifconfig 10.60.68.237 10.60.68.238
tun-mtu 1400
up /etc/openvpn/zusiteA.up
secret mein.key
port 1193
user nobody
com-lzo
ping 8
ping-restart 20
ping-timer-rem
persist-tun
persist-key

/etc/openvpn/zusiteA.up:
#!/bin/sh
route add -net 10.4.40.0 netmask 255.255.255.0 tun0
iptables -A FORWARD -p all -s 10.60.68.237 -j ACCEPT
iptables -A FORWARD -p all -d 10.3.39.0/24 -j ACCEPT
exit 0


Ich logg mich auf beiden Linksys-WRT54 über SSH ein. Ich kann von einem auf den andren Pingen, weil der Tunnel steht. Also Pings auf 10.60.68.237 und 10.60.68.238 vice-versa funktionieren einwandfrei. Der Tunnel steht definitv. Irgendwie scheints aber noch mit dem Weiterleiten ins 'normale' Netz zu hängen? "route -n" zeigt mir jedoch die Routing Tables korrekt an, auf beiden Geräten. Nichts ungewöhnliches also. Auch Firewalleinträge habe ich evtl. überprüft, das kanns aber alles nicht sein, denn:

das Ganze funktionierte bis ich dem Internetrouter und WRT54-Router auf SiteA abgeänderte. Das frühere Netz lautete 192.168.178.0/24 (typisches Fritz-Subnet) und ich änderte es ab auf 10.4.40.0/24 und habe eigentlich alle Anpassungen durchgeführt. Es muss also sehr wahrscheinlich damit zusammenhängen. Jedoch habe ich alles durchsucht und nix finden können. Wahrscheinlich hab ich 'ne Kleinigkeit übersehen und seh vor lauter Bäumen den Wald nicht Hoffe ihr könnt helfen. Merci
Mitglied: thaenhusen
09.08.2012 um 12:25 Uhr
Moin.

In /etc/openvpn/zusiteA.up

müsste das nicht

iptables -A FORWARD -p all -d 10.4.40.0/24 -j ACCEPT

statt

iptables -A FORWARD -p all -d 10.3.39.0/24 -j ACCEPT

heissen?

HTH
MK
Bitte warten ..
Mitglied: panguu
09.08.2012 um 14:55 Uhr
ja, das war aber ein Tippfehler von mir, da ich es abgeschrieben habe von nem andren Rechner/Monitor trotzdem danke für den Hinweis. Es stimmt also so. Any other ideas?
Bitte warten ..
Mitglied: panguu
09.08.2012 um 15:04 Uhr
Na da schau her, hab grad zum Test 'nen Ping abgesetzt und jetzt funktionierts !!! ??? Häää? Ich werd nicht schlau draus. Hab absolut NICHTS umgestellt seit dem letzten Posting. Woran könnte das gelegen haben? *dummguck*
Bitte warten ..
Mitglied: panguu
09.08.2012, aktualisiert um 16:09 Uhr
Also ich habs jetzt, es war die Firewalleinstellung. Heute Mittag schon hatte ich in der /etc/firewall.user weiter aufgeschraubt, aber nicht gleich im Anschluss getestet. Deswegen wunderte es mich, warum es plötzlich ging. Ich hab in beiden .up Scripts die gleiche IP aus Versehen drin gehabt. Es muss natürlich einmal die 10.60.68.237 und beim andren Endpunkt die 10.60.68.238 sein, ich habte bei beiden .237 stehen

Damit es aber funktioniert, habe ich die zwei Zeilen aus beiden Up-Scripts entfernt. Stattdessen habe ich in der /etc/firewall.user verwendet:

  1. Damit vom internen LAN interface auf das OpenVPN-Interface weitergeleitet werden darf (ausgehend)
iptables -A FORWARD -i br0 -o tun0 -j ACCEPT

  1. Damit die auf dem OpenVPN Tunnel-Interface eingehenden Pakete auf das LAN weitergeleitet werden dürfen (eingehend)
iptables -A FORWARD -i tun0 -o br0 -j ACCEPT


Wenn ich direkt von den zwei Linksys WRT54 einen Ping auf entfernte Hosts absetze im gegenüberliegenden Netz, krieg ich keine Antwort. Mache ich es jedoch von anderen normalen Hosts, dann funktioniert das bidirektional. Wieso können die VPN-Router selbst keine dahinterliegenden Hosts erreichen? Muss ich für die eine extra Firewall-Regel bilden ?
Bitte warten ..
Mitglied: aqui
10.08.2012, aktualisiert um 11:14 Uhr
Die Route ist eigentlich überflüssig, denn die kannst du automatisch mit einem "push route..." Kommando in der OVPN Konfig erledigen und ist einfacher.
Das OVPN Tutorial hier erklärt das eigentlich recht einfach:
http://www.administrator.de/contentid/123285
Ebenso das Troubleshooting...
Das du hinter dem Router liegende Hosts nicht erreichen kannst liegt evtl. daran das die nicht die OVPN Router als Default Gateway eingetragen haben sondern ein anderes gateway !
Dann musst du dort eine statische Route auf das OVPN Netz bzw. das Zielnetz einrichten, dann klappt das auch !
Zusätzlich musst du beachten das ggf. die lokale Firewall sowas blockt, da du ja aus einen fremden IP Netz kommst und die (Winblows) Firewall sowas z.B. gleich blockt. Ggf. also die FW anpassen oder für die Testphase der Verbindung temporär mal deaktivieren.
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Netzwerkgrundlagen
gelöst Heimnetzwerk über Server im Internet und OpenVPN erreichbar machen (16)

Frage von byt0xm zum Thema Netzwerkgrundlagen ...

Linux Netzwerk
OpenVPN, zwei OpenWRT Router verbinden und VLAN durchs VPN leiten (6)

Frage von sharbich zum Thema Linux Netzwerk ...

Router & Routing
Eine Steuerung hinter dem OpenVPN Client erreichen (15)

Frage von cannonball zum Thema Router & Routing ...

Batch & Shell
gelöst Nonsense Error - find ihn nicht. (Batch) (7)

Frage von clragon zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

DSL, VDSL
DSL-Signal bewerten (10)

Frage von SarekHL zum Thema DSL, VDSL ...

Windows Server
Mailserver auf Windows Server 2012 (8)

Frage von StefanT81 zum Thema Windows Server ...

Backup
Clients als Server missbrauchen? (8)

Frage von 1410640014 zum Thema Backup ...