Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

For-Schleife mit Modulo-Problem

Frage Entwicklung Batch & Shell

Mitglied: Killgnom

Killgnom (Level 1) - Jetzt verbinden

21.10.2009, aktualisiert 11:55 Uhr, 4947 Aufrufe, 2 Kommentare

Bin seit einiger Zeit am ausprobieren der Möglichkeiten von Batch und das Forum ist ja wohl das 'nonplusultra' auf dem Gebiet, weswegen ich mich auch grad mal registriert habe.

01.
@echo off 
02.
set gesammttage= 
03.
set /a jahrheute=%date:~6,4% 
04.
set /a jahrheute=jahrheute-1 
05.
set jahrdamals=2006 
06.
 
07.
for /L %%J IN (%jahrdamals%, 1, %jahrheute%) DO ( 
08.
	if  %%J%%4 == 0 ( 
09.
		set /a gesammttage=gesammttage+366 
10.
	) else ( 
11.
		set /a gesammttage=gesammttage+365 
12.
13.
14.
echo %gesammttage% 
15.
pause
Selbst wenn '%%J=2008' ist und beim ausführen '2008%4 == 0' anzeigt wird, wird trotzdem der 'else'-Befehl ausgeführt.
Wo liegt da das Problem?
Mitglied: bastla
21.10.2009 um 13:19 Uhr
Hallo Killgnom und willkommen im Forum!

Für die Modulo-Berechnung benötigst Du ein "set /a", und damit das ohne "delayedExpansion" umzusetzen ist, könntest Du es so versuchen:
01.
@echo off & setlocal 
02.
set gesamttage= 
03.
set /a jahrheute=%date:~6,4% 
04.
set /a jahrheute-=1 
05.
set jahrdamals=2006 
06.
 
07.
for /L %%J IN (%jahrdamals%, 1, %jahrheute%) DO ( 
08.
    set /a gesamttage+=365 
09.
    for /f %%a in ('set /a %%J%%4') do if %%a==0 set /a gesamttage+=1 
10.
11.
12.
echo %gesamttage% 
13.
pause
Grüße
bastla
Bitte warten ..
Mitglied: Killgnom
21.10.2009 um 14:04 Uhr
Danke für die schnelle Antwort, funktioniert so wie es soll. Klammer in Zeile 10 ist aber überflüssig ;)
Killgnom
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Batch & Shell
gelöst Batch Problem bei einer For Schleife (2)

Frage von Juergen42 zum Thema Batch & Shell ...

Batch & Shell
Zwei Ergänzungen in einer For Schleife

Frage von charmeur zum Thema Batch & Shell ...

Batch & Shell
gelöst FOR Schleife mit Unterverzeichnissen, die Ausgabe kürzen (tokens evtl.) (5)

Frage von Kriegstreiber zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Viren und Trojaner
gelöst Wie werde ich den Mist "fanli90" wieder los? (18)

Frage von Taumel zum Thema Viren und Trojaner ...

Switche und Hubs
LAG zwischen Cisco SG300 und Dlink DGS1100 herstellen - wie? (16)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...

CPU, RAM, Mainboards
Hardware Fragen (12)

Frage von xaver-2 zum Thema CPU, RAM, Mainboards ...

Exchange Server
gelöst Exchange 2013 - Kontakte aus CSV importieren (9)

Frage von hesper zum Thema Exchange Server ...