Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Formel falsch?!

Frage Microsoft Microsoft Office

Mitglied: SlamFaL

SlamFaL (Level 1) - Jetzt verbinden

22.09.2008, aktualisiert 18.10.2012, 3619 Aufrufe, 3 Kommentare

Hallo zusammen,

ich habe eine Excel Tabelle in der viele Namen stehen(manche mit und manche ohne Leerzeichen), jetzt wollte ich ein Formel machen die mit die Namen mit Leerzeichen anzeigen und die ohne Leerzeichen soll freibleiben.

So sieht meine Formel aus kann aber irgentwie nicht verstehen warum sie nicht funktioniert:

=WENN(FINDEN(" ";B15);RECHTS(B15;LÄNGE(B15)-FINDEN(" ";B15))&"."&LINKS(B15;1);" ")

Die Fehlermeldung die kommt ist #WERT!, habe die Formel scho mehrmals umgeändert!!

Die Formel in Worten gefasst ist: WENN ein Leerzeichen in B15 gefunden wurde dann soll es mir die Formel einfügen (RECHTS(B15;LÄNGE(B15)-FINDEN(" ";B15))&"."&LINKS(B15;1)) ansonsten soll das Feld freibleiben.

Hoffe ihr könnt mir irgendwie helfen!!

mfg
SlamFaL
Mitglied: Logan000
22.09.2008 um 13:48 Uhr
Moin moin

Der Fehler steckt in deiner Bedingung:
01.
=WENN(FINDEN(" ";B15);Dann;Sonst)
Was immer auch FINDEN() zurückgibt wenn nichts gefunden wird, verursacht den Fehler.
Versuchs Mal so:
01.
=WENN(ISTZAHL(FINDEN(" ";B15));Dann;Sonst)


Gruß L.
Bitte warten ..
Mitglied: SlamFaL
22.09.2008 um 13:51 Uhr
Hallo Logan,

Danke hat super funktioniert!!

mfg
SlamFaL
Bitte warten ..
Mitglied: bastla
22.09.2008, aktualisiert 18.10.2012
Hallo SlamFaL!

Eigentlich hattest Du die Lösung schon in Deinem vorigen Thread ...

Grüße
bastla
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
IP-Einstellungen werden falsch angezeigt (5)

Frage von schlumpf90 zum Thema Windows Server ...

Microsoft Office
gelöst Excel-Formel oder VBA (7)

Frage von nicki01 zum Thema Microsoft Office ...

Netzwerkgrundlagen
gelöst Subnetting Musterlösung falsch!? (5)

Frage von pokerfacejb zum Thema Netzwerkgrundlagen ...

Microsoft Office
Rechnungen in Word - zu lange Formel (2)

Frage von traller zum Thema Microsoft Office ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...