Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Formel falsch?!

Frage Microsoft Microsoft Office

Mitglied: SlamFaL

SlamFaL (Level 1) - Jetzt verbinden

22.09.2008, aktualisiert 18.10.2012, 3643 Aufrufe, 3 Kommentare

Hallo zusammen,

ich habe eine Excel Tabelle in der viele Namen stehen(manche mit und manche ohne Leerzeichen), jetzt wollte ich ein Formel machen die mit die Namen mit Leerzeichen anzeigen und die ohne Leerzeichen soll freibleiben.

So sieht meine Formel aus kann aber irgentwie nicht verstehen warum sie nicht funktioniert:

=WENN(FINDEN(" ";B15);RECHTS(B15;LÄNGE(B15)-FINDEN(" ";B15))&"."&LINKS(B15;1);" ")

Die Fehlermeldung die kommt ist #WERT!, habe die Formel scho mehrmals umgeändert!!

Die Formel in Worten gefasst ist: WENN ein Leerzeichen in B15 gefunden wurde dann soll es mir die Formel einfügen (RECHTS(B15;LÄNGE(B15)-FINDEN(" ";B15))&"."&LINKS(B15;1)) ansonsten soll das Feld freibleiben.

Hoffe ihr könnt mir irgendwie helfen!!

mfg
SlamFaL
Mitglied: Logan000
22.09.2008 um 13:48 Uhr
Moin moin

Der Fehler steckt in deiner Bedingung:
01.
=WENN(FINDEN(" ";B15);Dann;Sonst)
Was immer auch FINDEN() zurückgibt wenn nichts gefunden wird, verursacht den Fehler.
Versuchs Mal so:
01.
=WENN(ISTZAHL(FINDEN(" ";B15));Dann;Sonst)


Gruß L.
Bitte warten ..
Mitglied: SlamFaL
22.09.2008 um 13:51 Uhr
Hallo Logan,

Danke hat super funktioniert!!

mfg
SlamFaL
Bitte warten ..
Mitglied: bastla
22.09.2008, aktualisiert 18.10.2012
Hallo SlamFaL!

Eigentlich hattest Du die Lösung schon in Deinem vorigen Thread ...

Grüße
bastla
Bitte warten ..
Ähnliche Inhalte
Exchange Server
(Exchange 2013) Mails im Posteingang werden falsch interpretiert (1)

Frage von bigpansen zum Thema Exchange Server ...

Microsoft Office
gelöst Dateiliste in Excel 2010 wird nur nach Formel löschen aktualisiert (1)

Frage von dressa zum Thema Microsoft Office ...

Neue Wissensbeiträge
Administrator.de Feedback

Umgangsformen auf der Seite

(7)

Information von Frank zum Thema Administrator.de Feedback ...

Windows 10

Windows 8.x oder 10 Lizenz-Key aus dem ROM auslesen mit Linux

(11)

Tipp von Lochkartenstanzer zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Batch & Shell
gelöst Dir tc Befehl unter Windows 10 macht Probleme (14)

Frage von sugram zum Thema Batch & Shell ...

Windows Server
Windows Server Komplettspiegelung (13)

Frage von pdiddo zum Thema Windows Server ...

Windows Server
Windows Server 2016 RDS Remoteapp Anzeigefehler (11)

Frage von qlnGenius zum Thema Windows Server ...