Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Formel falsch?!

Frage Microsoft Microsoft Office

Mitglied: SlamFaL

SlamFaL (Level 1) - Jetzt verbinden

22.09.2008, aktualisiert 18.10.2012, 3625 Aufrufe, 3 Kommentare

Hallo zusammen,

ich habe eine Excel Tabelle in der viele Namen stehen(manche mit und manche ohne Leerzeichen), jetzt wollte ich ein Formel machen die mit die Namen mit Leerzeichen anzeigen und die ohne Leerzeichen soll freibleiben.

So sieht meine Formel aus kann aber irgentwie nicht verstehen warum sie nicht funktioniert:

=WENN(FINDEN(" ";B15);RECHTS(B15;LÄNGE(B15)-FINDEN(" ";B15))&"."&LINKS(B15;1);" ")

Die Fehlermeldung die kommt ist #WERT!, habe die Formel scho mehrmals umgeändert!!

Die Formel in Worten gefasst ist: WENN ein Leerzeichen in B15 gefunden wurde dann soll es mir die Formel einfügen (RECHTS(B15;LÄNGE(B15)-FINDEN(" ";B15))&"."&LINKS(B15;1)) ansonsten soll das Feld freibleiben.

Hoffe ihr könnt mir irgendwie helfen!!

mfg
SlamFaL
Mitglied: Logan000
22.09.2008 um 13:48 Uhr
Moin moin

Der Fehler steckt in deiner Bedingung:
01.
=WENN(FINDEN(" ";B15);Dann;Sonst)
Was immer auch FINDEN() zurückgibt wenn nichts gefunden wird, verursacht den Fehler.
Versuchs Mal so:
01.
=WENN(ISTZAHL(FINDEN(" ";B15));Dann;Sonst)


Gruß L.
Bitte warten ..
Mitglied: SlamFaL
22.09.2008 um 13:51 Uhr
Hallo Logan,

Danke hat super funktioniert!!

mfg
SlamFaL
Bitte warten ..
Mitglied: bastla
22.09.2008, aktualisiert 18.10.2012
Hallo SlamFaL!

Eigentlich hattest Du die Lösung schon in Deinem vorigen Thread ...

Grüße
bastla
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Microsoft Office
Excel Zählewenn aus Formel Wert (1)

Frage von cberndt zum Thema Microsoft Office ...

Windows Server
IP-Einstellungen werden falsch angezeigt (5)

Frage von schlumpf90 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Google Android
gelöst Android-Handy versehentlich (dauerhaft) gesperrt? (19)

Frage von FA-jka zum Thema Google Android ...

Batch & Shell
gelöst Ordner und Datei Name gleich (BATCH) (12)

Frage von clragon zum Thema Batch & Shell ...

Windows Server
SBS 2011 Standard virtualisieren (11)

Frage von HeinrichM zum Thema Windows Server ...

DSL, VDSL
gelöst DSL 200m verlängern (11)

Frage von Angela44 zum Thema DSL, VDSL ...