Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Formular funktioniert nur mit IE lokal am Rechner

Frage Entwicklung PHP

Mitglied: Gauschterna

Gauschterna (Level 1) - Jetzt verbinden

02.04.2013, aktualisiert 07.04.2013, 2868 Aufrufe, 5 Kommentare

Hallo Zusammen,

ich bin dabei ein Intranet aufzubauen und dabei
habe ich ein Problem mit folgendem Formular:

<form action="f_land.php" method="POST">
<input type="text" name="landname"></input><br>
<input type="hidden" name="flag" value="1"></input>
<input type="submit" name="form_submit" value="abschicken"></input>
</form>
Das Ganze ist in einer PHP Seite eingebaut.
Es werden die Daten local an eine MYSQL Datenbank übergeben
Es funktioniert, allerdings nur lokal am Rechner über den Internet Explorer (64 Bit).
Sobald ich Firefox oder Google Chrome ausprobiere ist keine Eingabe möglich.

Wenn ich die Seite über Browser auf dem Zielrechner ausprobiere,
funktioniert das Formular auch nicht mehr über IE noch über andere Browser.

Was mache ich Falsch
Danke für Lösungen.

Gruß Peter
Mitglied: nxclass
02.04.2013, aktualisiert um 14:45 Uhr
... HTML sieht OK aus - und dürfte auch nicht Browser abhängig sein.

Es werden die Daten local an eine MYSQL Datenbank übergeben
in der f_land.php - dazu sendest Du aber kein Code !?

unktioniert das Formular auch nicht mehr
ist keine Eingabe möglich
nur lokal am Rechner
das sind alles sehr schwammige Aussagen - WAS geht denn nicht ? WIE erfolgt der Aufruf des Formulars genau ?
Bitte warten ..
Mitglied: Gauschterna
02.04.2013 um 16:04 Uhr
Hi nxclass,

danke für deine Antwort, anbei das ganze Skript.
Das Formular wir wird in einer If Funktion aufgerufen.
Und das Formular funktioniert nur am localhost über IE.
Wenn ich Firefox oder andere ausprobiere, ist keine Eingabe im Textfeld möglich.
Auch der Absenden Button zeigt keine Funktion über andere Browser.

Kann es sein, dass ich im Doctype was verändern muß?


<!DOCTYPE html PUBLIC " -W3CDTD XHTML 1.0 Stric tEN" "http:www.w3.org/TR/xhtml2/DTD/xhtml1-strict.dtd">
<html>
<xmlns="http://www.w3.org/1999/xhtml" xml:lang="en">
<head>
<title></title>


<!--CSS Navi-->
<link rel="stylesheet" media="all" type="text/css" href="hover_drop_2/hover_drop_2.css" />
<script src="hover_drop_2/iefix.js" type="text/javascript"></script>

</head>
<body onload="ieFix('menu')">
<div id="banner"><span style="color:#ffffff;">



</span>
</div>
<div id="inhalt">
<span style="font-size:1.2em;width:50px;text-align: justify;">
<?php
/* mit DB - Server verbinden
-------------------------------------------------------------------------------------------*/
$db_handle = mysql_connect("localhost","XXXXX","XXXXX");
if($db_handle)
print " ";
else
print "DB-Serververbindung fehlgeschlagen!<br>";
/* mit Datenbankverbinden
-------------------------------------------------------------------------------------------*/
$verbunden = mysql_select_db("XXXXX",$db_handle);
if($verbunden)
print "";
else
die("Datenbankverbindung fehlgeschlagen!<br>");


?>

<?php
/* XXXXXXXXXXXXXXX__ANFANG_SEITENINHALT__XXXXXXXXXXXXXXX
-------------------------------------------------------------------------------------------*/
echo "IT-Verwaltung++Adressbuch++Land++hinzuf&#252gen";
?>
<?php
echo"<h3>Daten eintragen</h3>";
/*Variablen deklarieren
-------------------------------------------------------------------------------------------*/
$landname= $_POST["landname"];

/*$_POST['flag']==1, Prüfen ob das Formular abgeschickt wurde
-------------------------------------------------------------------------------------------*/
if($_POST['flag']==1){
/*SQL Abfrage durchführen Zeile
-----------------------------------------------------------------------------------------*/
$sql = "INSERT INTO `XXXXX`.`t_land` ( `land_id`, `landname`) VALUES (NULL, '$landname')";
mysql_query($sql) or die(mysql_error());

echo "Ihr Eintrag wurde hinzuf&#252gt!";

}//Ende if($_POST['flag']==1


if(!$_POST['flag'])
{
?>
<form action="f_land.php" method="POST">
<input type="text" name="landname"></input><br>
<input type="hidden" name="flag" value="1"></input>
<input type="submit" name="form_submit" value="abschicken"></input>
</form>
<?php
}
?>





<?php

/* XXXXXXXXXXXXXXX__Ende_SEITENINHALT__XXXXXXXXXXXXXXX
-------------------------------------------------------------------------------------------*/
?>
<?php
/* Serververbindung auflösen
-----------------------------------------------------------------------------------------*/
mysql_close();
?>
</span>
</div>
<?php
require ("menue.php");
?>

im require ("menue.php"); wir der Rest der Seite eingebunden.

Danke für jede Antwort Peter
Bitte warten ..
Mitglied: nxclass
02.04.2013, aktualisiert um 23:40 Uhr
Kann es sein, dass ich im Doctype was verändern muß?
es scheint da ein kleiner Tippfehler drin zu sein
01.
<!doctype html public "-//w3c//dtd xhtml 1.0 strict//en" "http://www.w3.org/tr/xhtml1/dtd/xhtml1-strict.dtd">
kann mir aber nicht vorstellen das dies so eine Auswirkung hat.

was mir ins Auge sticht ist:
01.
<script src="hover_drop_2/iefix.js" type="text/javascript"></script> 
02.
<body onload="ieFix('menu')">
... was passiert denn wenn Du mal den JS code deaktivierst ? bzw. was wird da gemacht ?
Bitte warten ..
Mitglied: Gauschterna
03.04.2013 um 18:01 Uhr
hi nxclass,

der JS Code steuert das Dropdown Menue.
..... habs ohne js code ausprobiert, siehe da, es funktioniert. Hier liegt also der Fehler begraben.
Ich werde hier mal alles überprüfen.

Vielen Dank erstmal.

Gruß Peter
Bitte warten ..
Mitglied: Gauschterna
07.04.2013 um 23:30 Uhr
hi nxclass,

hab nun Zeit gefunden alles zu überprüfen, es war ein Fehler in der Verschachtelung der einzelnen Container (div).
Kann es nur leider nicht mehr nachvollziehen (hab alles ausprobiert und nun geht es), ich muss mir das Thema (div verschachteln) nochmals reinziehen, ich hätte sonst gerne den Quelltext reingestellt.

Aber dein Tip war Gold wert Danke, beide Daumen hoch!!!

Gruß Peter
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
MS Access summe-Befehl in Formularen funktioniert nicht auf allen Rechnern
Frage von greatmgmMicrosoft Office

Hallo zusammen, der tt sagt einfach alles :D Habe ein Endlos-Formular mit einem gebundenen Datenfeld "kpbetrag" und in der ...

Exchange Server
OWA funktioniert nur im IE
gelöst Frage von ketanest112Exchange Server18 Kommentare

Hallo zusammen, ich habe folgendes Problem: Mein Exchange Server an sich läuft, nimmt auch Mails an. Meine Handy Syncronisiert ...

Windows 7
Terminalserverprofil nicht auf lokalem Rechner anwenden
Frage von FreaksterWindows 71 Kommentar

Hallo, ich habe einen PC mit Windows7, einen Terminalserver mit Windows 2008 und einen Domaincontroller mit Windows 2008. In ...

Windows 7
Sekundäre Anmeldung am IE, drucken funktioniert nicht
gelöst Frage von adminstWindows 71 Kommentar

Guten Morgen zusammen Client: Win 7 x64 IE: 11 Patchstand: aktuell Wenn jemand den IE auf dem Client unter ...

Neue Wissensbeiträge
Verschlüsselung & Zertifikate

19 Jahre alter Angriff auf TLS funktioniert immer noch

Information von BassFishFox vor 3 StundenVerschlüsselung & Zertifikate

Interessant zu lesen. Der Bleichenbacher-Angriff gilt unter Kryptographen als Klassiker, trotzdem funktioniert er oft noch. Wie wir herausgefunden haben, ...

Windows 10

Windows 10 Fall Creators Update - Neue Funktion Hyper-V Standardswitch kann ggf. Fehler bei Proxy Configs verursachen

Erfahrungsbericht von rzlbrnft vor 14 StundenWindows 102 Kommentare

Hallo Kollegen, Da wir die Gefahr lieben, haben wir bei einigen Usern nun mittlerweile das Creators Update drauf. Einige ...

Sicherheit

TLS-Zertifikat und privater Schlüssel von Microsofts Dynamics 365 geleakt

Information von Penny.Cilin vor 16 StundenSicherheit

Microsoft hat versehentlich das TLS-Zertifikat inklusive dem privaten Schlüssel seiner Business-Anwendung Dynamics 365 geleakt. TLS-Zertifikat und privater Schlüssel von ...

Viren und Trojaner

Deaktivierter Keylogger in HP Notebooks entdeckt

Information von bitcoin vor 1 TagViren und Trojaner3 Kommentare

Ein Grund mehr warum man Vorinstallationen der Hersteller immer blank bügeln sollte Der deaktivierte Keylogger findet sich im vorinstallierten ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Firefox Profieles im Roaming
gelöst Frage von Hendrik2586Netzwerkmanagement17 Kommentare

Hallo liebe Leute. :) Ich hab da ein kleines Problem, welches anscheinend nicht unbekannt ist. Wir nutzen hier in ...

Netzwerkmanagement
NAS über zwei weitere Ethernet Anschlüsse verbinden
gelöst Frage von Sibelius001Netzwerkmanagement16 Kommentare

Sorry - ich bin hier wahrscheinlich als kompetter IT Trottel unterwegs. Aber eventuell kann mir jemand ganz einfach helfen: ...

LAN, WAN, Wireless
Häufig Probleme beim Anmelden in WLAN
Frage von mabue88LAN, WAN, Wireless15 Kommentare

Hallo zusammen, in einem Netzwerk gibt es relativ häufig (1-2 mal pro Woche) Probleme mit der WLAN-Verbindung. Zunächst mal ...

Netzwerkgrundlagen
Hi eine blöde frage. xD
Frage von 132954Netzwerkgrundlagen13 Kommentare

Also: Habe 2012 r2 essentials neuinstalliert, allerdings installiert diese version ja gleich diesen gangen AD kram mit, den hab ...