Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Formulardaten über sendmail.php werden nicht verschickt

Frage Entwicklung PHP

Mitglied: achklein

achklein (Level 1) - Jetzt verbinden

20.08.2013 um 17:44 Uhr, 1770 Aufrufe, 4 Kommentare

Hallo,

ich bin dabei eine neue Homepage zu erstellen. Auf der Seite

http://www.mendener-branchen.de/branchen.php

sollen Anzeigenkunden Ihre Daten eintragen, die dann per E-Mail an mich übermittelt werden sollen. Leider erscheint statt der Bestätigungsseite nur eine weiße, leere Seite. Die gleichen Skripte verwende ich schon erfolgreich auf einer anderen Webseite, allerdings bei einem anderen Hoster. Was habe ich hier falsch gemacht? Danke für Eure Hinweise!

Achim

Mitglied: nxclass
20.08.2013 um 18:08 Uhr
Leider erscheint statt der Bestätigungsseite nur eine weiße, leere Seite.
... dann steht der Fehler sicher im Webserver log. (evtl nur ein simpler Syntax Fehler beim copy & paste)
Bitte warten ..
Mitglied: colinardo
21.08.2013 um 11:47 Uhr
Hallo Achim,
ohne deinen Code mit den verwendeten PHP-Funktionen können wir hier nur mutmaßen, eventuell ist bei dem anderen Hoster eine deiner verwendeten Funktionen aus Sicherheitsgründen deaktiviert. Checke das indem du folgende PHP-Datei erstellst, hoch lädst und öffnest.
01.
<?php 
02.
    phpinfo(); 
03.
?>
Zur zusätzlichen Fehleranalyse baue zusätzlich folgende Zeile ganz oben in dein sendmail-Script ein, damit alle eventuell auftretenden Fehler angezeigt werden.
01.
error_reporting(E_ALL);
Grüße Uwe
Bitte warten ..
Mitglied: achklein
21.08.2013 um 15:16 Uhr
Hallo, ich habe hier mal die Antwort des Servers gespeichert:

https://dl.dropboxusercontent.com/u/1984524/phptest.jpg

Zudem habe die Zeile wie beschrieben in sendmail.php eingebaut, aber an der Reaktion der Seite ändert sich nichts

Achim
Bitte warten ..
Mitglied: colinardo
21.08.2013 um 16:06 Uhr
Zitat von achklein:
Hallo, ich habe hier mal die Antwort des Servers gespeichert:

https://dl.dropboxusercontent.com/u/1984524/phptest.jpg
Ich meinte damit das du selber dein Script auf benutzte Funktionen überprüfst und auf der Seite überprüfst ob bestimmte Bibliotheken nicht aktiv sind. So kann ich damit nix anfangen.

Zudem habe die Zeile wie beschrieben in sendmail.php eingebaut, aber an der Reaktion der Seite ändert sich nichts
ohne Code kann ich dir da leider nicht weiterhelfen.
Werden die Mails denn überhaupt gesendet, oder wird nur die leere Seite angezeigt aber die Mail trotzdem gesendet ?
Bitte warten ..
Ähnliche Inhalte
Viren und Trojaner
gelöst Von meinem Rechner wurden Spam-Nachrichten verschickt (11)

Frage von stormwind81 zum Thema Viren und Trojaner ...

Exchange Server
Exchange 2013 dynamische Verteilergruppe verschickt keine Emails (5)

Frage von blackhawk17 zum Thema Exchange Server ...

Neue Wissensbeiträge
Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

(2)

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Viren und Trojaner

CNC-Fräsen von MECANUMERIC werden (ggf.) mit Viren, Trojanern, Würmern ausgeliefert

(4)

Erfahrungsbericht von anteNope zum Thema Viren und Trojaner ...

Windows 10

Windows 10: Erste Anmeldung Animation deaktivieren

(3)

Anleitung von alemanne21 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Netzwerkprotokolle
gelöst Leiten "dumme" Switches VLAN-Tags mit durch? (26)

Frage von coltseavers zum Thema Netzwerkprotokolle ...

Netzwerkgrundlagen
Kann auf Freigabe nicht Zugreifen (16)

Frage von leon123 zum Thema Netzwerkgrundlagen ...

Windows Server
gelöst Neues KB für W10 1607 und W2K16 wieder mal nicht im WSUS 3.0, hat das noch jemand? (16)

Frage von departure69 zum Thema Windows Server ...

Exchange Server
Apple Mail mit Exchange 2010 verbinden (12)

Frage von DieAzubinne zum Thema Exchange Server ...