Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

FreeBSD 8.2 bootet nicht nach installation mit ZFS

Frage Linux

Mitglied: -Ryou-

-Ryou- (Level 1) - Jetzt verbinden

19.04.2011 um 13:46 Uhr, 4556 Aufrufe, 3 Kommentare

Hallo Kollegen und Kolleginnen,

Ich hab folgendes Problem. Ich bin gerade dabei ein Test-System (FreeBSD 8.2 mit ZFS-Fielsystem) in Virtualbox auf zu setzen. Nach der Installation beim Neu Starten bekomme ich immer die Fehlermeldung.
" ZFS: i/o error - all block copies unavailable".
" ZFS: can'T read MOS object directory"
"Can't find root filesystem - giving up"

Auch wenn ich nach den Fehler google finde ich nichts was mir wirklich weiter hilft. Hat jemand eine Idee an was es liegen kann?
Diese Howto hab ich als Leitpfad benützt: http://wiki.freebsd.org/RootOnZFS/GPTZFSBoot/RAIDZ1
hab Sie aber ein wenig angepasst. Ihr die Dokumentation von meiner Installation.

<----FreeBSD 8.2 Install manuel---->


Installer
--> Germany
--> Germany ISO
--> Fixit
--> CDROM/DVD


<----Fixit Konsole---->


Erstellen von GPT Disk
Fixit# gpart create -s gpt da0
Fixit# gpart create -s gpt da1
Fixit# gpart create -s gpt da2



Erstellen von GPT Partitionen
Fixit# gpart add -b 34 -s 64k -t freebsd-boot da0
Fixit# gpart add -b 162 -s 41942845 -t freebsd-zfs -l sys1 da0
Fixit# gpart add -b 34 -s 64k -t freebsd-boot da1
Fixit# gpart add -b 162 -s 41942845 -t freebsd-zfs -l sys2 da1
Fixit# gpart add -b 34 -s 64k -t freebsd-boot da2
Fixit# gpart add -b 162 -s 41942845 -t freebsd-zfs -l sys3 da2



Installieren von MBR & GPT boot loader
Fixit# gpart bootcode -b /mnt2/boot/pmbr -p /mnt2/boot/gptzfsboot -i 1 da0
Fixit# gpart bootcode -b /mnt2/boot/pmbr -p /mnt2/boot/gptzfsboot -i 1 da1
Fixit# gpart bootcode -b /mnt2/boot/pmbr -p /mnt2/boot/gptzfsboot -i 1 da2


Laden von ZFS Kernel module
Fixit# kldload /mnt2/boot/kernel/opensolaris.ko
Fixit# kldload /mnt2/boot/kernel/zfs.ko



Erstellen von ZFS Pool zroot
Fixit# mkdir /boot/zfs
Fixit# zpool create zroot raidz1 /dev/gpt/sys1 /dev/gpt/sys2 /dev/gpt/sys3
Fixit# zpool set bootfs=zroot zroot



<----Installation von FreeBSD auf dem ZFS-Feilsystem---->


Erstellen von ZFS Partitionen
Fixit# zfs set checksum=fletcher4 zroot
Fixit# zfs set compression=lzjb zroot
Fixit# zfs create -o checksum=off -o exec=on -o setuid=off zroot/tmp
Fixit# chmod 1777 /zroot/tmp
Fixit# zfs create -o checksum=off -o setuid=off -o mountpoint=/usr/ports zroot/ports
Fixit# zfs create -o checksum=off -o exec=on -o setuid=off -o mountpoint=/var/tmp zroot/var_tmp
Fixit# chmod 1777 /var/tmp



Installieren FreeBSD auf zroot
Fixit# cd /dist/8.2-*
Fixit# export DESTDIR=/zroot
Fixit# for dir in base manpages; do (cd $dir ; ./install.sh; cd ..) ; done
Fixit# cd kernels ; ./install.sh generic
Fixit# cd /zroot/boot ; cp -Rlp GENERIC/* /zroot/boot/kernel/



Grundkonfiguration
Fixit# echo 'zfs_enable="YES"' > /zroot/etc/rc.conf
Fixit# echo 'hostname="vbox-zfs"' >> /etc/rc.conf
Fixit# echo 'zfs_load="YES"' > /boot/loader.conf
Fixit# echo 'vfs.root.mountfrom="zfs:zroot"' >> /boot/loader.conf
Fixit# chroot /zroot
<----chroot benötigt!---->
Fixit# passwd root
Fixit# tzsetup
Fixit# cd /etc/mail
Fixit# make aliases
Fixit# exit


System bootfähigmachen
Fixit# zpool export zroot
Fixit# zpool import zroot
Fixit# cp /boot/zfs/zpool.cache /zroot/boot/zfs/
Fixit# touch /zroot/etc/fstab
Fixit# export LD_LIBRARY_PATH=/mnt2/lib
Fixit# zfs unmount -a
Fixit# zfs set mountpoint=/tmp zroot/tmp
Fixit# zfs set mountpoint=legacy zroot
Fixit# exit
Mitglied: ckworld
19.04.2011 um 14:18 Uhr
Hast du für die Virtualbox die IO-APIC aktiviert?
Bitte warten ..
Mitglied: -Ryou-
19.04.2011 um 14:28 Uhr
Ja das und die Hardware-Virtualisierung wie die erweiterte Einstellungen bei Prozessor.
Bitte warten ..
Mitglied: -Ryou-
20.04.2011 um 10:16 Uhr
Hab es jetzt um den Teil erweitert.

Fixit# echo 'vfs.root.mountfrom.options="rw"' >> /boot/loader.conf

Aber das System bootet immer noch nicht.
Bitte warten ..
Neuester Wissensbeitrag
Festplatten, SSD, Raid

12TB written pro SSD in 2 Jahren mit RAID5 auf Hyper-VServer

Erfahrungsbericht von Lochkartenstanzer zum Thema Festplatten, SSD, Raid ...

Ähnliche Inhalte
Windows Server
gelöst Problem nach DC-Installation unter Server 2012 R2 (9)

Frage von manuel1985 zum Thema Windows Server ...

Windows Installation
Server 2016 UEFI Installation von USB (3)

Tipp von DerWoWusste zum Thema Windows Installation ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (34)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...