Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

FreeNAS, M1015, Proxmox und Booten

Frage Virtualisierung KVM

Mitglied: bongartz

bongartz (Level 1) - Jetzt verbinden

09.02.2015, aktualisiert 10:41 Uhr, 2129 Aufrufe, 6 Kommentare

Hallo zusammen,

Ich bin gerade dabei mir ein neues RAID System mit FreeNas 9.3.x und Proxmox 3.3.x einzurichten. Hierbei bin ich leider auf ein sehr komisches Problem gestoßen. Wenn ich bei dem Proxmox den IBM M1015 Raidcomtroller mit PCI direkt an den FreeNAS durchreiche kann ich plötzlich nicht mehr Booten, da keinen Bootbare Festplatte mehr gefunden wird.

Hier meine System Konfiguration.

Hardware:

HP MicroServer Gen8
Intel E3 1265L
16 GB RAMA
Samsung SSD für System auf SATA OOD Port
IBM M1015 Raid Controller mit geflashten BIOS
4 x 4TB WD Red

Software:
Proxmox 3.3.x mit 2.6 Kernel auf der SSD
KVM mit FreeNAS 9.3.x mit 12 GB RAM
Vitro HDD 16GB
Bootreihenfolge Virteo HHD, CO-ROM, Netzwerk

Wenn ich FreeNAS ohne anpasste conf Datei, also ohne RAID Conteoller starte kann ich ganz normal hochfahren, wenn jedoch der RAID Controller eingebunden ist, will das System immer von der ersten Platte vom RAID starten wo natürlich kein OS drauf ist.

Wenn ich mit crt + c in den RAID Controller beim starten will passiert nicht. Und F12 beim FreeNAS gibt mir nur die Wahl von der ersten HHD zu booten oder per Netzwerk.

Weiß einer von euch wie ich die bootreihenfolge in der KVM verändern kann? In Proxmox ist natürlich als erste Bootgerät die Vitro HDD ausgewählt, aber da der RAID Controller ja durchgeschleift wird bringt diese konfiguration ja nicht so viel.

Danke

Gruß

André
Mitglied: keine-ahnung
LÖSUNG 09.02.2015, aktualisiert um 10:41 Uhr
Moin,
ich will mal so sagen:
HP MicroServer Gen8
O.K.
Intel E3 1265L
not supported
16 GB RAMA
Hier könnte Butter statt RAMA Wunder wirken
IBM M1015 Raid Controller mit geflashten BIOS
not supported
Proxmox 3.3.x
not supported

Kurz: wer basteln will, muss leiden

LG, Thomas

p.s.: vermutlich bist Du hier besser aufgehoben, da trifft sich alles, was aus einem Gen8-Microserver einen prima neuen Hamsterkäfig bauen will ...
Bitte warten ..
Mitglied: bongartz
09.02.2015 um 10:45 Uhr
Wo hast du denn deine Quellen her was nicht Supportet wird und von was?

Redest du jetzt von FreeNAS oder von dem Gen8?

Das es viele gibt die diesen Weg nicht all optimal ansehen weiß ich, aber ich würde mir lieber selbst ein Bild machen. Und mal ehrlich alles was nicht Apple ist ist bastel Zeugs. Also bitte lassen wir diese Kommentare.

Danke
Bitte warten ..
Mitglied: keine-ahnung
09.02.2015 um 11:05 Uhr
Wo hast du denn deine Quellen her was nicht Supportet wird und von was
Nennt sich quick specs - Lesen ist nicht ausschliesslich ein negatives Entwicklungsmerkmal
Und mal ehrlich alles was nicht Apple ist ist bastel Zeugs.
no comment - sind schon wieder Ferien??

Lies Dir mal den gelinkten Sammelfred durch ... sind mittlerweile schon 105 Seiten Bastelanleitungen.

LG, Thomas
Bitte warten ..
Mitglied: bongartz
09.02.2015 um 11:18 Uhr
Also im anderen Forum wird mir gerade geholfen, somit Danke für den Link.

Was ich nie verstehe ist warum immer zich Infos kommen die ein Priblem kaum berühren aber auf den eigentlich Punkt nie wirklich eingegangen wird.

Achja der FreeNAS läuft nativ sehr perfekt auf der Maschine trotz RAMA
Bitte warten ..
Mitglied: keine-ahnung
09.02.2015 um 12:33 Uhr
Was ich nie verstehe ist warum immer zich Infos kommen die ein Priblem kaum berühren aber auf den eigentlich Punkt nie wirklich eingegangen wird.
Nun ... das ist hier eher ein seriöses Forum . I.d.R. werden hier Probleme abgehandelt, die im produktiven Betrieb auftreten - insofern versucht man schon, verirrte Schäfchen wieder auf den Pfad des Herrn zurückzuholen . Insgesamt achten wir - zumindest ich - eher auf Zuverlässigkeit, nicht so sehr darauf, was eventuell möglich ist und kennen daher solche Begriffe wie Spezifikationen etc. Mitunter halten wir uns sogar daran ... wenn hier Bastellösungen breitgetreten werden, hält das irgendwann mal ein user, der den Fred über die SuFu findet, wiederum für den Stein der Weisen.
Also im anderen Forum wird mir gerade geholfen,
Prima! Das gehört auch eher dahin ...

LG, Thomas
Bitte warten ..
Mitglied: bongartz
11.02.2015 um 13:25 Uhr
Ok.

Also ich habe das Problem jetzt finden können und will hier kurz meine Lösung posten, für den Fall das jemand eine ähnliche Lösung umsetzen will.

Das Problem lag dadran, dass der RAID Controller immer in der VM eine Boot Priorität hatte. Dies muss man im BIOS (strg + c beim booten des Controllers) des RAID Controller separat ausschalten, dass er beim Booten nix macht.

Eigentlich ganz logisch, aber durch die VM und das man nicht in das BIOS über die VM kommt hat es was gedauert bis auf das Problem gekommen bin. Also wenn man in das BIOS des Controller will, muss man das HOST-System mit Proxmox komplett neustarten, hier kann man dann ins BIOS.
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Router & Routing
gelöst Proxmox WAN IPs (13)

Frage von sebastian2608 zum Thema Router & Routing ...

KVM
gelöst Proxmox KVM - Disk read error nach verschieben der disk (6)

Frage von ketanest112 zum Thema KVM ...

Notebook & Zubehör
Surface Pro 4 Booten von USB Stick (6)

Frage von endurance zum Thema Notebook & Zubehör ...

Linux Netzwerk
Proxmox - LAN aus virtuellen und physischen Maschinen (2)

Frage von balus7 zum Thema Linux Netzwerk ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...