Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

freeRasdius mit EAP-TLS betreiben

Frage Sicherheit Verschlüsselung & Zertifikate

Mitglied: Nils1988

Nils1988 (Level 1) - Jetzt verbinden

21.02.2008, aktualisiert 28.08.2008, 3652 Aufrufe, 2 Kommentare

Hallo zusammen,

ich sitze grade an einem Projekt.

Ich habe einen freeRadius Server (SuSE 10.3). Dieser ist mit einem Accesspoint (Netgear) verbunden. Ich habe jetzt eigentlich auf dem Access Point und auf dem Radius Server alle Einstellungen für EAP-TLS vorgenommen. Nun habe ich die Zertifikate erzeugt und die entsprechenden Zertifikate auch auf einen Windows XP Client kopiert und eigebunden.

Wenn ich mich jetzt verbinden will, steht unten einfach nur: Es wird kein Zertifikat gefunden, um Sie am Netzwerk anzumelden.

Wenn ich mir jetzt die Logs von meinem Accesspoint ansehe, steht dort nur:

[2004 Jan 1 00:00:01] AP activated
[2004 Jan 1 00:00:01] Connect to RADIUS Server
[2004 Jan 1 00:00:01] Connect to Accounting Server
[2004 Jan 1 00:00:01] GTK generate
[2004 Jan 1 00:00:01] accounting service on
[2004 Jan 1 00:01:17] autocell ready
[2004 Jan 1 00:09:19] 00:1B:11:C5:37:84 authenticated
[2004 Jan 1 00:09:19] 00:1B:11:C5:37:84 associated
[2004 Jan 1 00:09:31] 00:1B:11:C5:37:84 disassociated
[2004 Jan 1 00:09:34] 00:1B:11:C5:37:84 authenticated
[2004 Jan 1 00:09:34] 00:1B:11:C5:37:84 associated
[2004 Jan 1 00:09:49] 00:1B:11:C5:37:84 disassociated
[2004 Jan 1 00:09:50] 00:1B:11:C5:37:84 authenticated
[2004 Jan 1 00:09:50] 00:1B:11:C5:37:84 associated


So jetzt bin ich einen Schritt weiter gegangen und habe meinen Radius Server im Debug Modus gestartet. Wenn ich jetzt den Access Point einmal ausziehe und wieder einstecke, empfängt der Radius Server das hier:

rad_recv: Accounting-Request packet from host 192.168.167.9:1025, id=25, length=135
User-Name = "netgear95030a"
Service-Type = Framed-User
Acct-Status-Type = Accounting-On
Acct-Session-Id = " 18"
Acct-Authentic = RADIUS
Called-Station-Id = "001B2F95030A:Radius"
NAS-Identifier = "netgear95030a"
NAS-Port-Type = Wireless-802.11
Connect-Info = "CONNECT 54Mbps 802.11g"
NAS-IP-Address = 192.168.167.9
Processing the preacct section of radiusd.conf
modcall: entering group preacct for request 9
modcall[preacct]: module "preprocess" returns noop for request 9
rlm_acct_unique: WARNING: Attribute NAS-Port was not found in request, unique ID MAY be inconsistent
rlm_acct_unique: Hashing ',Client-IP-Address = 192.168.167.9,NAS-IP-Address = 192.168.167.9,Acct-Session-Id = " 18",User-Name = "netgear95030a"'
rlm_acct_unique: Acct-Unique-Session-ID = "aedfca019b6bfef4".
modcall[preacct]: module "acct_unique" returns ok for request 9
rlm_realm: No '@' in User-Name = "netgear95030a", looking up realm NULL
rlm_realm: No such realm "NULL"
modcall[preacct]: module "suffix" returns noop for request 9
modcall[preacct]: module "files" returns noop for request 9
modcall: leaving group preacct (returns ok) for request 9
Processing the accounting section of radiusd.conf
modcall: entering group accounting for request 9
radius_xlat: '/var/log/radius/radacct/192.168.167.9/detail-20080221'
rlm_detail: /var/log/radius/radacct/%{Client-IP-Address}/detail-%Y%m%d expands to /var/log/radius/radacct/192.168.167.9/detail-20080221
modcall[accounting]: module "detail" returns ok for request 9
modcall[accounting]: module "unix" returns noop for request 9
radius_xlat: '/var/log/radius/radutmp'
rlm_radutmp: NAS AP restarted (Accounting-On packet seen)
modcall[accounting]: module "radutmp" returns ok for request 9
modcall: leaving group accounting (returns ok) for request 9
Sending Accounting-Response of id 25 to 192.168.167.9 port 1025
Finished request 9
Going to the next request
--- Walking the entire request list ---
Cleaning up request 9 ID 25 with timestamp 47bd4cf9
Nothing to do. Sleeping until we see a request.


Lässt das darauf schließen, dass der Radius Server richtig arbeitet?

Ansonsten kommen aber keinerlei Meldungen am Radius Server an.

Bitte euch alle ganz dringend um Hilfe!

Danke!
Mitglied: gnarff
07.03.2008 um 15:52 Uhr
Problem noch aktuell???

saludos
gnarff
Bitte warten ..
Mitglied: oohlala
28.08.2008 um 12:47 Uhr
denke liegt wie bei mir an den zertifikaten auf dem client, die ich installieren kann wie ich will, aber dann wenn ich sie brauch im wlan client util nicht auswählen. das util sagt dann es findet keine zertifikate.
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Vmware
SSL TLS Fehler Veeam VMware (3)

Information von hagerino zum Thema Vmware ...

Router & Routing
gelöst VPN-Server (Fritzbox) hinter Zyxel 5501 betreiben (7)

Frage von basti76nie zum Thema Router & Routing ...

Apache Server
gelöst Apache und PHP auf Ubuntu 12.04.5.TLS installieren (8)

Frage von laster zum Thema Apache Server ...

Windows Server
2 Terminalserver parallel betreiben (5)

Frage von derSESO zum Thema Windows Server ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (17)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

DSL, VDSL
DSL-Signal bewerten (14)

Frage von SarekHL zum Thema DSL, VDSL ...