Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Frontend spielt bei 2 von 20 Rechnern verrückt, Formular geht nicht auf, Entwurf auch nicht

Frage Microsoft Microsoft Office

Mitglied: greatmgm

greatmgm (Level 1) - Jetzt verbinden

06.10.2008, aktualisiert 07.10.2008, 3379 Aufrufe, 7 Kommentare

Hallo zusammen,

ich drehe gleich am Montagmorgen so richtig am Rad
Habe eine Access-Datenbank mit einem frontend und backend.
Beide liegen auf dem Server. Die Nutzer holen sich via script das frontend auf den lokalen Rechner
und arbeiten dann los.
Das Ganze läuft für ca. 20 clients ... und läuft auch ... bis auf 2 clients, hier öffnen bestimmte
Formulare nicht es passiert einfach ca. 10 min. nichts, dann kommt Anwendung reagiert nicht.
Auch wenn ich das lokale frontend öffne und versuche den Entwurf des Formulars zu öffnen, passiert
das selbe.
Raparatur ohne Erfolg, Tabellen neu eingebunden ohne Erfolg, Formulare exportiert und neu importiert ohne Erfolg.
Wie gesagt bei 18 Rechnern funktionierts.

Bisher einzige Lösung, eine lokale DB angelegt dort nur die nicht funktionierenden Formulare importiert und halt
mit dieser Version arbeiten.

Wo kann ich denn da noch suchen ?
Mitglied: 60730
06.10.2008 um 14:11 Uhr
Servus,

beschreibe die Zeile:
Die Nutzer holen sich via script das frontend auf den lokalen Rechner und arbeiten dann los.
bitte mal genauer.

Das Ganze läuft für ca. 20 clients ... und läuft auch ... bis auf 2 clients

Und wenn du auf 5 Clients die Anwendung beendest und dann auf den zwei (nicht laufenden) die Anwendung startest - was passiert dann?

Habe eine Access-Datenbank mit einem frontend und backend.
Also zwei MDBs oder eine MDB - die auf einen xyzSql Server zugreift?

Gruß
Bitte warten ..
Mitglied: greatmgm
06.10.2008 um 14:15 Uhr
Die Nutzer holen sich via script das frontend auf den lokalen Rechner und arbeiten dann los.

--> via wscript host wird die "frontend.mdb" nach C: kopiert

Das Ganze läuft für ca. 20 clients ... und läuft auch ... bis auf 2 clients

--> auch wenn die 2 clients alleine drin sind, die wollen einfach nicht

Also zwei MDBs oder eine MDB - die auf einen xyzSql Server zugreift?

--> das lokale "kopierte" frontend.mdb ist verknüpft mit einer zentralen "backend.mdb"
Bitte warten ..
Mitglied: 60730
06.10.2008 um 16:41 Uhr
Servus again,

also mit

--> via wscript host wird die "frontend.mdb" nach C: kopiert
kann ich nicht viel anfangen, ich weiß nur:
  • das eine bereits geöffnete mdb nicht so einfach zu kopieren ist.
  • kenne den Hintergrund nicht, warum die kopiert werden soll und wie du das machst

Von daher hast du die schon mal direkt vom Server gestartet?
  • Sind die Sicherheiten bei Makros überall gleich?
  • Sind allüberall die gleichen system.mdws eingetragen?
  • lief es überhaupt auf den 2 Clients schonmal?

--> auch wenn die 2 clients alleine drin sind, die wollen einfach nicht
Auch das ist eine "sehr aussagekräftige" Fehlermeldung - in "echt" kommt doch bestimmt eine - mit der man auch etwas anfangen kann????

--> das lokale "kopierte" frontend.mdb ist verknüpft mit einer zentralen "backend.mdb"
*puh* es gibt 1.001 Varianten - ODBC; Fileebene mit ip oder per name oder oder oder
Welche hätten wir denn gerne genommen?

Gruß
Bitte warten ..
Mitglied: greatmgm
06.10.2008 um 17:01 Uhr
(i) kopiert wird mit dem "windows scripting host" und einfach nur aus dem Grund
um mit der lokalen mdb zum Beispiel temporäre Auslagerungen zu erstellen, bzw. batch Aufgaben vorzubereiten, das Kopieren klappt ja auch problemlos und ist bestimmt nicht die Ursache

(ii) direkt vom Server gehts auch nicht, Makroeinstellungen alle gleich. mdws nie angerührt und ja es lief auf dem einen client bis vor 2 Wochen und auf dem anderen bis heute morgen, dazu wäre noch zu bemerken das diese beiden clients seit Sept. 2007 ! gelaufen sind

(iii) <quote> Auch das ist eine "sehr aussagekräftige" Fehlermeldung - in "echt" kommt doch bestimmt eine - mit der man auch etwas anfangen kann???? </quote>

In "Echt" kommt das was ich am Anfang beschrieb, Access rührt sich nicht mehr und nach 10min. kommt Anwendung reagiert nicht mehr ...

(iv) verknüpft werden die tabellen der backend.mdb über Laufwerksbuchstabe der via net use auf die Freigabe einer IP gemappt ist, die wiederum einen w2k Server repräsentiert
Bitte warten ..
Mitglied: 60730
06.10.2008 um 17:25 Uhr
Servus,

ach jetzt hab ichs "wsh" bedeutet "Windows Scripting Host

Na da wäre ich ja auch im Leben nicht drauf gekommen
ich dachte irrtümlich, du würdest die betreffende Funktion mal mitgeben

und ist bestimmt nicht die Ursache
Kannst du bitte "kristallkugelalarm in deine Überschrift hinzufügen, dann weiß jeder, gleich wo er zu suchen hat

Spass beiseite - an deiner Konstellation sehe ich schon anhand der wenigen Infos, daß dort so einiges an Optimierungen möglich und sehr wahrscheinlich auch nötig ist

Im Fall von Office 2003: Ist bei den beiden das SP3 installiert?
Haben die beiden (unter Net use zu erfahren) den besagten Laufwerksbuchstaben gemappt und dürfen die User dort zumindestens drauf lesen?

Ofice schon mal repariert?
Schon mal an den Rechnern mit einem anderen Account (zur Not den lokalen Admin) benutzt?

Gruß
Bitte warten ..
Mitglied: greatmgm
07.10.2008 um 07:27 Uhr
Guten Morgen,

jaja der Laufwerksbuchstabe ist gemappt, es ist ja auch so das in diesem frontend noch ca. 50 andere Formulare/Berichte etc. sind die alle funktionieren, es geht halt nur ein Formular nicht mehr.
Ich tippte erst auf einen defekt der entsprechenden Tabelle auf die das Formular zugreift, aber dann würden ja nicht 18 clients funktionieren.

Ich werd jetzt mal Office runterhauen und neu installieren, vielleicht hat sich was mit jet-db-treiber verwurschtelt.

Danke.
Bitte warten ..
Mitglied: 60730
07.10.2008 um 10:10 Uhr
Moin zurück,


Ich werd jetzt mal Office runterhauen und neu installieren,
vielleicht hat sich was mit jet-db-treiber verwurschtelt.

Widerspricht sich eigentlich mit deinem vorherigen Zitat...

Bisher einzige Lösung, eine lokale DB angelegt dort nur die nicht
funktionierenden Formulare importiert und halt mit dieser Version arbeiten.

Try it trotzdem, evtl ist ja wirklich das SP3 schuld...
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Windows Server
gelöst Active Directory CA öffentlich vertrauenswürdig machen, geht das? (2)

Frage von DeathangelCH zum Thema Windows Server ...

Microsoft Office
Formular Autofill - Infopath (1)

Frage von TlBERlUS zum Thema Microsoft Office ...

Windows Server
Windows Server 2008 R2 Aero-Design auf Remote Desktop geht nicht (3)

Frage von Motherboard33 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (17)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

DSL, VDSL
DSL-Signal bewerten (14)

Frage von SarekHL zum Thema DSL, VDSL ...