Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

FTP Übertragungsproblem

Frage Netzwerke Netzwerkprotokolle

Mitglied: Lancelot1975

Lancelot1975 (Level 1) - Jetzt verbinden

19.07.2005, aktualisiert 17:41 Uhr, 6661 Aufrufe, 5 Kommentare

ftp bekommt Übertragungsende nicht mit

Folgendes Problem:

ich übertrage per FTP eine Datei von einem FTP-Server auf einen Windowsclient per Batchdatei in der Dosbox. Die Datei wird übertragen, aber FTP bekommt nicht mit, dass die Datei komplett übertragen wurde. Der Übertragungsbefehl mget bleibt hängen. Somit können die weiteren Verarbeitungsschritte der Batchdatei nicht gestartet werden.

Hat jemand eine Idee wieso das passiert und wie man das umgehen kann?

Gibt es für die FTP-Übertragung per Dosbox eine Verlaufsanzeige (vielleicht sogar in %) statt nur dem blinkenden Cursor?

Gruß Lancelot1975
Mitglied: 11078
19.07.2005 um 15:03 Uhr
Hallo,

poste mal die Batch-Datei oder (falls zu groß) wenigstens die FTP-relevanten Passagen.


Gruß,
TIM
Bitte warten ..
Mitglied: Lancelot1975
19.07.2005 um 15:48 Uhr
start /wait ftp -s:c:\batch\DFUGET1.TXT -i Servername
start/wait Programm.exe


In der Textdatei DFUGET1.TXT steht:

Ben.name
Passwort
binary
mget Dateiname.zip
mdelete K_0*
disconnect
quit
Bitte warten ..
Mitglied: 11078
19.07.2005 um 16:08 Uhr
Hallo,

soweit ich weiß, ist die Voreinstellung für "mget", dass bei jeder Datei abgefragt wird, ob sie auch wirklich übertragen werden soll. Genau an dieser Stelle könnte das ganze hängen.

Korrigier mich, aber mget ist ja eigentlich auch dafür gedacht, mehrere Dateien auf einmal (in verbindung mit Wildcards) zu übertragen.

Ersetze mget einfach mal mit get, denn Du willst ja auch nur eine einzelne Datei übertragen.


Gruß,
TIM

[EDIT: Ja, habs gerade mal probiert - mget fragt tatsächlich, ob die Datei übertragen werden soll. Also entweder "get" verwenden oder in der Zeile nach dem mget noch ein "y" einfügen]
Bitte warten ..
Mitglied: Lancelot1975
19.07.2005 um 17:20 Uhr
aber die Datei wurde ja auch ohne das "y" übertragen. Nur dass ftp noch meint, dass die Datei noch nicht übertragen wurde, sprich: mget wird nicht abgeschlossen.
Bitte warten ..
Mitglied: 11078
19.07.2005 um 17:41 Uhr
Hallo,

aber die Datei wurde ja auch ohne das
"y" übertragen. Nur dass ftp
noch meint, dass die Datei noch nicht
übertragen wurde, sprich: mget wird
nicht abgeschlossen.

na ja, die Abfrage "y" oder "n" kann man generell auch mit dem Befehl "prompt" abschalten - vermutlich bei Dir eine Voreinstellung. Das ist nicht das Problem.

Hast Du mal "get" statt "mget" probiert? "mget" ist einfach per definitionem für das Übertragen mehrerer Daten geschaffen worden. Wer wie Du nur eine Datei herunterladen will, sollte deshalb das dafür existierende "get" nehmen.

Ist bei Dir der "Ausführliche Modus" (Befehl: "verbose") eingeschaltet? Was mich wundert ist nämlich, dass keine Statusmeldung zurückgegeben wird. Auch wenn ein Befehl hängt oder so etwas sollte eigentlich eine Statusmeldung über den Fehler zurückgegeben werden....


TIM
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
gelöst Update mehrerer Verzeichnisse auf FTP-Server (3)

Frage von caspi-pirna zum Thema Batch & Shell ...

TK-Netze & Geräte
IP Cam und FTP Server auf der EasyBox (11)

Frage von RaMimi zum Thema TK-Netze & Geräte ...

Windows Server
Windows Server 2012R2 - IIS - FTP Benachrichtigung bei FTP Anmeldung (3)

Frage von MultiStorm zum Thema Windows Server ...

Neue Wissensbeiträge
Google Android

Cyanogenmod alternative Downloadquelle

(2)

Tipp von Lochkartenstanzer zum Thema Google Android ...

Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(5)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Heiß diskutierte Inhalte
Windows 7
gelöst Lokales Adminprofil defekt (25)

Frage von Yannosch zum Thema Windows 7 ...

LAN, WAN, Wireless
gelöst Statische Routen mit ISC-DHCP Server für Android Devices (22)

Frage von terminator zum Thema LAN, WAN, Wireless ...

Server
gelöst Wie erkennen, dass nur deutsche IPs Zugang zu einer Website haben? (22)

Frage von Coreknabe zum Thema Server ...

Exchange Server
gelöst Migration Exchange 2007 zu 2013 - Public Folder teilweise weg (16)

Frage von Andy1987 zum Thema Exchange Server ...