Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

FTP Error 425 auf Windows Server 2008

Frage Microsoft Windows Server

Mitglied: Eyeless

Eyeless (Level 1) - Jetzt verbinden

19.04.2009, aktualisiert 12:54 Uhr, 10679 Aufrufe, 8 Kommentare

Hallo,
ich bin relativ neu im Servergelände unter Windows...und zumindest mein erster Eindruk ist, dass die Konfiguration der Standarddienste hier etwas weniger intuitiv als unter Linux läuft ;) von daher wäre ich über eure Hilfe sehr sehr dankbar!

Ich habe auf meinem Windows 2008 Server IIS 7 als Webserver laufen und habe die FTP-Rolle nachinstalliert.
Ziel ist es einen Benutzer auf ein bestimmtes verzeichnis per FTP (ganz normales FTP, kein SSL oder ähnliches) zugreifen zu lassen. Hierfür will ich die Windowsauthentifizierung verwenden, da der Nutzer hier auch schon ein Konto hat.

Ich habe die FTP-Seite entsprechend diesem Tutorial
eingerichtet und kann mich per Filezilla auf den Server verbinden. Sobald ich jedoch eingeloggt bin, versucht er LIST zu machen
und ich erhalte die Meldung:

Befehl: LIST
Antwort: 425 Can't open data connection.

Ich habe bereits mithilfe von dieser Anleitung den Port 21 bei mir freigegeben, jedoch ohne Ergebnis. Zudem habe ich auch noch die Ports 20 und 22 in beide Richtungen freigegeben, was an anderer Stelle empfohlen wurde (aber eigentlich sollte Windows den Port ja dynamisch festlegen). Die Firewall ist bei mir für den öffentlichen Bereich aktiviert, läßt jedoch nach Außen bestimmte Verbindungen zu. Ich habe sie auch schonmal auf alle 'zulassen' gestellt, was jedoch keinerlei Änderung zur Folge hatte. Leider bin ich im Forum nicht fündig geworden, denn alle, die einen ähnlichen Fehler haben, konnten ihn mit einer der beschriebenen Methoden lösen.
Hat jemand ne Idee, woran das noch liegen könnte?

Vielen Dank im vorraus!
Mitglied: Nailara
19.04.2009 um 17:59 Uhr
Hi,

das hört sich so an, als wäre das W2K8 irgendwo weit weg in der Firma und der Client zu Hause. Dazwischen steht bestimmt noch eine Firewall mit NAT.

Variante a)
Versuche den Zugriff mit passiven FTP - Filezilla hat da glaube ich einen Haken.

Variante b)
Überprüfe die NTFS-Berechtigungen des Nutzers mit dem Du Dich anmeldest auf dem W2K8-Server.

Mathias
Bitte warten ..
Mitglied: Eyeless
19.04.2009 um 20:11 Uhr
Hi,
danke für deine Antwort!

das hört sich so an, als wäre das W2K8 irgendwo weit weg in
der Firma und der Client zu Hause. Dazwischen steht bestimmt noch eine
Firewall mit NAT.
Jipp, der Server ist ein Ende weit weg, ich nehme an, dass es dazwischen eine Adressesnumwandlung gibt.


Variante a)
Versuche den Zugriff mit passiven FTP - Filezilla hat da glaube ich
einen Haken.
Filezilla springt automatisch in den Passiven Modus bevor er mir sagt, dass er das Verzeichnis nicht auflisten kann. Die komplette Ausgabe von Filezilla ist:

Status: Verbindung hergestellt, warte auf Willkommensnachricht...
Antwort: 220 Microsoft FTP Service
Befehl: USER Benutzername
Antwort: 331 Password required for Benutzername
Befehl: PASS

Antwort: 230 User Benutzername logged in.
Befehl: SYST
Antwort: 215 Windows_NT
Befehl: FEAT
Antwort: 211-Extended features supported:
Antwort: SIZE
Antwort: MDTM
Antwort: 211 END
Status: Verbunden
Status: Empfange Verzeichnisinhalt...
Befehl: PWD
Antwort: 257 "/" is current directory.
Befehl: TYPE I
Antwort: 200 Type set to I.
Befehl: PASV
Antwort: 227 Entering Passive Mode (IP des Servers).
Befehl: LIST
Antwort: 425 Can't open data connection.
Fehler: Verzeichnisinhalt konnte nicht empfangen werden



Variante b)
Überprüfe die NTFS-Berechtigungen des Nutzers mit dem Du
Dich anmeldest auf dem W2K8-Server.
Also sowohl der Nutzer selber, als auch die Gruppe, in der er sich befindet haben Lese/Schreibrechte auf dem Zielordner. Habe ihnen zum Test mal Vollzugriff gegeben, hat aber nichts geändert.

Hab grad mal versucht vom Server selber zuzugreifen, aber auch da sagt er mir, dass er die Dataconnection nicht öffnen kann ... das klingt für mich so, als würde es an was Lokalem liegen, gibt es noch ne Option oder sowas, die sowas verursachen kann?

Gruß Eyeless
Bitte warten ..
Mitglied: Nailara
19.04.2009 um 20:56 Uhr
Wenn es lokal schon nicht klappt, dann schalte doch mal die Windows Firewall aus.

Die Dataconnection wird bei passivem FTP auf Port 20 gemacht - der sollte also generell für Senden und Empfangen mit offen sein. Bei dynamischem FTP wird der Dataport erst ausgehandelt und das wäre schlecht, weil kaum beeinflussbar.

Mathias
Bitte warten ..
Mitglied: Eyeless
19.04.2009 um 21:08 Uhr
mmmh....FW ist aus, das ändert gar nichts, weder lokal noch übers Netz ist der Zugriff möglich .... das ist komisch....

Eyeless
Bitte warten ..
Mitglied: Nailara
19.04.2009 um 21:24 Uhr
Ist da ein Virenschutz installiert, möglicherweise eine ganze Security-Suite mit eigener Firewall?

Was sagt

netstat -n -a

Ist Port 20 schon irgendwie belegt?
Bitte warten ..
Mitglied: Eyeless
19.04.2009 um 21:45 Uhr
Nope, das ist ein nackter Server, da ist nichts ausser ner Website drauf (mit Gallery2)

Hier die Ausgabe:

PS C:\Users\Administrator> netstat -n -a

Aktive Verbindungen

Proto Lokale Adresse Remoteadresse Status
TCP 0.0.0.0:7 0.0.0.0:0 ABHÖREN
TCP 0.0.0.0:9 0.0.0.0:0 ABHÖREN
TCP 0.0.0.0:13 0.0.0.0:0 ABHÖREN
TCP 0.0.0.0:17 0.0.0.0:0 ABHÖREN
TCP 0.0.0.0:19 0.0.0.0:0 ABHÖREN
TCP 0.0.0.0:21 0.0.0.0:0 ABHÖREN
TCP 0.0.0.0:21 0.0.0.0:0 ABHÖREN
TCP 0.0.0.0:80 0.0.0.0:0 ABHÖREN
TCP 0.0.0.0:135 0.0.0.0:0 ABHÖREN
TCP 0.0.0.0:445 0.0.0.0:0 ABHÖREN
TCP 0.0.0.0:3306 0.0.0.0:0 ABHÖREN
TCP 0.0.0.0:3389 0.0.0.0:0 ABHÖREN
TCP 0.0.0.0:8172 0.0.0.0:0 ABHÖREN
TCP 0.0.0.0:49152 0.0.0.0:0 ABHÖREN
TCP 0.0.0.0:49153 0.0.0.0:0 ABHÖREN
TCP 0.0.0.0:49154 0.0.0.0:0 ABHÖREN
TCP 0.0.0.0:49155 0.0.0.0:0 ABHÖREN
TCP 0.0.0.0:49156 0.0.0.0:0 ABHÖREN
TCP 0.0.0.0:49157 0.0.0.0:0 ABHÖREN
TCP 0.0.0.0:49171 0.0.0.0:0 ABHÖREN
TCP 127.0.0.1:42424 0.0.0.0:0 ABHÖREN
TCP 127.0.0.1:50084 127.0.0.1:50085 HERGESTELLT
TCP 127.0.0.1:50085 127.0.0.1:50084 HERGESTELLT
TCP 127.0.0.1:50087 127.0.0.1:50088 HERGESTELLT
TCP 127.0.0.1:50088 127.0.0.1:50087 HERGESTELLT
TCP öffentl. ServerIP:21 77.4.181.75:50221 HERGESTELLT
TCP öffentl. ServerIP:139 0.0.0.0:0 ABHÖREN
TCP öffentl. ServerIP:3389 77.4.181.75:50217 HERGESTELLT
TCP [::]:7 [::]:0 ABHÖREN
TCP [::]:9 [::]:0 ABHÖREN
TCP [::]:13 [::]:0 ABHÖREN
TCP [::]:17 [::]:0 ABHÖREN
TCP [::]:19 [::]:0 ABHÖREN
TCP [::]:21 [::]:0 ABHÖREN
TCP [::]:80 [::]:0 ABHÖREN
TCP [::]:135 [::]:0 ABHÖREN
TCP [::]:445 [::]:0 ABHÖREN
TCP [::]:3389 [::]:0 ABHÖREN
TCP [::]:8172 [::]:0 ABHÖREN
TCP [::]:49152 [::]:0 ABHÖREN
TCP [::]:49153 [::]:0 ABHÖREN
TCP [::]:49154 [::]:0 ABHÖREN
TCP [::]:49155 [::]:0 ABHÖREN
TCP [::]:49156 [::]:0 ABHÖREN
TCP [::]:49157 [::]:0 ABHÖREN
TCP [::]:49171 [::]:0 ABHÖREN
UDP 0.0.0.0:7 *:*
UDP 0.0.0.0:9 *:*
UDP 0.0.0.0:13 *:*
UDP 0.0.0.0:17 *:*
UDP 0.0.0.0:19 *:*
UDP 0.0.0.0:123 *:*
UDP 0.0.0.0:500 *:*
UDP 0.0.0.0:3456 *:*
UDP 0.0.0.0:4500 *:*
UDP 0.0.0.0:5355 *:*
UDP 127.0.0.1:3456 *:*
UDP öffentl. ServerIP:137 *:*
UDP öffentl. ServerIP:138 *:*
UDP [::]:7 *:*
UDP [::]:9 *:*
UDP [::]:13 *:*
UDP [::]:17 *:*
UDP [::]:19 *:*
UDP [::]:123 *:*
UDP [::]:500 *:*
UDP [::]:5355 *:*


Für mich sieht das so aus, als wär Port 20 nicht belegt!
Bitte warten ..
Mitglied: Nailara
19.04.2009 um 23:03 Uhr
Hm - bei Microsoft gibt es einen kostenfreien Netzwerkmonitor. Damit kann man die Netzwerkverbindungen tracen.

Installier den mal auf dem Server und versuche dann von der Kommandozeile mit ftp die Verbindung aufzubauen. Wenn das funktioniert, dann gib hier PASV an und dann LIST.

Nebenbei kannst Du im Netzwerkmonitor schauen, ob da irgendwo doch noch die Verbindung abgewiesen wird...
Bitte warten ..
Mitglied: ChrisNbg
18.08.2011 um 22:12 Uhr
Servus,

ich hab hier mit meinem neuen 1und1 Dedi auch so meine Probleme mit dem Filezilla Server. Der PASV-Mode will ums verrecken nicht. Aktiv klappt alles super, aber der passiv geht nix...
Ich hab heut schon das "halbe Internet" umgepflügt, aber keine Lösung gefunden. Erst mal zu meinen Daten:
- Windows Server 2008R2 SP1 Std. x64
- Filezilla 0.9.39 (auch mit 38 und 37 getestet)

Ich habe auch Firewall von 1und1 mal konfiguriert sowie abgeschaltet auch mit Windows Firewall...
Ich habe das Problem auch mal mit CurrPorts von NirSoft analysiert. Das Problem scheint zu sein, dass Filezilla den Port für den PASV-Mode nicht richtig an die IP bindet. CurrPorts zeigt an, dass FZS auf dem konfigurierten Port lauscht, aber nicht die richtige öffentliche IP binden. Komischer weiße zeigts immer 0.0.0.0 an statt 217.160.x.x (so wie beim Port 21....)

Das Problem ist übrigens Lokal sowie über einen externen Rechner reproduzierbar. Wie gesagt, wenn ich den Client anweise dass er aktiv verbinden soll flutscht alles super, aber automatisch versucht er normalerweise IMMER PASV...und dann kommt immer der 425er Fehler.

Kann das nicht a Bug vom FZS sein? Ich habe aktuell noch einen Server 2003R2x64 laufen mit der gleichen Config. ich habe mal alles Files von FZS kopiert und gestartet. Ergebnis ist das selbe mit dem 0.0.0.0-Bindungs-Problem

FZS ist übrigens in der Config auch über all wo es geht auf die feste öffentliche IP konfiguriert...

PS: den FTPSVR-Dienst von Windows hab ich auch schon deaktiviert...

ich weiß echt nicht weiter. Mir würde es ja schon helfen wenn man den PASV-Modus deaktivieren könnte, scheint aber auch nicht möglich zu sein... echt nerfig.

Weiß jemand Rat?
Ich danke schonmal!
Lg
Christian
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (14)

Frage von liquidbase zum Thema Windows Update ...