Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

ftp put lädt datei nicht korrekt hoch - normaler ftp-client schon

Frage Entwicklung Batch & Shell

Mitglied: Lousek

Lousek (Level 2) - Jetzt verbinden

04.09.2008, aktualisiert 05.09.2008, 6881 Aufrufe, 4 Kommentare

Hallo Forum.

Ich habe hier ein kleines Problem mit einem Batch-Script.
Das Script lädt Bilder (.jpg) per ftp put auf den FTP-Server ...
Dies funktioniert alles auch.
Wenn ich jedoch auf dem Webspace den Bildpfad eingebe (z.B. /manana/imagine_manana_001.jpg) auf ein Bild das ich mit dieser Methode (ftp put also ftp ... open ... put ... bye) hochgeladen habe, steht dort einfach der Pfad (http://mein.beispiel.de/manana/imagine_manana_001.jpg).
Hochladen etc. verlief jedoch alles mit "File successfully transferred" usw.
Wenn ich jedoch das Bild mit einem FTP-Client (z.B. FlashFXP) an genau diesselbe Stelle hochlade, und den genau gleichen Pfad eingebe (z.B. /manana/imagine_manana_001.jpg), kommt das Bild als "Vorschau", also es wird halt einfach angezeit ... auch Links auf diese Bilder (<img src="...">) funktionieren ohne Probleme, bei der mit Batch hochgeladenen Bildern erscheint einfach ein "Bild nicht gefunden" resp. das kleine Zeichen dafür ...
Kann es sein, dass (trotz Erfolgmeldungen) die Bilder nicht korrekt übertragen werden?

Greetz, Lousek
Mitglied: aqui
04.09.2008 um 09:12 Uhr
Hast du bei der Batch Verarbeitung den FTP Client auch in den Binary Modus (bin Kommando) versetzt bevor der Transfer stattfindet ???
Ansonsten ist es möglich das die Datei im ASCII Modus gesendet wird was dann zu solchen Ergebnissen führt !
Bitte warten ..
Mitglied: Lousek
04.09.2008 um 11:35 Uhr
Nee, ist mir auch aufgefallen, mit binary funktionierts =)
Trotzdem danke ;)
Bitte warten ..
Mitglied: aqui
05.09.2008 um 08:59 Uhr
OK, wenns denn jetzt funktioniert bitte
http://www.administrator.de/index.php?faq=32
nicht vergessen !
Bitte warten ..
Mitglied: Lousek
05.09.2008 um 14:51 Uhr
Bei mir wird er zwar schon als "Gelöst" markiert (sobald der erste eine Antwort geschrieben hat ... Bug?) ... aber scheinbar für euch nicht ... also setzte ich den Haken mal ...
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(2)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
CMS
Wordpress FTP Client im Frontend (4)

Frage von Yannosch zum Thema CMS ...

Windows Tools
Automatischer FTP-Upload ohne angemeldeten Benutzer (3)

Frage von SarekHL zum Thema Windows Tools ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (15)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...