Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

FTP-Zugriff hängt sich beim -list Befehl auf

Frage Hardware SAN, NAS, DAS

Mitglied: Legat1808

Legat1808 (Level 1) - Jetzt verbinden

05.10.2009 um 13:42 Uhr, 7951 Aufrufe, 6 Kommentare

Hallo zusammen!
Ich habe ein Problem beim Zuriff auf mein NAS via FTP von aussen.

Ich habe ein NAS von QNAP und es funktioniert auch soweit recht gut. Nun habe ich den FTP Dienst auf diesem Gerät aktiviert und kann auch problemlos mit jedem x-beliebigen FTP-Client drauf zugreifen - allerdings nur lokal.

Mein Server ist von aussen via DynDNS und Portforwarding erreichbar. Ich kann Ihn auch anpingen usw.

Wenn ich mich nun von extern mit einem FTP-Client anmelden will, kann ich sehen dass ich Ordnungsgemäß angemeldet werde, er läuft auch durch, bis zum Befehl "-list" dann ist Schluss.


Wo könnte hier der Fehler liegen? Serverseitig habe ich dahingehend keine weiteren Einstellmöglichkeiten gefunden. Mit dem Putty kann ich mich auch connecten, jedoch kenn ich die UNIX-Befehle nicht, wo ich den FTP Dienst manuell Konfigurieren kann.

Freue mich gern über hilfe oder Tipps.
Mitglied: D3S3RT
05.10.2009 um 14:13 Uhr
Lies dich mal in aktiv und passiv bei FTP Verbindungen ein. Hier liegt der Hase begraben.
Bitte warten ..
Mitglied: Legat1808
05.10.2009 um 14:21 Uhr
Hallo!

Ich habe auch das bereits ins Auge gefasst und der Client verbindet sich im Aktiv Modus... da der Server in der Tat wohl Problem mit dem PASV - Mode hat.
Bitte warten ..
Mitglied: aqui
05.10.2009 um 14:51 Uhr
Versuch mal den Zugriff mit einem Browser wie dem Firefox ala ftp://<ftp_adresse>. Der benutzt immer den Passive Modus !

Details zum Active Passive Modus findest du hier:
http://www.alenfelder.com/Informatik/pass-akt-ftp.html
Bitte warten ..
Mitglied: Legat1808
05.10.2009 um 15:16 Uhr
Vielen Dank für den Link, jedoch habe ich bereits beid Varianten durchgespielt.
LogOn ist ja schon erfolgreich, aber egal welchen Client ich nehme, er "stirbt" bei diesem Befehl:

200 PORT command successful
LIST

Ab hier ist schluß. Auch habe ich bereits die Browser Variante Probiert, welche sich dann auch mehr oder weniger aufgehangen hat. Er fragt noch die Userdaten ab und das Wars dann auch schon. Kann es sein, das ich die FW Falsch konfiguriert habe?
Bitte warten ..
Mitglied: aqui
06.10.2009 um 11:12 Uhr
Dann bleibt fast nur noch ein Fragementierungsproblem übrig. Hast du mal versucht die MTU auf deinem DSL Router etwas zu verkleinern, z.B. auf 1440 ??
Damit solltest du mal etwas spielen. Am QNAP wirst du das ja wohl kaum customizen können.
Bitte warten ..
Mitglied: Legat1808
08.12.2009 um 15:37 Uhr
Hallo,

ich habe es nun nach einigem nachdenken selbst hinbekommen Es lag tatsächlich an der Firwall des Routers ( Speedport W701V)
Portforwarding war da zwar richtig konfiguriert, allerdings wollter diese Firewall den Server nochmal Explicit angegebne haben - keine Ahnung warum. ich werde mich mit diesem Router auch nicht weiter beschäftigen, da ich mir einen anderen zulegen werde. Besten Dank für die denkanstöße.

MFg
Bitte warten ..
Ähnliche Inhalte
Windows Server
FTP-Zugriff auf Server2016 Essential (1)

Frage von angler2001 zum Thema Windows Server ...

Windows Server
FTP Zugriff per VPN auf Server 2008 - Fehler (2)

Frage von Markowitsch zum Thema Windows Server ...

Windows Server
Windows 2008 Terminalserver hängt (10)

Frage von Aubanan zum Thema Windows Server ...

Neue Wissensbeiträge
Linux Netzwerk

Ping und das einstellbare Bytepattern

(1)

Erfahrungsbericht von LordGurke zum Thema Linux Netzwerk ...

Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

(3)

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Viren und Trojaner

CNC-Fräsen von MECANUMERIC werden (ggf.) mit Viren, Trojanern, Würmern ausgeliefert

(4)

Erfahrungsbericht von anteNope zum Thema Viren und Trojaner ...

Heiß diskutierte Inhalte
SAN, NAS, DAS
MSA 2050 RAID Konfig (27)

Frage von Leo-le zum Thema SAN, NAS, DAS ...

Netzwerkmanagement
Windows Server 2008 R2: "netsh reset" nicht verfügbar? (11)

Frage von RickTucker zum Thema Netzwerkmanagement ...

Microsoft Office
Outlook 2016 in Ordneransicht starten - GPO (8)

Frage von D-Line zum Thema Microsoft Office ...

Outlook & Mail
Outlook Suche liefert kein Ergebnise mehr (8)

Frage von Bjoern-B zum Thema Outlook & Mail ...