Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Fußball-Punktetabelle

Frage Microsoft Microsoft Office

Mitglied: 29457

29457 (Level 2)

22.02.2009, aktualisiert 12:57 Uhr, 8664 Aufrufe, 5 Kommentare

nicht von dem etwas längeren Text abschrecken lassen, eigentliches Problem ist weiter unten und unterstrichen

Guten Morgen,

also ich habe jetzt bei Excel (viel mehr OpenOffice -> scheint aber von den Funktionen fast identisch zu sein) versucht eine Fußball-Punktetabelle zu erstellen, jedoch scheitere ich an der Ausgabe.

Man kann die Begegnungen aufschreiben und den Punktestand auch.
Gezählt wird bisher nur die Gesamtzahl der Tore. -> Das ist ja auch nicht weiter schwer, einfach nur die Summe.

Nun scheitere ich jedoch bei dem Zählen der Siege, Niederlagen etc.

Ich habe es zwar schon geschafft, dass in einer anderen Zelle bspw. eine 3 (3 Punkte) ausgegeben wird, wenn die eine Mannschaft mehr Tore hat, als die andere (ZÄHLE WENN), jedoch muss ich dann ja für jedes Spiel eine extra Zelle machen.

Und hiermit kommen wir zu meinem nächsten Problem:
Ich habe das mit den eigenen Zellen für jedes Spiel nun gemacht, und die Ausgabe ist auch richtig. D.h. dass wenn Mannschaft A gewinnt, steht in einer anderen Zelle "3".
Der Fehler ist nun aber, dass ich mehrere Zellen, bei denen ich dieses ZÄHLE WENN angewendet habe, nicht addieren kann.
Es kommt immer 0 raus.


Ich mache mal eine kleine Beispieltabelle:
Mannschaft A - Mannschaft B: 0:1
Mannschaft B - Mannschaft C: 3:2

Hier hat nun Mannschaft B insgesamt 4 Tore geschossen (SUMME).
Wie kann ich nun anzeigen lassen, dass Mannschaft B 2x gewonnen hat?
Es soll quasi in einer anderen Zelle "2" stehen.



Vielen Dank schonmal für die Hilfe!
Mitglied: bastla
22.02.2009 um 11:57 Uhr
Hallo Rabbit23!

Unter der Annahme, dass die einzelnen Spiele in den Zellen A1:D90 (entspräche den Spielen einer 10er-Liga mit Hin- und Rückrunde, kann aber auch zB A1:A240 für eine 16er-Liga etc sein) stehen:
  • Spalte A: Heimmannschaft
  • Spalte B:Auswärtsmannschaft
  • Spalte C:Tore der Heimmannschaft
  • Spalte D:Tore der Auswärtsmannschaft

und ab H2 die Übersicht zeilenweise mit folgenden Inhalten
  • Mannschaftsname in exakt gleicher Schreibweise wie in den Spalten A und B
  • Anzahl Spiele
  • Anzahl Siege
  • Anzahl Unentschieden
  • Anzahl Niederlagen
  • Punkte
erstellt werden soll, sähe eine Lösung mit Array-Formeln etwa so aus:
H2: Mannschaft A 
I2: =SUMME(WENN($A$1:$A$90=H2;1;0)*WENN($B$1:$B$90<>H2;1;0);WENN($B$1:$B$90=H2;1;0)*WENN($A$1:$A$90<>H2;1;0)) 
J2: =SUMME(WENN($A$1:$A$90=H2;1;0)*WENN($C$1:$C$90>$D$1:$D$90;1;0);WENN($B$1:$B$90=H2;1;0)*WENN($D$1:$D$90>$C$1:$C$90;1;0)) 
K2: =SUMME(WENN($A$1:$A$90=H2;1;0)*WENN($C$1:$C$90=$D$1:$D$90;1;0);WENN($B$1:$B$90=H2;1;0)*WENN($D$1:$D$90=$C$1:$C$90;1;0)) 
L2: =SUMME(WENN($A$1:$A$90=H2;1;0)*WENN($C$1:$C$90<$D$1:$D$90;1;0);WENN($B$1:$B$90=H2;1;0)*WENN($D$1:$D$90<$C$1:$C$90;1;0)) 
M2: =SUMME(WENN($A$1:$A$90=H2;1;0)*WENN($C$1:$C$90>$D$1:$D$90;3;WENN($C$1:$C$90=$D$1:$D$90;1;0));WENN($B$1:$B$90=H2;1;0)*WENN($D$1:$D$90>$C$1:$C$90;3;WENN($D$1:$D$90=$C$1:$C$90;1;0)))
Die Berechnung der Punkte kann natürlich auch mit
=J2*3+K2
erfolgen (und sollte auch zusätzlich so ermittelt werden) - die Formel für M2 dient der Plausibilitätskontrolle.

Alternative zu dieser Art der Überprüfung: I2 (hier werden nur Spiele gezählt, bei denen die Mannschaft entweder Heim- oder Auswärtsmannschaft, aber nicht beides ist) muss der Summe von J2:L2 (bei der Berechnung dieser Anzahlen wird die Kontrolle des "oder" nicht vorgenommen) entsprechen.
Falls Dir Array-Formeln nicht geläufig sein sollten: Zu erkennen ist eine solche Formel daran, dass sie zwischen "{" und "}" steht, wobei diese Zeichen nicht einzugeben sind, sondern von Excel selbst gesetzt werden - ich habe sie daher (damit die Formel leichter zu kopieren ist) oben weg gelassen - die Formel für I2 wird nach der Eingabe in der Bearbeitungszeile so dargestellt:
I2: {=SUMME(WENN($A$1:$A$90=H2;1;0)*WENN($B$1:$B$90<>H2;1;0);WENN($B$1:$B$90=H2;1;0)*WENN($A$1:$A$90<>H2;1;0))}
Einzugeben ist die Formel (auch nach jeder Bearbeitung) mit der Tastenkombination Strg+Umsch+Enter.

Zur Funktionsweise: Jene Bestandteile der Formel, für welche ein Bereich angegeben wurden, werden für jede einzelne Zelle des Bereiches je einmal ausgeführt - daher also die Berechnung der gesamten Anzahl an Spielen (in I2) so:
  • Wenn A1 = H2 (Mannschaft, für welche die Werte ermittelt werden sollen) nimm 1, ansonsten 0 und
  • multiplliziere mit dem Ergebnis (1 oder 0) des Vergleiches für B1 <> H2;
  • nur, wenn die Mannschaft in A1, aber nicht in B1 steht, ist das Ergebnis hier 1, in allen anderen Fällen 0;

  • führe die selbe Überprüfung mit umgekehrten Vorzeichen aus: die in H2 stehende Mannschaft soll also Auswärts- (Spalte B), aber nicht Heimmannschaft (Spalte a) sein - Ergebnis wiederum nur dann 1, wenn dieser beiden Bedingungen zutreffen und

  • bilde abschließend die Summe aus den beiden Teilergebnissen - kann nur 1 (wenn die Mannschaft aus H2 nur entweder Heim- oder Auswärtsmannschaft war) oder 0 (alle anderen Fälle: Mannschaft kommt in Spiel der Zeile 1 nicht oder als Heim- und Auswärtsmannschaft vor)

  • Wiederhole diesen Vorgang (deswegen die Array-Formel) für alle Zellen der Spalten A und B bis zu A90 bzw B90 und

  • bilde am Ende die Gesamtsumme (entspricht dem Abzählen aller "1"-Ergebnisse der einzelnen Zeilen).

Analog dazu die Vorgangsweise für die Berechnung der Siege etc, wobei hier nur darauf geachtet wird, ob im jeweils betrachteten Spiel die Mannschaft aus H2 beteiligt war, zB steht in J2 der Teil:
WENN($A$1:$A$90=H2;1;0)*WENN($C$1:$C$90>$D$1:$D$90;1;0)
für die Überprüfung, ob als Heimmannschaft gewonnen wurde und

WENN($B$1:$B$90=H2;1;0)*WENN($D$1:$D$90>$C$1:$C$90;1;0)
für einen Sieg als Auswärtsmannschaft, wobei in beiden Fällen zunächst wiederum 1 oder 0 als Kennzeichen für "Mannschaft war Heim-/Auswärtsmannschaft" zugeordnet wird, und nur wenn das Ergebnis 1 lautet, kann aus der Multiplikation mit der Überprüfung auf Sieg (= mehr Tore erzielt - ergibt wiederum Teilergebnis 1) als Gesamtergebnis des betrachteten einzelnen Spieles eine (durch die "darübergestülpte" Summen-Formel "zählbare") 1 entstehen.

Grüße
bastla
Bitte warten ..
Mitglied: 29457
22.02.2009 um 12:56 Uhr
Vielen vielen Dank für deine ausführliche Antwort!

Bitte warten ..
Mitglied: 29457
22.02.2009 um 13:17 Uhr
Hmm..
Ich habe es mal ausprobiert und irgendwie klappt es leider immer noch nicht


Könntest du dir das evtl mal anschauen und vllt dort einfügen?

http://aniloeztas.kilu.de/punktetabelle.xls
Bitte warten ..
Mitglied: bastla
22.02.2009 um 13:35 Uhr
Hallo Rabbit23!

Meine Formel war darauf ausgelegt, die einzelnen Mannschaften anhand ihres Namens zu unterscheiden - in Deiner Tabelle müsstest Du dann zB in K3 "FC ARSENAL" eintragen und könntest dann folgende Formel in K4 verwenden:
=SUMME(WENN($B$2:$B$56=K3;1;0)*WENN($C$2:$C$56>$D$2:$D$56;1;0);WENN($E$2:$E$56=K3;1;0)*WENN($D$2:$D$56>$C$2:$C$56;1;0))
Wenn Du aber tatsächlich nur vergleichen willst, wie oft die in Spalte B angegebenen Mannschaften gewonnen haben, genügt:
=SUMME(WENN($C$2:$C$56>$D$2:$D$56;1;0))
- auch das ist (wie oben) eine Array-Formel und daher mit den 3 Tasten Strg+Umsch+Enter abzuschließen.

Für die Ermittlung der Unentschieden und Niederlagen wäre dann jeweils nur das Vergleichszeichen ">" auf "=" oder "<" zu ändern.

Grüße
bastla
Bitte warten ..
Mitglied: 29457
23.02.2009 um 11:32 Uhr
Jetzt klappt es

Vielen Dank!
Bitte warten ..
Neue Wissensbeiträge
Windows 10

Autsch: Microsoft bündelt Windows 10 mit unsicherer Passwort-Manager-App

Tipp von kgborn vor 1 TagWindows 103 Kommentare

Unter Microsofts Windows 10 haben Endbenutzer keine Kontrolle mehr, was Microsoft an Apps auf dem Betriebssystem installiert (die Windows ...

Sicherheits-Tools

Achtung: Sicherheitslücke im FortiClient VPN-Client

Tipp von kgborn vor 1 TagSicherheits-Tools

Ich weiß nicht, wie häufig die NextGeneration Endpoint Protection-Lösung von Fortinet in deutschen Unternehmen eingesetzt wird. An dieser Stelle ...

Internet

USA: Die FCC schaff die Netzneutralität ab

Information von Frank vor 1 TagInternet5 Kommentare

Jetzt beschädigt US-Präsident Donald Trump auch noch das Internet. Der neu eingesetzte FCC-Chef Ajit Pai ist bekannter Gegner einer ...

DSL, VDSL

ALL-BM200VDSL2V - Neues VDSL-Modem mit Vectoring von Allnet

Information von Lochkartenstanzer vor 1 TagDSL, VDSL2 Kommentare

Moin, Falls jemand eine Alternative zu dem draytek sucht: Gruß lks

Heiß diskutierte Inhalte
Windows Server
GPO nur für bestimmte Computer
Frage von Leo-leWindows Server13 Kommentare

Hallo Forum, gern würde ich ein Robocopy script per Bat an eine GPO hängen. Wichtig wäre aber dort der ...

Windows Server
KMS Facts for Client configuration
Frage von winlinWindows Server13 Kommentare

Hey Leute, wir haben in unserem Netz nun einen neuen KMS Server. Haben Bestands-VMs die noch nicht aktiviert sind. ...

Router & Routing
OpenWRT bzw. L.E.D.E auf Buffalo WZR-HP-AG300H - update
gelöst Frage von EpigeneseRouter & Routing11 Kommentare

Guten Tag, ich habe auf einem Buffalo WZR-HP-AG300H die alternative Firmware vom L.E.D.E Projekt geflasht. Ich bin es von ...

Windows Tools
Software-Tool zum Entfernen von bösartigem Windows
Frage von emeriksWindows Tools11 Kommentare

Hi, siehe Betreff hat das jemals irgendjemand schonmal sinnvoll eingesetzt? (MRT) E.