Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

funktion vergleich() über mehrere tabellen

Frage Microsoft Microsoft Office

Mitglied: 39263

39263 (Level 1)

27.04.2007, aktualisiert 30.04.2007, 8778 Aufrufe, 4 Kommentare

hallo,

man kann ja über die funktion vergleich() in excel verschieden zeilen oder spalten miteinander vergleichen.
in meinem fall möchte ich doppelte einträge anzeigen lassen, was dann folgendermaßen aussieht:
=WENN(VERGLEICH(A1;1:1;0)=SPALTE();"";"schon vorhanden")
nun möchte ich aber auch über mehrere tabellen (alle in einem dokument) hinweg die spalten überprüfen.
(bsp: die verschieden tabellen sind verschiedene jahreszahlen und nun soll excel herausfinden ob der hr. mustermann in der tabelle 2005 UND in 2006 auftaucht)

danke schonmal im vorraus

mfg, torsten
Mitglied: 8644
27.04.2007 um 11:57 Uhr
Hi,

einfach den Tabellennamen vor den Bezug setzen:

01.
=Wenn(Vergleich(Tabelle2!A1 ...
Das Ausrufezeichen nicht vergessen!

Psycho
Bitte warten ..
Mitglied: 8644
27.04.2007 um 12:18 Uhr
Ich noch mal,

war nicht richtig, was ich dir da geschrieben habe - sorry;

Schau dir mal die Funktionen sverweis und wverweis an, damit sollte was gehen.

Psycho
Bitte warten ..
Mitglied: bastla
27.04.2007 um 17:00 Uhr
Hallo cableselected!

Vielleicht kannst Du noch etwas genauer ausführen, wie Dein gewünschtes Ergebnis aussehen soll, insbesondere, da Dein angeführtes Beispiel eine Zeile auf mehrfach vorkommende Einträge hin überprüft, während Du in Zukunft "über mehrere tabellen (alle in einem dokument) hinweg die spalten überprüfen" willst ...

Grüße
bastla
Bitte warten ..
Mitglied: 8644
30.04.2007 um 11:25 Uhr
Hi,

Hier mal ein ganz anderer Ansatz:

01.
=WENN(SUMME(ZÄHLENWENN('2005!B1:B100;A1);ZÄHLENWENN('2006!B1:B100;A1))>0;"Vorhanden";"")
Also einfach das Vorkommen zählen und wenn das Ergebnis größer Null ist, den entsprechenden Text ausgeben.

Psycho
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
Vergleich von 2 Tabellen in Excel
gelöst Frage von abuelitoMicrosoft Office4 Kommentare

Hallo an Alle, folgendes Problem: Ich habe eine Exceldatei mit 2 Tabellen. Spalten sind identisch. Tabelle1 hat aktuelle Daten ...

VB for Applications
Exceltabelle mit anderen 2 tabellen vergleichen
gelöst Frage von 123660VB for Applications12 Kommentare

Hallo zusammen! Ich stehe vor folgendem Problem und bräuchte wieder eure Hilfe. In Excel 2010 muss ich Tabelle 1 ...

Microsoft
Tabellen miteinander vergleichen
Frage von Acht85Microsoft1 Kommentar

Hallo Community, ich habe 2 Tabellen mit Namen (die auch unterschiedlich geschrieben sein können, baer nicht mehrmals auftauchen) und ...

Microsoft Office
ACCESS Tabellen vergleichen
gelöst Frage von abuelitoMicrosoft Office4 Kommentare

Hallo, ich habe eine ACCESS 2003 Datenbank mit 2 Tabellen. Jede Tabelle hat nur eine Spalte. Tabelle1 hat ca. ...

Neue Wissensbeiträge
Windows 10

Autsch: Microsoft bündelt Windows 10 mit unsicherer Passwort-Manager-App

Tipp von kgborn vor 10 StundenWindows 101 Kommentar

Unter Microsofts Windows 10 haben Endbenutzer keine Kontrolle mehr, was Microsoft an Apps auf dem Betriebssystem installiert (die Windows ...

Sicherheits-Tools

Achtung: Sicherheitslücke im FortiClient VPN-Client

Tipp von kgborn vor 11 StundenSicherheits-Tools

Ich weiß nicht, wie häufig die NextGeneration Endpoint Protection-Lösung von Fortinet in deutschen Unternehmen eingesetzt wird. An dieser Stelle ...

Internet

USA: Die FCC schaff die Netzneutralität ab

Information von Frank vor 1 TagInternet3 Kommentare

Jetzt beschädigt US-Präsident Donald Trump auch noch das Internet. Der neu eingesetzte FCC-Chef Ajit Pai ist bekannter Gegner einer ...

DSL, VDSL

ALL-BM200VDSL2V - Neues VDSL-Modem mit Vectoring von Allnet

Information von Lochkartenstanzer vor 1 TagDSL, VDSL2 Kommentare

Moin, Falls jemand eine Alternative zu dem draytek sucht: Gruß lks

Heiß diskutierte Inhalte
TK-Netze & Geräte
VPN-fähige IP-Telefone
Frage von the-buccaneerTK-Netze & Geräte16 Kommentare

Hi! Weiss noch jemand ein VPN-fähiges IP-Telefon mit dem man z.B. einen Heimarbeitsplatz gesichert anbinden könnte? Habe nur einen ...

Windows Server
GPO nur für bestimmte Computer
Frage von Leo-leWindows Server12 Kommentare

Hallo Forum, gern würde ich ein Robocopy script per Bat an eine GPO hängen. Wichtig wäre aber dort der ...

Windows Server
KMS Facts for Client configuration
Frage von winlinWindows Server12 Kommentare

Hey Leute, wir haben in unserem Netz nun einen neuen KMS Server. Haben Bestands-VMs die noch nicht aktiviert sind. ...

Netzwerkgrundlagen
Laufwerkszuordnung mit zwei IPs
Frage von Alex29Netzwerkgrundlagen11 Kommentare

Hallo in die Runde, Ich als Hobbyadmin hätte mal wieder eine Frage an die Profis. Ich habe ein Netzwerk ...