Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

funktion vergleich() über mehrere tabellen

Frage Microsoft Microsoft Office

Mitglied: 39263

39263 (Level 1)

27.04.2007, aktualisiert 30.04.2007, 8699 Aufrufe, 4 Kommentare

hallo,

man kann ja über die funktion vergleich() in excel verschieden zeilen oder spalten miteinander vergleichen.
in meinem fall möchte ich doppelte einträge anzeigen lassen, was dann folgendermaßen aussieht:
=WENN(VERGLEICH(A1;1:1;0)=SPALTE();"";"schon vorhanden")
nun möchte ich aber auch über mehrere tabellen (alle in einem dokument) hinweg die spalten überprüfen.
(bsp: die verschieden tabellen sind verschiedene jahreszahlen und nun soll excel herausfinden ob der hr. mustermann in der tabelle 2005 UND in 2006 auftaucht)

danke schonmal im vorraus

mfg, torsten
Mitglied: 8644
27.04.2007 um 11:57 Uhr
Hi,

einfach den Tabellennamen vor den Bezug setzen:

01.
=Wenn(Vergleich(Tabelle2!A1 ...
Das Ausrufezeichen nicht vergessen!

Psycho
Bitte warten ..
Mitglied: 8644
27.04.2007 um 12:18 Uhr
Ich noch mal,

war nicht richtig, was ich dir da geschrieben habe - sorry;

Schau dir mal die Funktionen sverweis und wverweis an, damit sollte was gehen.

Psycho
Bitte warten ..
Mitglied: bastla
27.04.2007 um 17:00 Uhr
Hallo cableselected!

Vielleicht kannst Du noch etwas genauer ausführen, wie Dein gewünschtes Ergebnis aussehen soll, insbesondere, da Dein angeführtes Beispiel eine Zeile auf mehrfach vorkommende Einträge hin überprüft, während Du in Zukunft "über mehrere tabellen (alle in einem dokument) hinweg die spalten überprüfen" willst ...

Grüße
bastla
Bitte warten ..
Mitglied: 8644
30.04.2007 um 11:25 Uhr
Hi,

Hier mal ein ganz anderer Ansatz:

01.
=WENN(SUMME(ZÄHLENWENN('2005!B1:B100;A1);ZÄHLENWENN('2006!B1:B100;A1))>0;"Vorhanden";"")
Also einfach das Vorkommen zählen und wenn das Ergebnis größer Null ist, den entsprechenden Text ausgeben.

Psycho
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
gelöst Excel: Wert aus mehreren Zeilen vergleichen (2)

Frage von Nicolaas zum Thema Microsoft Office ...

Datenbanken
SQL - Mehrere Tabellen über JOINS verketten (1)

Frage von Gwahlers zum Thema Datenbanken ...

Windows 10
Windows 10 Multitasking Funktion - SnapAssist - geht nicht mehr (1)

Frage von freeuser616 zum Thema Windows 10 ...

Neue Wissensbeiträge
LAN, WAN, Wireless

Schwachstelle im WPA2 Protokoll veröffentlicht

(3)

Information von colinardo zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte