Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Wie funktioniert die SummeProdukt-Formel

Frage Microsoft Microsoft Office

Mitglied: fcmfanswr

fcmfanswr (Level 1) - Jetzt verbinden

07.10.2010 um 11:08 Uhr, 3408 Aufrufe, 6 Kommentare

Hallo,

ich habe im Internet folgende Formel gefunden:
=SUMMENPRODUKT(LÄNGE(C6:C26)-LÄNGE(WECHSELN(KLEIN(C6:C26);"+";)))

Mit dieser Formel errechne ich, wieviele "+" in Spalte C vorkommen.
Es funktioniert alles super, aber ich würde die Formel gerne verstehen.
Kann mir das jemand erklären?

Also: "(C6:C26)" gibt sicher den Bereich an, indem gesucht werden soll, was macht das "LÄNGE" davor?
Wozu ist der Ausdruck hinter dem "-" [LÄNGE(WECHSELN(KLEIN(C6:C26);"+";))] da? Was bewirkt das "-"?
Ja und allgemein, was heißt SummeProdukt, müßte dann in der Formel nicht irgendwo ein "*" stehen?

Vielen Dank und Viele Grüße
Mitglied: bastla
07.10.2010 um 11:30 Uhr
Hallo fcmfanswr!

Abgesehen davon, dass für das Abzählen der "+" in den Zellen C6:C26 ein
=ZÄHLENWENN(C6:C26;"+")
genügt, sollte "SUMMENPRODUKT()" besser "PRODUKTESUMME()" heißen - es wird damit die Summe der Produkte der angegebenen Bereiche gebildet, wobei es nur der Angabe der Bereiche, aber keines "*" bedarf (die Vorgabe "PRODUKT" bedeutet ja schon, dass multipliziert werden soll).

Eine andere Verwendung findet die Funktion (und so wäre es auch in Deinem Fall gedacht gewesen), um Arrays in Formeln zu holen, ohne eine eigentliche "Array"-Formel dafür erstellen zu müssen.

Grüße
bastla
Bitte warten ..
Mitglied: RobertG
07.10.2010 um 11:35 Uhr
Hallo!

Im Prinzip kann man es so erklären:

LÄNGE(C6:C26)-LÄNGE(WECHSELN(KLEIN(C6:C26);"+";))
Es wird zuerst die Länge des vollen Zellentextes ermittelt, davon abgezogen wird dann die Länge des Zellentextes bei dem man alle "+" herausgelöscht hat (mit WECHSELN()). Die Differenz ergibt dann die Anzahl der "+" dieser Zelle, auch dann falls mehrere "+" vorkommen.
Wie auffält steht als Bereichsparameter C6:C26.

SUMMENPRODUKT macht nun praktisch folgendes: es summiert alle diese Längendifferenzen je Zelle, also von C6 bis C26. Das ergibt dann die Gesamtanzahl der "+".

Ich hoffe das ist irgendwie verständlich ausgedrückt.

Liebe Grüße!

Robert
Bitte warten ..
Mitglied: Biber
07.10.2010 um 11:35 Uhr
Moin fcmfanswr,

Zitat von fcmfanswr:
Hallo,

ich habe im Internet folgende Formel gefunden:
...und warum müssen wir das dann ausbaden? *g

=SUMMENPRODUKT(LÄNGE(C6:C26)-LÄNGE(WECHSELN(KLEIN(C6:C26);"+";)))

Mit dieser Formel errechne ich, wieviele "+" in Spalte C vorkommen.
Es funktioniert alles super, aber ich würde die Formel gerne verstehen.
Kann mir das jemand erklären?
Schon.... aber es nichts dabei, was sich nicht durch Auflösen der Einzelschritten nicht selbst nachkaspern liesse..

Ich würde dir jedenfalls gern noch eine halbe Stunde Zeit zum Selber-Lösen lassen, das bringt dir mehr.


Also: "(C6:C26)" gibt sicher den Bereich an, indem gesucht werden soll, was macht das "LÄNGE" davor?
Hmmm... was könnte denn der Funktionsname "Länge()" suggerieren wollen?

Wozu ist der Ausdruck hinter dem "-" [LÄNGE(WECHSELN(KLEIN(C6:C26);"+";))] da?
Was bewirkt das> "-"?
Wenn jemand die Bedeutung des Minuszeichens petzt, dann lösch ich dessen Kommentar.

Ja und allgemein, was heißt SummeProdukt, müßte dann in der Formel nicht irgendwo ein "*" stehen?
Nun, "SummenProdukt" heißt soviel wie die Summe EINER Matrix ODER die Summe des Produkts mehrerer Matrizen.

Grüße
Biber
Bitte warten ..
Mitglied: fcmfanswr
07.10.2010 um 11:36 Uhr
Danke,

aber was heißt summer der produkte? was für Produkte?
und wofür ist der hintere teil der formel, ab dem "-"?

achja, hab es vergessen zu sagen =ZÄHLENWENN(C6:C26;"+") geht nicht, weil in einer zelle auch ++ oder +++ stehen kann.

Viele Grüße
Bitte warten ..
Mitglied: bastla
07.10.2010 um 11:39 Uhr
Hallo fcmfanswr!
geht nicht, weil in einer zelle auch ++ oder +++ stehen kann.
... wobei sich die Frage stellt, ob jedes einzelne "+" oder nur jede Zelle mit mindestens einem "+" gezählt werden soll - für ersteren Fall hast Du ja schon eine Formel, für die Variante 2 könntest Du
=ZÄHLENWENN(C6:C26;"*+*")
verwenden (und nein, da wird nix multipliziert ).

Grüße
bastla
Bitte warten ..
Mitglied: fcmfanswr
08.10.2010 um 10:24 Uhr
@ RobertG
Danke, veständlich erklärt.

@Biber
ich fühl mich natürlich jetzt schon ein bisschen dumm, wobei du natürlich nicht ganz unrecht hast... ;)
Irgendwie hat sich mir alleine das nicht erschloßen, wennauch die einzelnen Anweisungen garnicht so kompliziert sind.

Naja, wie auch immer, jedenfalls hab ich es jetzt verstanden und kann mir das nächste mal eine ähnliche Formel selber bauen...

Vielen Dank für eure Hilfe
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Linux
LTSP: PXE Boot funktioniert nicht (16)

Frage von Fenris14 zum Thema Linux ...

Virtualisierung
Drucker aus einer VM heraus funktioniert nicht (5)

Frage von NCCTech zum Thema Virtualisierung ...

LAN, WAN, Wireless
gelöst Netzwerk funktioniert nur in eine Richtung mit Gigabit (28)

Frage von DrChiwago zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...