Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Warum Funktioniert der tokens befehl nicht

Frage Entwicklung Batch & Shell

Mitglied: DomiZone1

DomiZone1 (Level 1) - Jetzt verbinden

26.11.2014 um 22:23 Uhr, 1177 Aufrufe, 5 Kommentare

Hallo liebe Administartor Community
Ich Beis gleich in mein nicht vorhandenes lenkrad :D
der befehl: for /f "delims=: tokens1,2" %%A in (<Befehl,pfad,datei>) do
Funktioniert bei mir GAR NICHT!
Daten Über das betriebs System
OS= Windows 7 Home Premium x64
Vor Relativ kurzem neu aufgesetzt (Davor gings auch nicht War aber nicht der gund :D)
und dieser befehl lässt mich im stich was muss ich tun das das klappt
Oder muss ich nur die befehls erweiterung Aktivieren/Deaktivieren

Danke im Vorraus

LG DomiZone1
Mitglied: Pjordorf
26.11.2014 um 22:38 Uhr
Hallo,

Zitat von DomiZone1:
Funktioniert bei mir GAR NICHT!
Definiere "GAR NICHT".

Verstehe ich es richtig das du in ein CMD Fenster deines W7 folgendes eintippelst
01.
for /f "delims=: tokens1,2" %%A in (<Befehl,pfad,datei>) do
und drückst die Enter Taste, oder?

Was soll Befehl zurückgeben? Soll es überhaupt etwas zurückgeben? Werden deine gewünschte Anzahl an Tokens zurückgegeben?

Aber ganz nebenbei. Auch dein W7 sollte irgend etwas schon ausspucken wenn du es so machst wie du geschrieben hast. Selbst ein "for nicht gefunden" oder sonst ein Blödsinn sollte erscheinen. Aber das dort dann GAR NICHTS dort steht .....

Oder muss ich nur die befehls erweiterung Aktivieren/Deaktivieren
Wenn du dir dadurch erhoffst das aus GAR NICHTS dann DOCH WAS wird....

Und das du ins Lenkrad gerade beißt ändert nichts an der mangelnden Informationen zu deiner vermeintlichen Frage. Vielleicht musst du einfach nur den Nippel durch die Lasche ziehen damit dein GAR NICHTS sich ändert......

Gruß,
Peter
Bitte warten ..
Mitglied: DomiZone1
26.11.2014 um 22:49 Uhr
Die Fehler meldung ist jedes mal:
"tokens1,2"" kann syntaktisch an dieser Stelle nicht verarbeitet werden.
das nervige ist diese "tokens" funktion soll mir einen fürs programm wichtigen wert/e zurück liefern
und dann kommt das problem ich verstehs net
obwohl ich früher auch immer so aufgebaut habe als ich mal von der cmd direkt sowas entnommen habe stand es Ähnlich
da fehler trat auf aber der war bei einer variable und nicht bei dem
der befehl hat aber zu viel unnötiges und tu ich es weg heisst es direkt wieder:
"tokens1,2"" kann syntaktisch an dieser Stelle nicht verarbeitet werden.
Das nerft richtig

LG DomiZone1
Bitte warten ..
Mitglied: rubberman
26.11.2014, aktualisiert um 22:54 Uhr
Hallo DomiZone1,

Bei delims schreibst du ein = , bei tokens aber nicht. Warum?

Wenn du einen Syntaxfehler ausgespuckt bekommst, ist es auch einer.

Grüße
rubberman
Bitte warten ..
Mitglied: Pjordorf
LÖSUNG 26.11.2014, aktualisiert 26.12.2014
Hallo,

Zitat von DomiZone1:
"tokens1,2"" kann syntaktisch an dieser Stelle nicht verarbeitet werden.
Warum hast du dies nicht sofort geschrieben. Und warum glaubst du dein OS nicht wenn es dir ein Syntaxfehler auf Silbertablett liefert. Wie rubberman schon anmerkte.... Hier noch ein kleiner Hinweis. Mach mal ein
01.
For /?
und schau dir die Syntax mal etwas genauer an. Das Fragezeichen hilft viel, auch wenn es nerfvt. Beim nächsten Einkauf solltest du dir Ersatz für deine defekte Tastatur mitbringen und nutzen...weil das nervt tatsächlich.

als ich mal von der cmd direkt sowas entnommen
?Entnommen? ?!?

stand es Ähnlich
Ähnlich ist aber nicht gut genug. Du willst auf dein gehaltscheck auch kein Ähnlich 1000 EUR lesen, sondern genau 1000 EUR stehen haben wollen

Aber schön wenn dein Code jetzt durch Anwenden der genauen Syntax nicht mehr GAR NICHTS macht als es noch so ähnlich war

Gruß,
Peter
Bitte warten ..
Mitglied: 114757
27.11.2014, aktualisiert um 00:03 Uhr
Meine Güte, das Niveau hier wird immer erbärmlicher. Die Leute sind schneller mit Fragen schreiben, anstatt sich erst mal die Dokumentation gründlich durchzulesen. So führt dann eine Frage zur nächsten, zur nächsten .... nur weil jemand zu faul zum Lesen ist oder eine Brille braucht.
Bitte warten ..
Ähnliche Inhalte
Windows 10
Windows 10 Update funktioniert nicht (9)

Frage von master3477 zum Thema Windows 10 ...

MikroTik RouterOS
gelöst Mikrotik externe SD Card funktioniert nicht (9)

Frage von sebasscha zum Thema MikroTik RouterOS ...

Router & Routing
gelöst WOL über zwei Router - Ping funktioniert nicht (3)

Frage von erdmelone zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Verschlüsselung & Zertifikate
gelöst Festplattenverschlüsselung im Ausland (13)

Frage von Nicolaas zum Thema Verschlüsselung & Zertifikate ...

Windows Server
gelöst Microsoft-Lizenz CALs und passendes Server-Betriebssystem (12)

Frage von planetIT2016 zum Thema Windows Server ...

Festplatten, SSD, Raid
gelöst Fehlerhafte Blöcke im RAID 10 (12)

Frage von Kojak-LE zum Thema Festplatten, SSD, Raid ...

Netzwerkgrundlagen
gelöst Cisco SG500 Series LAG hat sich von selbst umgestellt (11)

Frage von Ex0r2k16 zum Thema Netzwerkgrundlagen ...