Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Frage Microsoft Windows Tools

Funktions und Verständnisfrage Windows WDS, Image und Sysprep

Mitglied: jester84

jester84 (Level 1) - Jetzt verbinden

13.07.2012, aktualisiert 14:48 Uhr, 3628 Aufrufe, 3 Kommentare

Hallo, wir wollen aktuell Windows WDS zum einfacheren und automatisiertem installieren von Clients einsetzen.
Mir ist noch nicht ganz die nötige Verknüpfung der Tools untereinander klar.

Also zunächst einmal zum Aufbau,
wir haben einen mit Windows 2008 R2 Server in einer Domäne mit DHCP, DNS und dem installierten
Bereitstellungsdienst am laufen. Generelles Images capturen vom Client sowie eine Installation
eines Images vom Server auf dem Client funktioniert problemlos.

Zu Beginn haben wir einfach einen Client mit Windows 7 installiert, alle Updates
sowie die benötigten Treiber und weitere Programme darauf installiert.
Dann das Sysprep gestartet, Generalize, OOBE auf dem Client und damit herunter gefahren.
Im nächsten Schritt dann das Image via Boot PE auf den Server gecaptured.
Das Image lässt sich auch zurück spielen auf den Client, allerdings
fragt er beim zurückspielen relativ viele Dinge noch mit ab, wie Benutzersprache,
Land, Festplattenaufteilung, Eingabe eines Benutzernamens, Pc Name...
Um diese manuellen Eingaben zum umgehen sollte man doch an das Image am Server eine erstellte
unattendes.xml anhängen oder?
Ich hatte jetzt so eine Datei erstellt und angehangen, allerdings fragt er dennoch die oben genannnten Dinge ab?

Daher wäre die Frage ist der gewählte Ablauf falsch? Oder einfach die unattended.xml falsch?
Oder etwas ganz anderes?

Vielen Dank schonmal für jede Hilfe!
Mitglied: dog
13.07.2012 um 18:08 Uhr
Ich hatte jetzt so eine Datei erstellt und angehangen, allerdings fragt er dennoch die oben genannnten Dinge ab?

Dann hast du sie falsch eingebunden oder sie ist fehlerhaft (du hast sie doch mit dem Tool aus dem WAIK erstellt, oder!?).
Eine Sache musst du aber beachten: Du kannst mit der unattended.xml keinen PC in eine Domäne einbinden!
Dazu musst du das MDT benutzen.
Bitte warten ..
Mitglied: jester84
13.07.2012 um 19:49 Uhr
Ja, sie wurde mit dem Tool aus WAIK erstellt, einen Domänen Pc will ich nicht einbinden, das würde
ich immer manuell später noch machen wenn benötigt.
Bitte warten ..
Mitglied: jester84
13.07.2012, aktualisiert um 19:53 Uhr
Hier mal die Datei, vielleicht sieht ja jemand einen Fehler?

<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<settings pass="windowsPE">
<component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="xxxxx" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<SetupUILanguage>
<UILanguage>en-US</UILanguage>
</SetupUILanguage>
<InputLocale>en-US</InputLocale>
<SystemLocale>en-US</SystemLocale>
<UILanguage>en-US</UILanguage>
<UserLocale>en-US</UserLocale>
</component>
<component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="xxxxx" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<DiskConfiguration>
<WillShowUI>OnError</WillShowUI>
<Disk wcm:action="add">
<CreatePartitions>
<CreatePartition wcm:action="add">
<Order>1</Order>
<Type>Primary</Type>
<Size>100</Size>
</CreatePartition>
<CreatePartition wcm:action="add">
<Order>2</Order>
<Type>Primary</Type>
<Extend>true</Extend>
</CreatePartition>
</CreatePartitions>
<ModifyPartitions>
<ModifyPartition wcm:action="add">
<Active>true</Active>
<Format>NTFS</Format>
<Label>System</Label>
<Order>1</Order>
<PartitionID>1</PartitionID>
</ModifyPartition>
<ModifyPartition wcm:action="add">
<Format>NTFS</Format>
<Label>Windows</Label>
<Letter>C</Letter>
<Order>2</Order>
<PartitionID>2</PartitionID>
</ModifyPartition>
</ModifyPartitions>
<DiskID>0</DiskID>
<WillWipeDisk>true</WillWipeDisk>
</Disk>
</DiskConfiguration>
<ImageInstall>
<OSImage>
<InstallTo>
<DiskID>0</DiskID>
<PartitionID>2</PartitionID>
</InstallTo>
<WillShowUI>OnError</WillShowUI>
<InstallToAvailablePartition>false</InstallToAvailablePartition>
<WillShowUI>OnError</WillShowUI>
</OSImage>
</ImageInstall>
<UserData>
<Organization>xyz</Organization>
<AcceptEula>true</AcceptEula>
</UserData>
</component>
</settings>
<settings pass="oobeSystem">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="xxxxx" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<OOBE>
<HideEULAPage>true</HideEULAPage>
<ProtectYourPC>3</ProtectYourPC>
</OOBE>
</component>
</settings>
<settings pass="specialize">
<component name="Microsoft-Windows-IE-InternetExplorer" processorArchitecture="amd64" publicKeyToken="xxxxx" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<Home_Page>http://www.xyz.de</Home_Page>"
</component>
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="xxxx" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<ProductKey>xxxxx-xxxxx-xxxxx-xxxxx-xxxxx</ProductKey>
</component>
</settings>
<settings pass="auditSystem">
<component name="Microsoft-Windows-Deployment" processorArchitecture="amd64" publicKeyToken="xxxx" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<Reseal>
<Mode>OOBE</Mode>
</Reseal>
</component>
</settings>
<cpi:offlineImage cpi:source="wim:c:/install.wim#Windows 7 ENTERPRISE" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
</unattend>
Bitte warten ..
Ähnliche Inhalte
Windows Installation
WDS Einbindung MainboardCD-Treiber bei Sysprep-Image
Frage von sermetWindows Installation2 Kommentare

Morgen, ich suche nun schon etwas länger bin zwar auf DPInst und pnputil gestoßen aber das war auch nur ...

Windows Server
Windows 10 WDS Image kann nicht auf WDS-Server hochgeladen werden
Frage von R3nD0mWindows Server

Hallo zusammen Ich habe mal wieder Probleme mit meinem WDS. Ich kann keine Images auf den WDS-Server hochladen. Ich ...

Windows Installation
SYSPREP Snapshot Image
Frage von MarabuntaWindows Installation1 Kommentar

Hallo, hab mein erstes Sysprep in einer VM erstellt und mit Snapshot ein Image gezogen. Dieses Image habe ich ...

Windows Server
Sysprep und Windows server 2012 R2 WDS
Frage von Arospace123Windows Server1 Kommentar

Hallo ihr Lieben, Ich habe seit Stunden ein Problem mit Sysprep und bekomme es nicht gelöst. Ich habe ein ...

Neue Wissensbeiträge
Linux

Meltdown und Spectre: Linux Update

Information von Frank vor 2 TagenLinux

Meltdown (Variante 3 des Prozessorfehlers) Der Kernel 4.14.13 mit den Page-Table-Isolation-Code (PTI) ist nun für Fedora freigegeben worden. Er ...

Tipps & Tricks

Solutio Charly Updater Fehlermeldung: Das Abgleichen der Dateien in -Pfad- mit dem Datenobject ist fehlgeschlagen

Tipp von StefanKittel vor 3 TagenTipps & Tricks

Hallo, hier einmal als Tipp für alle unter Euch die mit der Zahnarztabrechnungssoftware Charly von Solutio zu tun haben. ...

Sicherheit

Meltdown und Spectre: Wir brauchen eine "Abwrackprämie", die die CPU-Hersteller bezahlen

Information von Frank vor 3 TagenSicherheit12 Kommentare

Zum aktuellen Thema Meltdown und Spectre: Ich wünsche mir von den CPU-Herstellern wie Intel, AMD oder ARM eine Art ...

Sicherheit

Meltdown und Spectre: Realitätscheck

Information von Frank vor 3 TagenSicherheit12 Kommentare

Die unangenehme Realität Der Prozessorfehler mit seinen Varianten Meltdown und Spectre ist seit Juni 2017 bekannt. Trotzdem sind immer ...

Heiß diskutierte Inhalte
Firewall
Penetrationstester-Labor - Firewalls
Frage von Oli-nuxFirewall10 Kommentare

Mich würde interessieren warum man beim Einrichten eines Penetrationstester-Labor (VMs) die Firewall der Systeme deaktivieren soll? Hat das nur ...

SAN, NAS, DAS
Wer kennt sich mit QNAP und CISCO aus ?
gelöst Frage von MachelloSAN, NAS, DAS9 Kommentare

Hallo Zusammen hier im Forum, Ich habe ein QNas 451+ und dieses NAS hat zwei GBit Lan Adapter die ...

Netzwerkgrundlagen
IPv6 Inter-VLAN Routing
gelöst Frage von clSchakNetzwerkgrundlagen9 Kommentare

Hi ich befasse mich gerade mit der Implementierung von IPv6 was bisher (in einem VLAN) korrekt funktioniert inkl. DNS ...

Windows Netzwerk
Zugriff auf den Desktop Ordner eines anderen Rechners in der gleichen Domäne
gelöst Frage von JensNomaWindows Netzwerk6 Kommentare

Guten Abend, ich war neulich mit unserem Admin am Tisch gesessen. Er an seinem Notebook angemeldet mit dem Domänen-Admin, ...