Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Funktions und Verständnisfrage Windows WDS, Image und Sysprep

Frage Microsoft Windows Tools

Mitglied: jester84

jester84 (Level 1) - Jetzt verbinden

13.07.2012, aktualisiert 14:48 Uhr, 3593 Aufrufe, 3 Kommentare

Hallo, wir wollen aktuell Windows WDS zum einfacheren und automatisiertem installieren von Clients einsetzen.
Mir ist noch nicht ganz die nötige Verknüpfung der Tools untereinander klar.

Also zunächst einmal zum Aufbau,
wir haben einen mit Windows 2008 R2 Server in einer Domäne mit DHCP, DNS und dem installierten
Bereitstellungsdienst am laufen. Generelles Images capturen vom Client sowie eine Installation
eines Images vom Server auf dem Client funktioniert problemlos.

Zu Beginn haben wir einfach einen Client mit Windows 7 installiert, alle Updates
sowie die benötigten Treiber und weitere Programme darauf installiert.
Dann das Sysprep gestartet, Generalize, OOBE auf dem Client und damit herunter gefahren.
Im nächsten Schritt dann das Image via Boot PE auf den Server gecaptured.
Das Image lässt sich auch zurück spielen auf den Client, allerdings
fragt er beim zurückspielen relativ viele Dinge noch mit ab, wie Benutzersprache,
Land, Festplattenaufteilung, Eingabe eines Benutzernamens, Pc Name...
Um diese manuellen Eingaben zum umgehen sollte man doch an das Image am Server eine erstellte
unattendes.xml anhängen oder?
Ich hatte jetzt so eine Datei erstellt und angehangen, allerdings fragt er dennoch die oben genannnten Dinge ab?

Daher wäre die Frage ist der gewählte Ablauf falsch? Oder einfach die unattended.xml falsch?
Oder etwas ganz anderes?

Vielen Dank schonmal für jede Hilfe!
Mitglied: dog
13.07.2012 um 18:08 Uhr
Ich hatte jetzt so eine Datei erstellt und angehangen, allerdings fragt er dennoch die oben genannnten Dinge ab?

Dann hast du sie falsch eingebunden oder sie ist fehlerhaft (du hast sie doch mit dem Tool aus dem WAIK erstellt, oder!?).
Eine Sache musst du aber beachten: Du kannst mit der unattended.xml keinen PC in eine Domäne einbinden!
Dazu musst du das MDT benutzen.
Bitte warten ..
Mitglied: jester84
13.07.2012 um 19:49 Uhr
Ja, sie wurde mit dem Tool aus WAIK erstellt, einen Domänen Pc will ich nicht einbinden, das würde
ich immer manuell später noch machen wenn benötigt.
Bitte warten ..
Mitglied: jester84
13.07.2012, aktualisiert um 19:53 Uhr
Hier mal die Datei, vielleicht sieht ja jemand einen Fehler?

<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<settings pass="windowsPE">
<component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="xxxxx" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<SetupUILanguage>
<UILanguage>en-US</UILanguage>
</SetupUILanguage>
<InputLocale>en-US</InputLocale>
<SystemLocale>en-US</SystemLocale>
<UILanguage>en-US</UILanguage>
<UserLocale>en-US</UserLocale>
</component>
<component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="xxxxx" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<DiskConfiguration>
<WillShowUI>OnError</WillShowUI>
<Disk wcm:action="add">
<CreatePartitions>
<CreatePartition wcm:action="add">
<Order>1</Order>
<Type>Primary</Type>
<Size>100</Size>
</CreatePartition>
<CreatePartition wcm:action="add">
<Order>2</Order>
<Type>Primary</Type>
<Extend>true</Extend>
</CreatePartition>
</CreatePartitions>
<ModifyPartitions>
<ModifyPartition wcm:action="add">
<Active>true</Active>
<Format>NTFS</Format>
<Label>System</Label>
<Order>1</Order>
<PartitionID>1</PartitionID>
</ModifyPartition>
<ModifyPartition wcm:action="add">
<Format>NTFS</Format>
<Label>Windows</Label>
<Letter>C</Letter>
<Order>2</Order>
<PartitionID>2</PartitionID>
</ModifyPartition>
</ModifyPartitions>
<DiskID>0</DiskID>
<WillWipeDisk>true</WillWipeDisk>
</Disk>
</DiskConfiguration>
<ImageInstall>
<OSImage>
<InstallTo>
<DiskID>0</DiskID>
<PartitionID>2</PartitionID>
</InstallTo>
<WillShowUI>OnError</WillShowUI>
<InstallToAvailablePartition>false</InstallToAvailablePartition>
<WillShowUI>OnError</WillShowUI>
</OSImage>
</ImageInstall>
<UserData>
<Organization>xyz</Organization>
<AcceptEula>true</AcceptEula>
</UserData>
</component>
</settings>
<settings pass="oobeSystem">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="xxxxx" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<OOBE>
<HideEULAPage>true</HideEULAPage>
<ProtectYourPC>3</ProtectYourPC>
</OOBE>
</component>
</settings>
<settings pass="specialize">
<component name="Microsoft-Windows-IE-InternetExplorer" processorArchitecture="amd64" publicKeyToken="xxxxx" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<Home_Page>http://www.xyz.de</Home_Page>"
</component>
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="xxxx" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<ProductKey>xxxxx-xxxxx-xxxxx-xxxxx-xxxxx</ProductKey>
</component>
</settings>
<settings pass="auditSystem">
<component name="Microsoft-Windows-Deployment" processorArchitecture="amd64" publicKeyToken="xxxx" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<Reseal>
<Mode>OOBE</Mode>
</Reseal>
</component>
</settings>
<cpi:offlineImage cpi:source="wim:c:/install.wim#Windows 7 ENTERPRISE" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
</unattend>
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Windows 7
Windows 7: Automatische Domänenanbindung mit Sysprep

Frage von honeybee zum Thema Windows 7 ...

Windows 10
gelöst AIO Image Erstellung - Darstellungsfehler im Windows Setup (2)

Frage von m.reeger zum Thema Windows 10 ...

Windows 7
Windows 7 Sysprep - neue SID generieren (5)

Frage von xenon2008 zum Thema Windows 7 ...

Windows Installation
gelöst HP840 G3 und sysprep beim Original Image (9)

Frage von PizzaPepperoni zum Thema Windows Installation ...

Heiß diskutierte Inhalte
DSL, VDSL
gelöst DSL 200m verlängern (15)

Frage von Angela44 zum Thema DSL, VDSL ...

LAN, WAN, Wireless
Per Script auf UniFi-controller zugreifen und WPA2-Key ändern (11)

Frage von Winfried-HH zum Thema LAN, WAN, Wireless ...

Windows Server
SBS 2011 Standard virtualisieren (11)

Frage von HeinrichM zum Thema Windows Server ...

Exchange Server
gelöst DHCP Sever MS Server 2012 Problem (10)

Frage von Florian86 zum Thema Exchange Server ...