Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Gateway in anderem IP-Bereich, Server 2003 und 2008

Frage Netzwerke

Mitglied: powermax

powermax (Level 1) - Jetzt verbinden

16.12.2009, aktualisiert 18.10.2012, 6384 Aufrufe, 19 Kommentare

Erforsche die Welt der Server

Hi All,


ich habe 2 Testsysteme aufgebaut, einmal Server 2003(IP: 192.168.2.1, Subnetz 255.255.255.0, Gateway: 192.168.0.101, DNS Server: 192.168.2.1) und Server 2008 (IP: 192.168.1.1, Subnetz 255.255.255.0, Gateway: 192.168.0.101, DNS Server: 192.168.1.1), beides auf einem und dem selben PC (Verschiedene Partitionen), also die Hardware ist gleich.
Beide Serverversionen fungieren als DC, DNS etc. funktioniert.
Nun komme ich zu meiner Frage, WIESO habe ich beim Server 2008 Internet, obwohl verschiedene IP-Bereiche was Gateway betrifft und beim Server 2003 verschwindet das I-net nach ca. 1 min? Kann mir das Jemand erklären? Das das Gateway in selbem bereich sein sollte ist mir klar, mir gehts um Verständniss. Kann man das S2003-Problem auch i-wie lösen?

Vielen dank
Mitglied: 82477
16.12.2009 um 11:09 Uhr
Du musst eine andere Subnetzmaske nehmen, in Deinem Fall 255.255.0.0. Ansonsten muss der GW im gleichen Netz wie der Server betrieben werden.
Bitte warten ..
Mitglied: powermax
16.12.2009 um 11:13 Uhr
Vielen dank für deine Antwort ddave77, das mit 255.255.0.0 habe ich bereits getestet, ohne Erfolg, das I-net verschwindet nach ca. 1min nach wie vor. UND wieso funktioniert es beim Server 2008, dort hab ich an der Subnetzmaske nichts verändert!!!???
Bitte warten ..
Mitglied: 82477
16.12.2009 um 11:28 Uhr
wie sieht es denn mit anderen hosts im netz aus? kannst du die pingen? kommst du auf den gw?
Bitte warten ..
Mitglied: laster
16.12.2009 um 11:34 Uhr
Hallo powermax,

ein Gateway muss immer im gleichen Netzwerk liegen wie die Rechner, die über das GW in ein anderes Netz wollen.
Wenn das GW ein externen Router ist, muss das Netz (mit den Servern) im gleichen Netz liegen, somit das Netzwerk für beide Testsysteme 192.168.0.0 / 24 (die laufen doch eh nicht gleichzeitig?).
vG laster
Bitte warten ..
Mitglied: powermax
16.12.2009 um 11:39 Uhr
ping 192.168.0.101 = zeitüberschreitung
ping 192.168.2.5 (XP rechner) = OK

wenn ich vom server 2008 aus den router anpinge kommt auch nichts bei raus, internet funktioniert jedoch ohne problemme. wieso nicht beim 2003
Bitte warten ..
Mitglied: powermax
16.12.2009 um 11:43 Uhr
hi laster danke für deine antwort!

kannst du mir dann erklären wieso es beim server2008 dennoch funktioniert, obwohl verschiedene netze.
Bitte warten ..
Mitglied: jhinrichs
16.12.2009 um 12:05 Uhr
Moin,

was gibt denn der Befehl
route PRINT
auf der Kommandozeile aus?
Bitte warten ..
Mitglied: powermax
16.12.2009 um 12:32 Uhr
hi jhinrichs, vielen dank für dein beitrag!


also hier sind die ergebnisse;

SERVER2008:

Microsoft Windows [Version 6.0.6001]
Copyright (c) 2006 Microsoft Corporation. Alle Rechte vorbehalten.

C:\Users\Administrator>route print
Schnittstellenliste
10 ...90 e6 ba bd 64 0a ...... Realtek PCIe GBE Family Controller
1 ........................... Software Loopback Interface 1
11 ...00 00 00 00 00 00 00 e0 isatap.{078225C3-0DCE-4408-8E91-9D70E92076A9}

IPv4-Routentabelle
Aktive Routen:
Netzwerkziel Netzwerkmaske Gateway Schnittstelle Metrik
0.0.0.0 0.0.0.0 192.168.0.101 192.168.1.1 266
127.0.0.0 255.0.0.0 Auf Verbindung 127.0.0.1 306
127.0.0.1 255.255.255.255 Auf Verbindung 127.0.0.1 306
127.255.255.255 255.255.255.255 Auf Verbindung 127.0.0.1 306
192.168.1.0 255.255.255.0 Auf Verbindung 192.168.1.1 266
192.168.1.1 255.255.255.255 Auf Verbindung 192.168.1.1 266
192.168.1.255 255.255.255.255 Auf Verbindung 192.168.1.1 266
224.0.0.0 240.0.0.0 Auf Verbindung 127.0.0.1 306
224.0.0.0 240.0.0.0 Auf Verbindung 192.168.1.1 266
255.255.255.255 255.255.255.255 Auf Verbindung 127.0.0.1 306
255.255.255.255 255.255.255.255 Auf Verbindung 192.168.1.1 266
Ständige Routen:
Netzwerkadresse Netzmaske Gatewayadresse Metrik
0.0.0.0 0.0.0.0 192.168.0.101 Standard

IPv6-Routentabelle
Aktive Routen:
If Metrik Netzwerkziel Gateway
1 306 ::1/128 Auf Verbindung
1 306 ff00::/8 Auf Verbindung
Ständige Routen:
Keine


Server 2003:


D:\Dokumente und Einstellungen\Administrator>route print

IPv4-Routentabelle
Schnittstellenliste
0x1 ........................... MS TCP Loopback interface
0x10003 ...90 e6 ba bd 64 0a ...... Realtek PCIe GBE Family Controller - Filterg
erõt f³r Netzwerklastenausgleich
Aktive Routen:
Netzwerkziel Netzwerkmaske Gateway Schnittstelle Metrik
0.0.0.0 0.0.0.0 192.168.0.101 192.168.2.1 10
127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
192.168.2.0 255.255.255.0 192.168.2.1 192.168.2.1 10
192.168.2.1 255.255.255.255 127.0.0.1 127.0.0.1 10
192.168.2.255 255.255.255.255 192.168.2.1 192.168.2.1 10
224.0.0.0 240.0.0.0 192.168.2.1 192.168.2.1 10
255.255.255.255 255.255.255.255 192.168.2.1 192.168.2.1 1
Standardgateway: 192.168.0.101
Ständige Routen:
Keine
Bitte warten ..
Mitglied: Pjordorf
16.12.2009 um 13:23 Uhr
Hallo powermax,

ich vermute du hast jetzt selber gesehen, WARUM dein Server 2008 (R2?) ins Internet kommt und warum dein Server 2003 NICHT ins Internet kommt.

Beim Einrichten des Server 2008 gibt es doch so schöne Asisstenten welche dir einiges an "Arbeit" abnehmen (können). Da wird wohl einer deine "Arbeit" (Einstellung(en) grundlagen IP Routing) gemacht haben.

Peter
Bitte warten ..
Mitglied: powermax
16.12.2009 um 13:47 Uhr
hi peter, scheinbar hast du das problemm erkannt, ich jedoch nicht da ich kein netzwerk profi bin, mein wissen reicht nicht bis zum routing etc.

kannst du es mir bitte erklären was der server 2008 da gemacht hat und was man folglich beim server2003 selber machen muss.

wäre nett von dir, auch wenn es für dich vieleicht kinderkramm ist ;)

ich muss es verstehen
Bitte warten ..
Mitglied: Pjordorf
16.12.2009 um 14:03 Uhr
Hallo powermax,

du hast hier zwar netterweise die Ausgaben von "route /print" reingestellt, aber selber hast du dir die Ausgaben weder angesehen noch verglichen. Du hast somit den Unterschied gar nicht gesehen bzw. gesucht. Du hast dir zwar einen Server 2008 aufgesetzt (wie hast du das bloß geschafft ohne Grundlagen Wissen?) und hast nicht verstanden was du gemacht hast.

Egal. Der Unteschied ist hier:
Ständige Routen:
Netzwerkadresse Netzmaske Gatewayadresse Metrik
0.0.0.0 0.0.0.0 192.168.0.101 Standard

http://de.wikipedia.org/w/index.php?title=Router&oldid=67777585
http://de.wikipedia.org/w/index.php?title=Routing&oldid=67886755
Auszug hieraus:
Statisches Routing: Dieses Verfahren ist nicht adaptiv, sehr einfach und daher viel benutzt. Jeder Knoten unterhält eine Tabelle mit einer Zeile für jeden möglichen Zielknoten. Eine Zeile enthält Einträge, welche die beste, zweitbeste usw. Übertragungsleitung für dieses Ziel ist, zusammen mit einer Gewichtung. Vor Weiterleitung eines Paketes wird der entsprechende Eintrag aus der Tabelle gewählt und auf eine der möglichen Leitungen gegeben. Die Gewichtung spiegelt hier die Wahrscheinlichkeit wider, dass diese Leitung gewählt wird

http://de.wikipedia.org/w/index.php?title=Gateway_(Informatik)&oldi ...

Peter
Bitte warten ..
Mitglied: powermax
16.12.2009 um 18:28 Uhr
vielen dank peter für die beschreibung und die links, ich werde mir das ganze mal durchlesen. und ich habe wohl mir die tabelle angeguckt aber nichts draus lesen können, wie gesagt kein netz profi.

ggf. melde ich mich morgen wieder...


danke an alle für die netten und hilfreichen beiträge
Bitte warten ..
Mitglied: aqui
17.12.2009, aktualisiert 18.10.2012
Vielleicht erweitert dies Tutorial deinen Horizont im Bereich Routing noch etwas:

http://www.administrator.de/wissen/routing-mit-2-netzwerkkarten-unter-w ...
Bitte warten ..
Mitglied: powermax
18.12.2009 um 10:19 Uhr
hallo zusammen,

so habe nun verstanden das der server 2008 eine ständige route eingerichtet hat (Ständige Routen:
Netzwerkadresse Netzmaske Gatewayadresse Metrik
0.0.0.0 0.0.0.0 192.168.0.101 Standard)

das ist also die rätselslösung.

nun muss ich also beim server 2003 ebenfalls eine route setzen damit das i-net funktioniert, dies habe ich auch versucht nur leider kommt eine fehler meldung: "Hinzufügen der Route fehlgeschlagen: Entweder ist der Schnittstellenindex ungült ig oder das Gateway befindet sich nicht im gleichen Netzwerk wie die Schnittstelle. Überprüfen Sie die IP-Adresstabelle für diesen Rechner."

folgendes habe ich eingegeben: route add 0.0.0.0 mask 0.0.0.0 192.168.0.101 metrik 1 (standartgateway habe ich dabei rausgenommen unter tcp/ip einstellungen)

wieso kann die route nicht gesetzt werden? kann einer helfen?
Bitte warten ..
Mitglied: aqui
18.12.2009 um 19:47 Uhr
Das ist Quatsch. Dein Grundproblem (was du ja auch selber schon erkannt hast...) ist eine komplett falsche IP Adressierung. Ohne das du das nicht grundlegend änderst wird das nie was !
Du fährst 2 vollkommen unterschiedliche IP Netze auf einem physischen Draht, logisch das das nicht geht.
Einzige Ausnahme: Du benutzt einen Router der sog. secondary IP Adressen sprich also mehrere IP Netze auf einem physischen Interface supportet. Damit ist das problemlos lösbar....anders nicht, auch nicht mit der route Frickelei von oben... !
Bitte warten ..
Mitglied: powermax
22.12.2009 um 10:38 Uhr
hallo aqui,

beim server 2008 funktionierts doch, s.o.! Der 08er ist ja ebenfalls in andrem ip bereich, dort wurde ne route automatisch gesetzt(ohne mein wissen) und schon funktioniert das i-net. Also wieso soll es nich auch beim 03er funktionieren? ist s03 so viel doofer als s08?

wie muss ich nun die route setzen damit der server 2003 genau so wie der 2008 ins internet kommt? weiss es einer?
Bitte warten ..
Mitglied: aqui
22.12.2009 um 20:15 Uhr
Das mag ja alles sein aber du bist ja nichtmal in der Lage auf dem Netzwerk mit dem Wireshark zu sniffern woher der Automatismus kommt, denn IP konform ist das ja logischerweise nicht.

Es ist zu vermuten das beim 2008 ein UPnP Dämon rennt und du wie jeder Anfänger vergessen hast UPnP am DSL Router aus Sicherheitsgründen zu deaktivieren. Vermutlich schickt der UPnP Router also UPnP Pakete an den Server der die IPs dann automatisch anpasst.
Das ist natürlich nicht üblich denn soviel weisst du ja selber das aus reiner IP Sicht deine beiden IP Netze niemals zusammenspielen könenn ohne Router, da sie ja eben in 2 völlig unterschiedlichen IP Netzen liegen.

Tu also bitte nicht so als ob Winblows das Maß aller Dinge ist da sie jeglichen Automatismus eingebaut haben die User mit gefährlichem Halbwissen nur weiter verdummen oder komplett verwirren...

Wie du es drehst oder wendest, Windows hin oder her es ist und bleibt ein falsches IP Adressdesign...da ändert auch ein mehr oder minder automatisches Windows nix dran !!
Vielleicht machst du dir als Windows Knecht mal die Mühe ein Linux Live System von CD zu booten wie z.B. Knoppix.
Das verhält sich IP konform und damit ist so ein Unsinn wie mit 2008 nicht machbar...glücklicherweise !
Bitte warten ..
Mitglied: powermax
23.12.2009 um 11:54 Uhr
hallo aqui,

nein UPnP ist NICHT aktiviert!

ich bin hier nicht um zu hören das ich zu etwas nicht in der lage bin oder das ich etwas nicht kann, ich bin hier um hilfe zu bekommen WEIL ich etwas nicht so gut kann!!!!
daher muss du mir aqui das nicht aufs brot schmieren.

bleiben wir sachlich! UPnP ist wie gesagt nicht aktiviert, wieso kommt der server 2008 r2 ins internet, ich habe absolut garnichts in diese richtung unternommen, nur das gateway eingetragen, was läuft da im hintergrund, das ist hier die frage! wie finde ich es mit hilfe von "wireshark" heraus, worauf muss ich dabei achten?

ich möchte zu gerne wissen wieso der 08ter server so einfach ins netz kommt ohne das es im selben netz ist???

habe mal versucht die route "0.0.0.0 mask 0.0.0.0 192.168.0.101 metric standart"(s.o.) unter server2008 zu löschen. folgendes ist passiert, der server hat das standartgateway 192.168.0.101 aus den einstellungen rausgenommen und somit funktionierte auch das internet nicht. setzte ich nun das standartgateway wieder, so erstellt der server wieder diese route automatisch (0.0.0.0 mask 0.0.0.0 192.168.0.101 metric standart).

das heisst es ist nur die route die es möglich macht das der server08 ins i-net kommt. nur wieso lässt sich eine solche(route add 0.0.0.0 mask 0.0.0.0 192.168.0.101) nicht unter server 2003 setzen, muss ein metric- sowie ein schnittstelle- wert vieleicht rein?
Bitte warten ..
Mitglied: aqui
24.12.2009 um 13:23 Uhr
Letztlich ist das ein kranker Windows Automatismus der mit dem IP Standard nichts zu tun hat...soviel ist sicher. Deshalb hat das auch eher was im Bereich Winblows zu suchen..aber egal.
Am besten wird es sein du bringst einen Wireshark Sniffer ins Netz oder installierst den MS NetworkMonitor auf dem Server und siehst dir die Pakete und die Adressierung des Servers einmal ganz genau und direkt an.
Das sollte doch alle sinnlose Raterei und Grübelei über irgendwelche geheimnisvollen Windows Prozesse sofort klären... !!!
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Server-Hardware
Dual CPU unter Server 2003 oder Server 2008 (4)

Frage von Usogul zum Thema Server-Hardware ...

Windows Netzwerk
Windows Server 2003 SBS Netzwerk durch neuen Server Ersetzen (9)

Frage von MultiStorm zum Thema Windows Netzwerk ...

Exchange Server
gelöst Microsoft Excange Server 2007 auf Windows Server 2003 Installieren? (9)

Frage von Herbrich19 zum Thema Exchange Server ...

Windows Server
gelöst Suche Windows Server 2003 Enterprise ISO (8)

Frage von Herbrich19 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...