Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Gbit Performanceprobleme

Frage Netzwerke LAN, WAN, Wireless

Mitglied: Concept

Concept (Level 1) - Jetzt verbinden

09.06.2007, aktualisiert 11.06.2007, 3538 Aufrufe, 7 Kommentare

Hallo administrator.de-Gemeinde!

Ich hoffe, daß ihr mir bei meinem Problem helfen könnt.

Vorweg Infos zu den Systemen:
Rechner1: AMD X2 4600+, nVidia onboard Gbit, 2Gbyte RAM, SATA-2 HDD, WinXP Pro (Stand Mai 2007)
Rechner2: AMD 3000+, Intel Pro/1000 NIC (PCI), 1Gbyte RAM, SATA-2 HDD, WinXP Pro (Stand Mai 2007)

Die Platten geben alle >60MB/s an Schreib- & Lesegeschwindigkeit her. Zur Problemlösung habe ich beide Rechner direkt ohne Switch mit einem neuen CAT7 Kabel verbunden. Habe schon verschiedene Einstellungen ausprobiert, auch mit DrTCP etc., doch egal was ich mache, ich komme nicht über 25MB/s (Dateitransfer mit 2Gbyte Testfiles, WinXP und FTP-Protokoll).

Habt ihr vielleicht noch Tipps für mich?

cYa
Concept
Mitglied: Schnief
09.06.2007 um 08:02 Uhr
Rechner2: AMD 3000+, Intel Pro/1000 NIC
(PCI),

>egal was ich mache, ich komme
nicht über 25MB/s

...nun ja ich geh mal mit aller höchster Wahrscheinlichkeit davon aus, das es an der Anbindung der Netzwerkkarte in den oben genannten PC liegt. Da diese NIC nur über PCI angebunden ist, liegt hier der Flaschenhals des ganzen Systems. Wenn sich der PCI Bus die Bandbreite mit noch anderen Karten teilen muss, dann geht die Datenrate schon mal in den Keller, wobei 25MB/s mit einer PCI NIC gar nicht mal so schlecht sind.
Nimm eine PCIe NIC oder die onboard Karte, die direct zur Bridge angebunden ist und deine Transferrate wird steigen.
So viel Hoffnung auf die theoretischen 120 MB/s Datendurchsatz solltest du dir damit aber auch nicht machen, denn mehr als 50-60MB/s ist in der Praxis auch nicht drinne.
Bitte warten ..
Mitglied: aqui
09.06.2007 um 14:23 Uhr
Mit MB/s meinst du damit jetzt Mbit/s oder Mbyte/s ???? Nicht das wir jetzt Aepfel mit Birnen vergleichen !!!
Dein Testverfahren mit der Kopiererei von Daten und das wahrscheinlich noch ueber das sehr performanceschlechte CIFS Protokoll von Windows sagt rein gar nichts ueber deine eigentliche Netzperformance aus !!!
Du solltest zuallererst ein Tool wie netio

http://www.ars.de/ars/ars.nsf/docs/netio

verwenden um ueberhaupt erstmal unabhaengig deine Netzwerkperformance messen. Das hilft dir ueberhaupt erstmal zu trennen obs am Netzwerk oder deinen restlichen Komponenten liegt.
Dr.TCP und Co. bringt rein gar nichts in einem LAN und ist unsinnig. Besser waere die TCPWindowsize in der Registry unter HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Tcpip/Parameters etwas anzupassen an ein GiG Netzwerk.
Bitte warten ..
Mitglied: Concept
09.06.2007 um 18:41 Uhr
@Schnief:
Die PCI NIC ist die einzigste Karte im System. Leider hat das MB kein PCIx und keine onboard NIC. Mit 50MB/s wäre ich ja recht zufrieden.

@aqui:
Die TCPWindowsize liegt bei beiden Systemen bei 400000. Ist der Wert für Gbit in Ordnung?
Ich spreche natürlich von 25Mbytes/s, daher das große "B". ;)
Mit netio komm ich leider nicht ganz zurecht. Gibt es ein Tutorial oder kannst du´s mir erklären?
Bitte warten ..
Mitglied: Concept
10.06.2007 um 03:09 Uhr
Noch mehr Info... =)

Laut der folgenden Tabelle von Intel, sollte der PCI-Bus 266MB/s zulassen: http://www.intel.com/support/network/sb/cs-025829.htm

Das kann somit ja also eigentlich nicht der Flaschenhals sein. Oder hab ich das jetzt falsch verstanden?

Bitte, bitte Hilfe! Ich komm hier nämlich echt nich weiter....
Bitte warten ..
Mitglied: aqui
10.06.2007 um 09:37 Uhr
NetIO ist ganz einfach..... Einfach die Binaries entpacken in ein Verzeichnis, sie sind unter Windows direkt ausfuehrbar.
Wenn du jetzt netio ohne Parameter aufrufst sagt dir das Programm automatisch die Syntax, damit sollte man schon klarkommen.

Du musst das Prg. natuerlich auf 2 Rechner im Netz bringen das ist klar !
Dein einen laesst du als NetIO Server rennen indem du einfach netio -s -t eingibst ! (-s sagt das er Server ist -t sagt ihm das er den Durchsatztest auf Basis von TCP machen soll)

Den 2ten Rechner startest du jetzt mit netio -t <ip_adresse_netio-server>
Nun kannst du gemuetlich zusehen wie das Prg. dir fuer unterschiedliche Packetgroessen den Durchsatz auf dem Netz misst....
Deine Windowsize ist OK.
Bitte warten ..
Mitglied: Concept
10.06.2007 um 13:45 Uhr
Ahhh.....das muss auf beiden Rechnern laufen. Das war´s, was ich nich gerafft hab. ;)

Hab den Test nun ausgeführt. Hier erreicht der Benchmark 37-40MB/s. Was sagt mir das jetzt? Was muss ich machen, damit ich diese Geschwindigkeiten ständig habe?
Bitte warten ..
Mitglied: aqui
11.06.2007 um 12:56 Uhr
Das wären dann 320 Mbit/s. Nicht übermässig berauschend für ein GiGE Netzwerk aber wahrscheinlich hast du nur normale PCI Karten in den Rechnern und dann ist das mehr oder weniger normal.
Also am Netzwerk liegt es dann nicht.... dann kannst du nun anfangen bei dir im System Server/Client zu suchen...
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless
gelöst 1 GBit Lan mit 0,09 bis 0,1 Gigabit Datendurchsatz (19)

Frage von viki11 zum Thema LAN, WAN, Wireless ...

Switche und Hubs
gelöst 8 port Gbit switch gesucht (13)

Frage von dxellas zum Thema Switche und Hubs ...

Switche und Hubs
Switch gesucht 10 GBit RJ45 (6)

Frage von puerto zum Thema Switche und Hubs ...

Windows Server
gelöst Performanceprobleme mit SQL Server (7)

Frage von lazkopat85 zum Thema Windows Server ...

Neue Wissensbeiträge
Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(2)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Windows 10

Das Windows 10 Creators Update ist auf dem Weg

(5)

Anleitung von BassFishFox zum Thema Windows 10 ...

Administrator.de Feedback

Tipp: Ungelöste Fragen ohne Antwort in Tickeransicht farblich hinterlegen

Tipp von pattern zum Thema Administrator.de Feedback ...

Viren und Trojaner

Neue Magazin Ausgabe: Malware und Angriffe abwehren

Information von Frank zum Thema Viren und Trojaner ...

Heiß diskutierte Inhalte
Windows Systemdateien
Warum System auf "C:" (29)

Frage von DzumoPRO zum Thema Windows Systemdateien ...

LAN, WAN, Wireless
Cisco SG200: Auf bestimmtem vLAN bestimmte TCP-Ports sperren (16)

Frage von SarekHL zum Thema LAN, WAN, Wireless ...

Windows Server
gelöst Update BackupExec 2015 auf 2016 führt zu SQL-Server Problem (16)

Frage von montylein1981 zum Thema Windows Server ...

Cloud-Dienste
gelöst Bitcoins minen über Nacht? (16)

Frage von 1410640014 zum Thema Cloud-Dienste ...