Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Geänderte Access Formulare lassen sich nicht abspeichern

Frage Microsoft Microsoft Office

Mitglied: Volker-K

Volker-K (Level 1) - Jetzt verbinden

12.11.2009, aktualisiert 17.11.2009, 7307 Aufrufe, 9 Kommentare

Ich habe eine SQL-Datenbank auf die ich mit Access zugreife.
Nun müssen in einigen Formularen die Defaultwerte geändert werden.

Ich habe eine SQL-Datenbank auf die ich mit Access zugreife.
Nun müssen in einigen Formularen die Defaultwerte geändert werden.
Wenn ich das aber tue und auch abspeichere, dann wird diese Änderung nicht übernommen.
Ich kann z.B. auch versuchen das Formular zu schliessen, wobei ich aber immer wieder gefragt werde, ob ich die änderungen Abspeichern möchte.
Ich bekomme keine Fehlermeldung, lediglich das Formular bleibt geöffnet und ich kann den Vorgang wiederholen, bis ich schwarz werde.
Dieses Problem hatte ich bereits und konnte es nur durch ein Restore der Access.mdb von Backup beheben.
Habe ich natürlich wieder versucht, blieb aber bisher ohne Erfolg.

An Zugriffsrechten kann es eigentlich nicht liegen, da der Fehler auftritt, wenn ich Access sowohl mit Adminrechten als auch mit Poweruserrechten öffne. Auch eine Lokale Kopie zeigt den gleichen Fehler.
Mitglied: KalleAtWork
12.11.2009 um 12:51 Uhr
Hi,

schon mal probiert die MDB zu reparieren?

Wenn da nichts hilft evtl. eine neue leere MDB anlegen und alle Objekte importieren.

Wenns dann immer noch nicht geht: Liegt die MDB in einem Ordner mit Schreibschutz? Evtl. die MDB mal in einen anderen Ordner kopieren und da probieren.

Gruß
Kalle
Bitte warten ..
Mitglied: Volker-K
12.11.2009 um 13:42 Uhr
"schon mal probiert die MDB zu reparieren?"
- Ja, hab ich (mit /repair) aber ohne Erfolg.

"Wenn da nichts hilft evtl. eine neue leere MDB anlegen und alle Objekte importieren."
- Hab ich versucht. Beim Exportieren bekomme ich mehrfach folgende Fehlermeldung:
"Dieser Name wird von einem bereits vorhandenen Modul, Projekt oder einer bereits vorhandenen Objektbibliothek verwendet"
Anschließend fehlen in der Ziel-MDB etliche Formulare.

"Wenns dann immer noch nicht geht: Liegt die MDB in einem Ordner mit Schreibschutz? Evtl. die MDB mal in einen anderen Ordner kopieren und da probieren"
-Hab ich auch versucht
Bitte warten ..
Mitglied: KalleAtWork
12.11.2009 um 15:06 Uhr
Nicht die Objekte exportieren aus der geöffneten MDB sondern die Original MDB schließen und die neue leere öffnen und dann importieren.
Und wenn da Fehler auftreten auf einzelne Objekte eingrenzen.
Bitte warten ..
Mitglied: Logan000
12.11.2009 um 15:49 Uhr
Moin Moin

"Wenn da nichts hilft evtl. eine neue leere MDB anlegen und alle Objekte importieren."
- Hab ich versucht. Beim Exportieren bekomme ich mehrfach folgende Fehlermeldung: "Dieser Name wird von einem bereits vorhandenen Modul, Projekt oder einer bereits vorhandenen Objektbibliothek verwendet"
Anschließend fehlen in der Ziel-MDB etliche Formulare.
Da hast du wahrscheinlich Systemobjekte mitimportieren wollen.

Gruß L.
Bitte warten ..
Mitglied: Volker-K
12.11.2009 um 18:08 Uhr
Zitat von Logan000:
Moin Moin

Da hast du wahrscheinlich Systemobjekte mitimportieren wollen.


Nein, auch einzelne Formulare haben diesen Fehler.
Ich konnte übrigens alles Andere Exportieren. Der Fehler scheint sich auf die Formulare zu beschränken.
Nur dort tritt der Fehler auf "Dieser Name wird von einem bereits vorhandenen Modul, Projekt oder einer bereits vorhandenen Objektbibliothek verwendet"
Das gilt natürlich auch, wenn ich nur ein einziges dieser Formulare in ein neues, jungfräuliches mdb-File exportiere oder auch importiere.

Zitat von KalleAtWork:
Nicht die Objekte exportieren aus der geöffneten MDB sondern die
Original MDB schließen und die neue leere öffnen und dann
importieren.
Und wenn da Fehler auftreten auf einzelne Objekte eingrenzen.

Habe ich, wie beschrieben, auf die Formulare eingrenzen können.
Es sind übrigens 70-80% der Formulare betroffen.

Gruss,

Volker
Bitte warten ..
Mitglied: KalleAtWork
13.11.2009 um 07:38 Uhr
Und wenn Du die Objekte vorher umbenennst?
Wie heissen die denn? Bitte mal ein paar auflisten.
Welche Access-Version ist das? Und welche Version hat die MDB? Evtl. die konvertieren.
Bitte warten ..
Mitglied: Volker-K
14.11.2009 um 20:46 Uhr
Das hab ich ja versucht, aber ich bekomme den selben Fehler.
Bitte warten ..
Mitglied: KalleAtWork
16.11.2009 um 12:53 Uhr
Also auch wenn Du nur ein einziges der Formulare importieren willst kommt schon der Fehler?

Ich würde dann mal in die Systemtabelle MSysObjects (Systemobjekte anzeigen) schauen, ob da nicht vielleicht doppelte Einträge vorhanden sind. Aber ansonsten weiß ich leider auch nicht weiter.
Bitte warten ..
Mitglied: Volker-K
17.11.2009 um 08:08 Uhr
Auf einem Backup habe ich eine ältere, funktionierende Version gefunden.
Es fehlen mir zwar ein paar Furmulare, dafür habe ich alle Makros und Abfragen wieder.
Die Fehlenden Formulare werd ich wohl neu erstellen müssen.

Das ist zwar nicht die Lösung, auf die ich gehofft habe, aber besser so als alles neu machen.
Falls ich die eigentliche Ursache rausfinde, werde ich das noch posten.

Vielen Dank für Eure Hilfe!
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Microsoft
gelöst RemoteApp Anmeldedaten lassen sich bei Win7 nicht abspeichern (8)

Frage von thomasreischer zum Thema Microsoft ...

Microsoft Office
gelöst DOT Dateien die über Access geöffnet werden lasssen sich nicht als DOC abspeichern (4)

Frage von bluepython zum Thema Microsoft Office ...

LAN, WAN, Wireless
Freifunk über vorhandene Access Points ausstrahlen (2)

Frage von Uwoerl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Direct Access mit VPN aufbau (4)

Frage von geocast zum Thema Windows Netzwerk ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...