Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Was geht bei DNS unter Windows 7 ab?

Frage Netzwerke DNS

Mitglied: nsilux

nsilux (Level 1) - Jetzt verbinden

08.09.2010, aktualisiert 17:04 Uhr, 5569 Aufrufe, 6 Kommentare

DNS teilweise ohne Ergebnis unter WIndows 7

Hallo,

ich habe zum Thema DNS Windows 7 viele Infos gefunden, aber keine ging auf die Ursachen ein oder hat ein Workaround für mich geliefert.

Die Situation bei meinem Kunden:

vigor 2600 mit WLAN verbindet LAN und WLAN mit WAN / DSL

Router bietet DHCP mit DNS-Server=Router / Gateway 192.168.1.1

bisher lief alles (mit XP) gut, jetzt kommt Windows 7

W7-Rechner: Laptop FSC 64 bit W7 prof de, LAN, WLAN und mobile-Karte/DFÜ

verschiedene Szenarien durchlaufen (nur ein Interface, zwei Interfaces, Heimnetzwerk, Arbeitsplatznetzwerk was hier am besten passt), das Ergebnis ist interessant:

per DOS funktioniert DNS korrekt ping internet-name klappte und klappt immerzu, auf XP und auch auf Win 7 !

per Bowser (IE 8, Opera 10.61) klappt DNS nur teilweise:
Seiten wie Microsoft.com, microsoft.de, <unsere private Webseite>, auch maps.google.com klappen richtig;
Seiten wie www.google.com oder xxx.xing.com aber nicht: DNS-Name kann nicht aufgelöst werden (dem Sinn nach, ich sitze nicht dran...)
hole ich mir über CMD per ping eine Adresse und trage diese ein, wird die Seite auch geladen.

ach ja: ich habe es probiert mit IP6 aktiviert auf einem, beiden und keinem Interface.
Mit den 2 Interfaces auf demselben Netz kommen Maschine und Netz zwar zurecht, aber zur Eingrenzung ab jetzt mit nur einem Interface (dhcp)

Erst, wenn ich einen gültigen externen DNS-Server fest eintrage, werden auch die vorher nicht aufgelösten Seiten geladen. Die (simplen) Tests mit ping und tracert lieferten in ALLEN Fällen korrekte Ergebnisse.

Der fixe DNS ist natürlich keine Dauerlösung. Deshalb meine Hoffnung, daß jemand helfen kann.

Mit freundlichen Grüßen
Uwe
Mitglied: Pjordorf
08.09.2010 um 17:30 Uhr
Hallo Uwe,

Zitat von nsilux:
ich habe zum Thema DNS Windows 7 viele Infos gefunden, aber keine ging auf die Ursachen ein oder hat ein Workaround für mich
geliefert.
Die Situation bei meinem Kunden:
vigor 2600 mit WLAN verbindet LAN und WLAN mit WAN / DSL
Router bietet DHCP mit DNS-Server=Router / Gateway 192.168.1.1
Der DNS im Vigor läuft? Die DNS weiterleitung im Vigor läuft? Der Vigor hat einen/mehrere korrekte externe DNS eingetragen? Mal im Vigor einen anderen externen DNS eingetragen? Firmware im Vigor OK? Vigor schon mal neu gestartet?

Der fixe DNS ist natürlich keine Dauerlösung. Deshalb meine Hoffnung, daß jemand helfen kann.
Was spricht bei deinem Netzwerk (Keine Server, nur ein paar lose zusammen gewürfelte Rechner ) dagegen, als DNS Server einen externen zu verwenden?

Peter
Bitte warten ..
Mitglied: nsilux
08.09.2010 um 18:10 Uhr
Hallo Peter,

thanks for answer

Zitat von Pjordorf:
Hallo Uwe,

> Zitat von nsilux:
> ich habe zum Thema DNS Windows 7 viele Infos gefunden, aber keine ging auf die Ursachen ein oder hat ein Workaround für
mich
> geliefert.
> Die Situation bei meinem Kunden:
> vigor 2600 mit WLAN verbindet LAN und WLAN mit WAN / DSL
> Router bietet DHCP mit DNS-Server=Router / Gateway 192.168.1.1
Der DNS im Vigor läuft? Die DNS weiterleitung im Vigor läuft? Der Vigor hat einen/mehrere korrekte externe DNS
eingetragen? Mal im Vigor einen anderen externen DNS eingetragen? Firmware im Vigor OK? Vigor schon mal neu gestartet?

Na ja, ich habe keinen Zugriff auf den Vigor, der Betreuer ist nur sporadisch alle paar Wochen da...
Aber gundsätzlich scheint DNS ja schon richtig zu laufen (reichlich Seiten werden ordentlich geladen. Den Browser-Cache habe ich auch gelöscht.
Ich frage mich, was da zwischen Browser (ich glaube Layer 7) und DNS-Server ( auch Layer 7) ausgehandelt wird, daß nur manche Seiten - pardon: Namen - nicht aufgelöst werden.

> Der fixe DNS ist natürlich keine Dauerlösung. Deshalb meine Hoffnung, daß jemand helfen kann.
Was spricht bei deinem Netzwerk (Keine Server, nur ein paar lose zusammen gewürfelte Rechner ) dagegen, als DNS Server
einen externen zu verwenden?
Grundsätzlich spricht nur dagegen, daß die IP eines DNS sich ja auch mal ändern kann bzw die Adresse kein DNS mehr bietet.
Deshalb lieber einen Namen oder am besten dynamisch über den Router.
Peter

Uwe
Bitte warten ..
Mitglied: Pjordorf
08.09.2010 um 18:50 Uhr
Hallo,

> Zitat von nsilux:
Na ja, ich habe keinen Zugriff auf den Vigor, der Betreuer ist nur sporadisch alle paar Wochen da...
Aber du kannst ihn mal neu starten, oder?

Aber gundsätzlich scheint DNS ja schon richtig zu laufen (reichlich Seiten werden ordentlich geladen.
Scheint aber nicht so zu sein das der DNS richtig läuft (hättest ja hier sonst nicht gefragt).

Den Browser-Cache habe ich auch gelöscht.
Das betrifft aber NUR deinen Client. Nicht den DNS Server im Vigor.

Ich frage mich, was da zwischen Browser (ich glaube Layer 7) und DNS-Server ( auch Layer 7) ausgehandelt wird, daß nur
manche Seiten - pardon: Namen - nicht aufgelöst werden.
Nichts.

Grundsätzlich spricht nur dagegen, daß die IP eines DNS sich ja auch mal ändern kann bzw die Adresse kein DNS
mehr bietet.
Deshalb lieber einen Namen oder am besten dynamisch über den Router.
Schon klar. geht aber zur zeit nicht bei dir

Wenn du an allen Clients dieses problem hast, aber nach ändern des DNS eintrags am Client auf einen Externen DNS, und dann die Probleme verschwunden sind, wo meinst du ist dann das Problem zu suchen und zu lösen? Da bleibt dann nur noch dein Vigor und danach dein ISP. (Malware wollen wir mal aussen vor lassen.)

Peter
Bitte warten ..
Mitglied: nsilux
08.09.2010 um 21:18 Uhr
Hallo Peter,


Zitat von Pjordorf:
> Na ja, ich habe keinen Zugriff auf den Vigor, der Betreuer ist nur sporadisch alle paar Wochen da...
Aber du kannst ihn mal neu starten, oder?
klaro, ist auch geschehen; allein das Symptom auf dem win 7 ist stabil geblieben.

> Aber gundsätzlich scheint DNS ja schon richtig zu laufen (reichlich Seiten werden ordentlich geladen.
Scheint aber nicht so zu sein das der DNS richtig läuft (hättest ja hier sonst nicht gefragt).
OK
gleichzeitig treten diese Probs aber auf z.B. XP nicht auf.

> Den Browser-Cache habe ich auch gelöscht.
Das betrifft aber NUR deinen Client. Nicht den DNS Server im Vigor.
siehe oben, Vigor Kaltstart.

> Ich frage mich, was da zwischen Browser (ich glaube Layer 7) und DNS-Server ( auch Layer 7) ausgehandelt wird, daß nur
> manche Seiten - pardon: Namen - nicht aufgelöst werden.
Nichts.
-(

> Grundsätzlich spricht nur dagegen, daß die IP eines DNS sich ja auch mal ändern kann bzw die Adresse kein
DNS
> mehr bietet.
> Deshalb lieber einen Namen oder am besten dynamisch über den Router.
Schon klar. geht aber zur zeit nicht bei dir
delhalb ja auch der Kunstgriff

Wenn du an allen Clients dieses problem hast, aber nach ändern des DNS eintrags am Client auf einen Externen DNS, und dann
die Probleme verschwunden sind, wo meinst du ist dann das Problem zu suchen und zu lösen? Da bleibt dann nur noch dein Vigor
und danach dein ISP. (Malware wollen wir mal aussen vor lassen.)

ich werde nochmal mit 2 weiteren PCs (weiterer Win 7 prof 64bit und ein XP32bit) die Settings und das Verhalten dirket vergleichen. Kann aber ein par Tage dauern. Ich poste dann das Ergebnis.

vorläufig noch mal Danke

Uwe
Bitte warten ..
Mitglied: GuentherH
08.09.2010 um 21:33 Uhr
Hallo.

DNS-Server=Router / Gateway 192.168.1.1

Also das wage ich jetzt so zu bezweifeln. Dieses Gerät bietet auf keinen Fall einen DNS Server. Der einzige Eintrag, der möglich ist, dass über den DHCP Server ein externer DNS an den Client weitergegeben wird.

Rufe daher einmal ipconfig /all auf deinem Client auf. Wenn hier bei der DNS Adresse 192.168.1.1 steht, dann ist der Vigor schlicht und einfach falsch konfiguriert.

LG Günther
Bitte warten ..
Mitglied: nsilux
14.09.2010 um 10:05 Uhr
Hallo Günther,

Zitat von GuentherH:
> DNS-Server=Router / Gateway 192.168.1.1

Also das wage ich jetzt so zu bezweifeln. Dieses Gerät bietet auf keinen Fall einen DNS Server. Der einzige Eintrag, der
möglich ist, dass über den DHCP Server ein externer DNS an den Client weitergegeben wird.

nun, ich habe die Settings des Vigor auf dem Client noch mal geprüft: er gibt definitiv sich selbst als DNS-Server aus. Soweit von der Konsole gefordert, klappt die Auflösung ja auch, allein einige Seiten werden AUSSCHLIESSLICH beim browsen (ohne jeden Proxy!) - auch nach einem Kaltstart des Vigor und ipconfig /flushdns auf dem Client - nicht so gelöst wie vorgesehen. Ich warte noch auf die Möglichkeit, mit dem Vigor-Admi zu sprechen und gebe dann laut.
bis dahin Danke.

Uwe
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows Server
Proxy für alle User adden - Skript geht nicht (Windows Server) (4)

Frage von bytetix zum Thema Windows Server ...

Windows Server
Windows Server 2008 R2 Aero-Design auf Remote Desktop geht nicht (3)

Frage von Motherboard33 zum Thema Windows Server ...

Notebook & Zubehör
gelöst Notebook geht im Betrieb nach Windows-Neuinstallation aus (3)

Frage von achklein zum Thema Notebook & Zubehör ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...