Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Gemappte Netzwerklaufwerke verweigern nach einer gewissen Zeit den Zugriff

Frage Linux Linux Netzwerk

Mitglied: Bear-X

Bear-X (Level 1) - Jetzt verbinden

13.01.2011 um 14:46 Uhr, 6686 Aufrufe, 2 Kommentare

Hallo,

wie der Titel meines Problems schon beschreibt, verliert ein WIN 7 Rechner
nach einer gewissen Arbeitszeit plötzlich den Zugriff auf die gemappten Laufwerke.
Diese werden dann im Explorer mit einem "X" markiert.
Bei Neuanmeldung geht allerdings alles wieder.

Kann es sein, dass dies speziell mit WIN 7 zusammenhängt? Auf den XP Rechnern
kann ich von solch einem Problem glücklicher Weise nicht berichten.

Kann mir jemand weiterhelfen?

Danke im Vorraus!

Mit freundlichen Grüßen
-B.
Mitglied: askando
13.01.2011 um 15:26 Uhr
Das ist "normal" und hängt mit einem Eintrag in der Registry zusammen, welcher den Timeout einer Verbindung definiert...

IMTK, das das mit dem von Microsoft eingesetzten NBT (NetBIOS over TCP/IP) zusammenhängt. Die Netzlaufwerke werden fest eingehängt, somit besteht eine dauerhafte SMB/CISF verbindung, welche "Unnötig" Ressourcen belegt -> um dies zu verhindern hat MS den Timeout definiert, die Verbindung steht jedoch unmittelbar nach dem Empfang eines SMB Packetes wieder...

Um diese Einstellung zu ändern kann man folgendes tun:

Unter: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters] den REG_DWORD Wert "Autodisconnect" ändern.

Die dezimale Darstellung entspricht, den Minuten bis zur Trennung bei Leerlauf. Dieser Wert kann auf z.Bsp. 1440 gestellt werden, was 24 Std. entspräche. Eine andere Möglickeit ist den Wert auf -1 zu stellen. Dies stellt die automatische Trennung ab.

Unter der CMD-Konsole kann man alternativ folgendes eingeben:

"NET CONFIG SERVER /autodisconnect:-1" = Abschalten, oder jede beliebige andere Zahl in Minuten, je nachdem was für eine Zeit gesetzt werden soll.

Dies gilt für Srv und Clients, ergo den Befehl bzw. die Änderung an allen Clients und beim Server ausführen.


Bei einer gewissen Anzahl an Arbeitsplätzen ist es evtl. klug den Befehl mit ins Anmeldescript einzubauen. Viele Firmen haben diese Probleme nicht, da es gewisse Programme gibt die immer wieder ein Request starten und somit die Verbindung permament aufrecht gehalten wird.

P.s. das Prob ist seit 2001 bekannt ^^
Bitte warten ..
Mitglied: Bear-X
14.01.2011 um 19:19 Uhr
Klasse!
Hatte diese Problem immer wieder, doch bis jetzt
leider noch nicht lösen können.

Vielen Dank askando!

Mit freundlichen Grüßen,
-B.
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (24)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...