Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Gemapptes Laufwerk wird erst nach Aufruf über den Explorer von Anwendung gefunden

Frage Netzwerke

Mitglied: Hubtus

Hubtus (Level 1) - Jetzt verbinden

18.09.2007, aktualisiert 15:27 Uhr, 8152 Aufrufe, 5 Kommentare

Eine Anwendung unter Win XP Pro möchte auf ein gemapptes Laufwerk zugreifen. Dieses Laufwerk (N: ) wird aber von der Anwendung nicht gefunden, obwohl es ordnungsgemäß gemappt wurde und auch beim erneuten Anmelden wieder verbunden wird. Erst wenn der Laufwerksinhalt einmal im Explorer angezeigt wurde findet die Anwendung auch das Laufwerk.

Auf ein anderes Netzlaufwerk (Z: ) kann ordnungsgemäß und ohne Probleme zugegriffen werden.

Wo liegt das Problem? Wer kennt eine Lösung?


Danke im Voraus.

Hubertus
Mitglied: TuXHunt3R
18.09.2007 um 13:48 Uhr
Wie werden die Laufwerke bei euch gemappt? Von Hand, per Loginbatch, per Login-VBScript?

Wenn du mit einem Loginscript arbeitest (Batch oder VBScript), poste doch mal den Code dieses Files
Bitte warten ..
Mitglied: Hubtus
18.09.2007 um 14:06 Uhr
Die Laufwerke sind ganz normal im Explorer per "Netzlaufwerk verbinden..." gemappt.
Bitte warten ..
Mitglied: TuXHunt3R
18.09.2007 um 15:27 Uhr
Arbeitest du in einer Domäne?

Wenn NEIN, pack den folgenden Code in ein Batchfile (Textdatei mit Endung "bat"), ersetze <servername> und <freigabe> durch deine Angaben und pack das Ding in den Autostart.

01.
net use N: /delete 
02.
net use N: \\<servername>\<freigabe>
Ein Beispiel:

01.
net use N: /delete 
02.
net use N: \\srv01\verwaltung$

Probier das Mal und gib uns Bescheid, ob es etwas gebracht hat.
Bitte warten ..
Mitglied: MaryLong
11.05.2010 um 11:26 Uhr
Guten Morgen

ich weiss, der Beitrag ist schon uralt, trotzdem nochmals eine Anfrage in die selbe Richtung. Habe momentan das genannte Problem. Für eine Applikation werden auf drei Win2k3-Server nmittels KIX-Script 4 Laufwerke auf WinXP SP3 Clients gemappt. In 99% der Fälle funktioniert dies auch einwandfrei, aber ab und an liegt genau das genannte Problem auf einem Client an.

"Das Laufwerk wird von der Anwendung nicht gefunden, obwohl es ordnungsgemäß gemappt wurde und auch beim erneuten Anmelden wieder verbunden wird. Erst wenn der Laufwerksinhalt einmal im Explorer angezeigt wurde findet die Anwendung auch das Laufwerk."

Es betrifft nicht immer den selben Client, aber immer dasselbe Laufwerk -> X:. Das Mapping erfolgt beim Logon mittels KIX-Script über die DC's. Der Codeauszug:

USE J: /DEL
USE S: /DEL
USE V: /DEL
USE X: /DEL
USE J: "\\servera\Applikationsordner"
USE S: "\\serverb\Gruppenshare"
USE V: "\\serverb\Applikationsvorlagen"
USE X: "\\serverc\Applikationsshare"

Tests Batchdatei (NET USE X: /DELETE und NET USE X: "\\serverc\Applikationsshare") führen zum selben Ergebnis.

Any ideas? Bin für jeden Tipp dankbar.

Schönen Tag auch
MaryLong
Bitte warten ..
Mitglied: TuXHunt3R
01.06.2010 um 11:43 Uhr
Hallo MaryLong (ich rauche American Spirit )

Ausser das Laufwerke mit /persistent:yes zu mappen und das Automatische Trennen zu entfernen: Keine.

Gruss TuXHunT3R
Bitte warten ..
Ähnliche Inhalte
Windows Server
Laufwerk verstecken im Explorer (10)

Frage von chattie zum Thema Windows Server ...

Windows 10
gelöst W10 kein Zugriff auf gemapptes Laufwerk als Admin (4)

Frage von leknilk0815 zum Thema Windows 10 ...

Neue Wissensbeiträge
Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(2)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Windows 10

Das Windows 10 Creators Update ist auf dem Weg

(5)

Anleitung von BassFishFox zum Thema Windows 10 ...

Administrator.de Feedback

Tipp: Ungelöste Fragen ohne Antwort in Tickeransicht farblich hinterlegen

Tipp von pattern zum Thema Administrator.de Feedback ...

Viren und Trojaner

Neue Magazin Ausgabe: Malware und Angriffe abwehren

Information von Frank zum Thema Viren und Trojaner ...

Heiß diskutierte Inhalte
Windows Systemdateien
Warum System auf "C:" (29)

Frage von DzumoPRO zum Thema Windows Systemdateien ...

LAN, WAN, Wireless
Cisco SG200: Auf bestimmtem vLAN bestimmte TCP-Ports sperren (16)

Frage von SarekHL zum Thema LAN, WAN, Wireless ...

Windows Server
gelöst Update BackupExec 2015 auf 2016 führt zu SQL-Server Problem (16)

Frage von montylein1981 zum Thema Windows Server ...

Cloud-Dienste
gelöst Bitcoins minen über Nacht? (16)

Frage von 1410640014 zum Thema Cloud-Dienste ...