Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Gentoo The root block device is unspecified

Frage Linux

Mitglied: 84331

84331 (Level 1)

15.01.2010, aktualisiert 19:06 Uhr, 2900 Aufrufe, 1 Kommentar

Hallo alle Linuxer

Mein Problem ist folgendes ich habe Gentoo 2007 installiert auf einem Lenovo R61i

Installation verlief ohne Probleme jedoch danach beim booten gab es ein Problem

The root block device is unspecified

hier meine grub.conf datei:

default 0
timeout 30

title=Gentoo Linux
root (hd0,0)

kernel /kernel-genkernel-x86-2.6.19-gentoo-r5 root=/dev/ram0 init=/linuxrc
ramdisk=8192 real_root=/dev/sda3 udev der Rechner besitzt keine hda platten sondern nur sda
initrd /initramfs-genkernel-x86-2.6.19-gentoo-r5

kernel bezeichnung stimmt habs ausgelesen....

Bitte um Hilfe danke schonmal im voraus
Mitglied: datasearch
15.01.2010 um 23:48 Uhr
Da du Gentoo einsetzt gehe ich von einiger Linux-Erfahrung aus.

Bitte minimiere deine Bootparameter auf das Nötigste. Öffne die Grub-Shell am Bootprompt und versuche den kernel direkt zu laden.

Bist du Sicher das der Kernel auf hd0,0 im Root liegt? Ist hd0,0 dein /boot device? Falls ja, bitte untenstehende Pfade korrigieren und das /boot entfernen.

grub> root(hd0,0)
grub> kernel /boot/vmlinuz (Falls der Symlink nicht vorhanden ist, bitte anlegen)
grub> boot
loading .......

Wenn der Kernel jetzt Lädt, aber kein Root-Device findet, stimmen deine Plattenangaben. Also, erneut Reboot und das ganze nochmal mit der initrd:

grub> root(hd0,0)
grub> kernel /boot/vmlinuz root=/dev/ram0 init=/linuxrc real_root=/dev/sda3 (Falls der Symlink nicht vorhanden ist, bitte von CD booten und anlegen)
grub> initrd /boot/initrd (Falls der Symlink nicht vorhanden, bitte von CD booten und anlegen)
grub> boot
loading .....

Sollte es wieder zum Fehler kommen, baue dir deinen eigenen Kernel indem du die für den Bootvorgang wichtigen Treiber fest einbaust. Dann benotigst du keine initial ramdisk und solche Probleme gehören der Vergangenheit an.

Solltest du nicht wissen was ich hier schreibe solltest du ernsthaft überlegen eine andere Distribution zu verwenden. Gentoo erfordert einiges an Wissen. Den Bootvorgang hinzubekommen ist nicht das riesen Problem, wenn ich dann aber an USE Flags, Netzwerk, X11 Konfiguration, HAL (XML-Basierende Konfigurationsdateien) oder spezielle Dinge wie Auswahl der locales.gen, unicode, java ..... überlege dir ganz genau ob du "bereit" für Gentoo bist.
Bitte warten ..
Ähnliche Inhalte
Backup
QNAP NASC77A61 mit Fehlerhaften Blöcken (11)

Frage von Fitzel69 zum Thema Backup ...

Server
gelöst Als Benutzer Root Datei veraendert (7)

Frage von TomTheCat zum Thema Server ...

Ubuntu
gelöst Webmin Root Benutzer gelöscht (4)

Frage von ClepToManix zum Thema Ubuntu ...

Verschlüsselung & Zertifikate
gelöst Root Zertifikat in Firefox importieren (6)

Frage von DarkScabs zum Thema Verschlüsselung & Zertifikate ...

Neue Wissensbeiträge
Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

(2)

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Viren und Trojaner

CNC-Fräsen von MECANUMERIC werden (ggf.) mit Viren, Trojanern, Würmern ausgeliefert

(4)

Erfahrungsbericht von anteNope zum Thema Viren und Trojaner ...

Windows 10

Windows 10: Erste Anmeldung Animation deaktivieren

(3)

Anleitung von alemanne21 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Netzwerkprotokolle
gelöst Leiten "dumme" Switches VLAN-Tags mit durch? (26)

Frage von coltseavers zum Thema Netzwerkprotokolle ...

Netzwerkgrundlagen
Kann auf Freigabe nicht Zugreifen (16)

Frage von leon123 zum Thema Netzwerkgrundlagen ...

Windows Server
gelöst Neues KB für W10 1607 und W2K16 wieder mal nicht im WSUS 3.0, hat das noch jemand? (16)

Frage von departure69 zum Thema Windows Server ...

Router & Routing
FTTH bzw FTTB Router (13)

Frage von ukulele-7 zum Thema Router & Routing ...