Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Geplante Task auch wenn kein Nutzer angemeldet ist

Frage Microsoft Windows Server

Mitglied: facebraker

facebraker (Level 1) - Jetzt verbinden

03.02.2012 um 14:18 Uhr, 10853 Aufrufe, 13 Kommentare

Hallo,

ich habe ein Problem zum Freitag.
Ich möchte ein VBS-Script für eine kleine Datensicherung nutzen, dies möchte ich über "Geplante Task" starten.
Das ganze soll auf einen Windows Server 2003 32Bit laufen.

Ich habe also einen geplanten Task eingerichtet und lasse das VB-Skript laufen, mein Problem ist, wenn ich als Administrator
angemeldet bin, startet es, wenn ich mich als Administrator abmelde, startet es nicht.

Ich habe den Haken "Nur ausführen wenn angemeldet" natürlich nicht angehakt, ich lasse den Task auch als Domain-Administrator laufen mit Kennwort.

Ich habe absolut keine Idee wo ich noch suchen kann, braucht der Administrator vielleicht ein Recht Tasks zu starten?

Würde mich über eure Hilfe sehr freuen!

Gruß Alex
Mitglied: jayjay0911
03.02.2012 um 14:36 Uhr
Normal läuft das alles reibungslos, bei uns gab's damit jedenfalls noch nie Probleme.
Hast du denn auch das Kennwort des Admins eingegeben, in desen Namen das Script ausgeführt werden soll und ist dieser in der Karteikarte "Sicherheit" mit Vollzugriff ausgestattet? Für "System" gilt das selbe, also auch Vollzugriff. Sind aber eigentlich Standardeinstellungen.
Nur das Passwort muss noch mal von Hand eingetragen werden.
Im Eventlog müsste doch ein Fehler stehen: ob gestartet wurde, warum abgebrochen, falsches Passwort, etc.??
Bitte warten ..
Mitglied: nikoatit
03.02.2012 um 14:46 Uhr
Moin,

noch als Ergänzung zu dem Beitrag von jayjay0911:
Auch unter geplante Task müsste der Status von der letzten Ausführung einsehen können (immer ein Code aus z.B. "X" und "0").

Gruß
Bitte warten ..
Mitglied: facebraker
03.02.2012 um 15:01 Uhr
Hallo, kein Fehler.
Hier das Beispiel er sollte 12:05Uhr starten, 12:10Uhr habe ich auf das System geschaut:

http://s14.directupload.net/file/d/2789/btx7bu29_png.htm

Auch im Eventlog nichts
Bitte warten ..
Mitglied: jayjay0911
03.02.2012 um 15:04 Uhr
Nächste Ausführungszeit: Nie!
Zeitplan richtig konfiguriert?
Bitte warten ..
Mitglied: DerWoWusste
03.02.2012 um 15:23 Uhr
Der Scheduler hat doch ein Log. Schau rein, dann weißt Du, was Sache ist. Evtl. fehlt dem Nutzer das Recht "Anmelden als Stapelverarbeitungsauftrag". Achtung: dieses muss auf Domänenebene per GPO festgelegt werden.
Bitte warten ..
Mitglied: facebraker
06.02.2012 um 11:52 Uhr
Guten Morgen, ich bin wieder auf Arbeit und in der Reichweite des Servers
Außerdem rechnet mir das keiner an wenn ich am Wochenende per VPN arbeite, außer mein Ego ^^

@jayjay0911: das "nie" ist richtig, ich habe es probiert mit einmaligen ausführen, er hat es versucht und nicht geklappt.

@DerWoWusste: ich muss mal ganz blöd fragen wo finde ich das Log des Schedulers unter den Ereignisprotokollen ist nichts

Ich habe deinen Rat befolgt und das Recht gesetzt, brachte keinen Erfolg, ich vermute, ich habe einen Denkfehler drin. Ich habe folgendes gemacht.

- ich habe eine neues GPO auf Domainebene angelegt und verknüft, berechtigungen wie standard drin Auth.Benutzer, Sicherheitsfilterung Auth.Benutzer
- GPO bearbeitet: Computerkonfiguration\Windows-Einstellungen\Sicherheitseinstellungen\Lokale Richtlinien\Zuweisen von Benutzerrechten\Anmelden als Stapelverarbeitungsauftrag
diesen aktiviert und bei Benutzer und Gruppen den DOMÄNE\Administrator und die Administratoren eingetragen.
- alles geschlossen und ein gpupdate /force gemacht.

War das korrekt, für mich war es logisch, dass ich das Recht an Benutzer binde, ansonsten kann es ja jeder oder mache ich da einen Denkfehler weil es eine Computerkonfiguration ist, ist es komplett falsch?


Danke für Eure Hilfe
Bitte warten ..
Mitglied: DerWoWusste
06.02.2012 um 13:22 Uhr
Das ist so richtig gewesen. Nur, wo hast Du gpupdate.force gemacht? Auf einem Client musst Du es machen, nicht am Server und danach mittels rsop.msc prüfen, ob es auch angewendet wurde.
Das Log findest im Taskplaner im Menü "erweitert".
Bitte warten ..
Mitglied: facebraker
06.02.2012 um 14:15 Uhr
Den Task möchte ich auf dem DC ausführen, also das gupdate.force habe ich auf dem DC gemacht.
rsop.msc kannte ich noch nicht, aber sehr sehr praktisch.
Ich habe kontrolliert und den Nutzer unter Computerkonfiguration\Windows-Einstellungen\Sicherheitseinstellungen\Lokale Richtlinien\Zuweisen von Benutzerrechten\Anmelden als Stapelverarbeitungsauftrag gefunden, sollte
also auch funtionieren, tut es aber nicht

Ich habe auch folgendes probiert: http://support.microsoft.com/kb/867466/en-us

Brachte auch kein Erfolg.

Das Log zeigt folgenden Fehler:

"TESTDASI.job" (TESTDASI.exe) 06.02.2012 13:50:00 FEHLER
Der Task konnte nicht gestartet werden..
Der genaue Fehler ist:
0x80070005: Zugriff verweigert
Suchen Sie die Anwendung über die Schaltfläche "Durchsuchen" auf der Registerkarte "Allgemein" des Tasks..


Das "komische" ist, dass es funktioniert wenn ich als Administrator angemeldet bin, da findet er irgendwie die Anwendung???
Wie hier unten zu sehen ist:

"TESTDASI.job" (TESTDASI.exe)
Start: 06.02.2012 13:00:00
"TESTDASI.job" (TESTDASI.exe)
Ende: 06.02.2012 13:00:03
Ergebnis: Der Task wurde mit folgendem Ergebniswert abgeschlossen: (0).


Gruß Alex
Bitte warten ..
Mitglied: DerWoWusste
06.02.2012 um 14:38 Uhr
Wenn der Admin nicht angemeldet ist, sind evtl. Netzlaufwerke nicht verbunden. Worauf könnte der Task zugreifen wollen?
Bitte warten ..
Mitglied: facebraker
06.02.2012 um 15:16 Uhr
BINGO
Hab den Wald vor lauter Bäumen nicht gesehen, die Netzlaufwerke sind so selbstverständlich für einen, da greift man einfach zu und bedenkt nicht, dass sie nicht
vorhanden sind, wenn man abgemeldet ist. Vielen Dank für den Tipp

Gruß Alex
Bitte warten ..
Mitglied: DerWoWusste
06.02.2012 um 16:06 Uhr
Schön. Toll auch, das MS schreibt "Zugriff verweigert", wo "Pfad nicht gefunden" hingehört.
Bitte warten ..
Mitglied: facebraker
06.02.2012 um 16:27 Uhr
Genau, da wird man ja auch auf eine falsche Fährte gelockt.
Woher soll man wissen, dass er keine Dateirechte im Nirvana hat

Ich teste das heute Abend noch, bei Erfolg markiere ich den Thread als gelöst

Danke Dir noch einmal!
Bitte warten ..
Mitglied: facebraker
09.02.2012 um 10:48 Uhr
Eines der 4 VB-Skripte habe ich nicht zum laufen bekommen, obwohl alles richtig war.
Ist aber nicht das Problem, ich habe VB-Skript komplett ersetzt und ein VB.NET Programm geschrieben, ist jetzt "schicker" und leichter zu warten.

Danke für Eure Hilfe!

*gelöst*
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(1)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Datenschutz
Adups: China-Billighandys spionieren ihre Nutzer ab Werk aus (1)

Link von magicteddy zum Thema Datenschutz ...

Verschlüsselung & Zertifikate
gelöst Wieso kann eine CA Zertifikate ausstellen und ein normaler Nutzer nicht? (7)

Frage von Mimetype zum Thema Verschlüsselung & Zertifikate ...

Webbrowser
Bericht: Browser-Add-on Web of Trust späht Nutzer aus (1)

Link von runasservice zum Thema Webbrowser ...

Netzwerkmanagement
gelöst Welche Freigaben haben welche Rechner im Netzwerk und welche User ist angemeldet? (5)

Frage von M.Marz zum Thema Netzwerkmanagement ...

Heiß diskutierte Inhalte
DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (10)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...

Backup
Clients als Server missbrauchen? (9)

Frage von 1410640014 zum Thema Backup ...