Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Get-WmiObject zieht von gewissen Befehlen die Remote-Inforamtionen nicht

Frage Entwicklung

Mitglied: Chambion

Chambion (Level 1) - Jetzt verbinden

27.04.2012, aktualisiert 11:19 Uhr, 3689 Aufrufe, 6 Kommentare

Hallo alle zusammen,

im folgenden mein Skript mit dem ich die Daten von PCs auslesen möchte:

$pc = "test-pc"
$cs = Get-WmiObject -Query "Select * from Win32_Computersystemproduct " -computername $pc
write-host "Hersteller : " $cs.Vendor
write-host "Model : " $cs.Name
write-host "Service-Tag : " $cs.IdentifyingNumber
$bi = Get-WmiObject -Query "Select * from Win32_Bios" -computername $pc
write-host "BIOSVersion : " $bi.SMBIOSBIOSVersion
write-host "BIOSManufacturer: " $bi.Manufacturer
write-host "BIOSName : " $bi.Name
$pr = Get-WmiObject -Query "Select * from Win32_Processor" -computername $pc
write-host "Model : " $pr.Name
write-host "Kerne : " $pr.NumberOfLogicalProcessors
$ph = Get-WmiObject -Query "Select * from Win32_PhysicalMemory" -computername $pc
write-host "RAM in byte : " $ph.Capacity
write-host "Taktung : " $ph.Speed

die Ausgabe sieht wie folgt aus:

Hersteller : Dell Inc.
Model : Studio XPS 1645
Service-Tag : "zensiert"
BIOSVersion : A12
BIOSManufacturer: Dell Inc.
BIOSName : Ver 1.00 BIOS A12 PARTTBL
Model : Intel(R) Core(TM) i7 CPU Q 720 @ 1.60GHz
Kerne : 8
RAM in byte :
Taktung :

____________________________________________________________________________





Warum wird mir "RAM in byte" und "Taktung" von dem Remote-PC nicht angezeigt?? Wenn ich den Befehl auf meinen eigenen PC ausführe klappt es. Desweitern kann ich auch den RAM und die Taktung auslesen wenn ich den Befehl direkt in die Powershell eingebe. Führe ich das komplette Skript in der Powershell aus funktioniert es auch wieder nicht.

Kennt jmd das Problem ?

Lieben Gruß
Mitglied: Penny.Cilin
27.04.2012 um 13:53 Uhr
Was passiert, wenn Du die Informationen direkt via WMIC abrufst? Funktioniert es dann?
Ich kenne unter WMIC die Parameter /NODE /USER /PASSWORD. Hast Du diese in Deinem Powershell Script umgesetzt?

Ich kenne mich mit Powershell nicht aus.
Bitte warten ..
Mitglied: Chambion
27.04.2012 um 13:58 Uhr
Nein habe ich nicht, aber das muss ich glaube ich auch nicht, oder? Denn wenn cih die Befehle einzeln direkt in die PS eingebe klappt es.
Bitte warten ..
Mitglied: Penny.Cilin
27.04.2012 um 14:14 Uhr
Ich habe Dein Script mal auf einer VM ausprobiert. Bis auf die Taktung funktioniert es. Wenn Du es Remote nutzen willst mußt Du wie gesagt die Powershell äquivalenten Parameter wie in meiner vorherigen Post umsetzen.

Hersteller : VMware, Inc.
Model : VMware Virtual Platform
Service-Tag : VMware-42 01 ca ba ba 85 bf 87-ba 42 2c 8d 2b c6 00 eb
BIOSVersion : 6.00
BIOSManufacturer: Phoenix Technologies LTD
BIOSName : PhoenixBIOS 4.0 Release 6.0
Model : AMD Opteron(tm) Processor 6136
Kerne : 1
RAM in byte : 4294967296
Taktung :
Bitte warten ..
Mitglied: Chambion
27.04.2012 um 14:54 Uhr
Puh ich muss sagen da stoße ich an meine Grenzen ^^ bin nämlich ganz neu in dem Gebiet und wunderte mich schlicht warum ich die anderen Daten auslesen kann aber die beiden nicht.. du weißt aber nicht wie ich dieses dann realisieren muss oder?
Bitte warten ..
Mitglied: Penny.Cilin
27.04.2012 um 21:35 Uhr
Ich habe es grade nochmal auf meinem Laptop ausprobiert. Gleiches Phänomen, wie bei Dir. RAM und Taktung werden nicht angezeigt.
Wobei auf meinem Laptop habe ich Windows 7 Home Premium installiert, die VM war Windows Server 2008 R2.

Bzgl. Powershell muss ich leider passen.
Bitte warten ..
Mitglied: Chambion
30.04.2012 um 08:24 Uhr
Trotzdem schonmal vielen Dank für deine Hilfe. Vielleicht kann das ja ein Powershellkunder Fachmann jetzt noch für einen Anfänger übersetzen (nicht vorkauen ;) ) damit ich weiter komme

Vi
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Batch & Shell
gelöst Get-WmiObject, nach Netzwerkadapter filtern (11)

Frage von Flodsche zum Thema Batch & Shell ...

Windows Server
2012 R2 Remote Desktop Farm - Userprofile (4)

Frage von quin83 zum Thema Windows Server ...

Batch & Shell
gelöst Powershell Get-Content Inhalt filtern (1)

Frage von derhoeppi zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Viren und Trojaner
gelöst Wie werde ich den Mist "fanli90" wieder los? (17)

Frage von Taumel zum Thema Viren und Trojaner ...

Switche und Hubs
LAG zwischen Cisco SG300 und Dlink DGS1100 herstellen - wie? (15)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...

Hardware
Lenovo Yoga 500 über angeschlossene USB Tastatur booten (13)

Frage von thomasreischer zum Thema Hardware ...

CPU, RAM, Mainboards
Hardware Fragen (12)

Frage von xaver-2 zum Thema CPU, RAM, Mainboards ...