Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Getrennte RemoteApp - Fehler virtueller Speicher

Frage Microsoft Windows 7

Mitglied: ts-wela

ts-wela (Level 1) - Jetzt verbinden

12.07.2013 um 11:51 Uhr, 4258 Aufrufe, 9 Kommentare, 1 Danke

Hallo zusammen.

Ich habe bei einem unserer Kunden folgendes Problem:

Der Kunde hat einen Terminalserver (Win 2008 R2) auf dem das Pflegeprogramm läuft. Alle Clients (ca. 20) greifen via verteilter RemoteApp auf dieses Programm zu. Teilweise sind Windows 7, teilweise Windows XP Rechner im Einsatz.

Ein PC zeigt nach ca. 30 Minuten immer folgende Fehlermeldung an:

"Getrennte RemoteAPP"

"Dieser Computer kann keine Verbindung mit dem Remotecomputer herstellen"

"Auf dem Computer ist nicht genügend virtueller Speicher vorhanden. Schließen Sie die anderen Anwendungen, und stellen Sie die Verbindung erneut her."

Client PC ist ein Windows 7 PC 32bit. RAM wurde bereits von 1 GB auf 3 GB aufgestockt, den virtuellen Speicher habe ich auch erhöht. Als Virenschutz wird Kaspersky eingesetzt, welches jedoch auch nicht die Ursache ist.

Wenn der User alle Anwendungen, die er bei der täglichen Arbeit benötigt, geöffnet hat ist der RAM zur Hälfte ausgelastet. Die CPU verhält sich ganz normal.

Komischerweise ist dieser PC auch noch einer der leistungsstärksten und weist als Einziger diesen Fehler auf.

Habt ihr eine Idee? Habe schon stundenlang gegoogled und rumprobiert, jedoch ohne Erfolg.

Über Rückmeldungen würde ich mich sehr freuen! Vielen Dank!

Mit freundlichen Grüßen ts
Mitglied: templier
12.07.2013, aktualisiert 13.07.2013
Zitat von ts-wela:
Als Virenschutz wird Kaspersky eingesetzt, welches jedoch auch nicht die Ursache ist.

Was macht Dich hier so absolut sicher? Ist das ein neuer Client den ihr ins Netz gehängt habt, oder ist er schon länger im Netz und das Problem kam selbstverständlich (wie immer) von heute auf Morgen, ohne das "was gemacht" wurde? Wie werden bei euch die Updates gefahren? Jeder als "Selbstbediener", also jeder Client loggt sich über internet bei MS ein und saugt sich was er braucht, oder Zentral (Bsp: WSUS, etc...)?

Kleiner Tip: Der RAM ist es mit Sicherheit nicht. So eine Meldung kommt unter Terminalservern hier- und da einfach mal vor. Sie bezeichnet aber nicht das eigentliche Problem, und die Ursachen sind meist ganz verschiedener Natur. Ich habe hier allerdings schon eine recht konkrete Vermutung:

Ich denke nämlich dieser Client hat einen neueren Remotedesktopclient installiert und ihr solltet euren Server einfach mal wieder mit aktuellen Updates versorgen. Da der Server irgendwann während des "Gespächs" den Client nicht mehr "verstehen" kann und deswegen die Verbindung einfach beendet, sozusagen. Das würde auch zu Deiner Aussage passen, das es in etwa immer zur gleichen Zeit (nach ca. 30 Min.) passiert.

Liebe Grüsse
Ralph
Bitte warten ..
Mitglied: ts-wela
15.07.2013 um 10:45 Uhr
Hallo Ralph.

Vielen Dank für die Antwort.

Die Clients holen sich die Updates selbst. Wir haben das Netzwerk vor Kurzen übernommen und noch nicht alle Konfigurationen angepasst.

Ich muss dazu sagen, dass der Win 7 Client vor Kurzen mit SP1 ausgestattet wurde. Darüber habe ich selbst gar nicht nachgedacht .

Der Server hat auch noch ein paar optionale Updates offen, wo unter anderem auf die Remotedesktopdienste in Bezug auf Windows 8 und Windows 7 SP1 hingewiesen wird. Im Laufe der Woche werde ich dieses Update einmal installieren.

Ich melde mich dann.

Gruß ts
Bitte warten ..
Mitglied: templier
15.07.2013 um 10:54 Uhr
Zitat von ts-wela:
Der Server hat auch noch ein paar optionale Updates offen, wo unter anderem auf die Remotedesktopdienste in Bezug auf Windows 8
und Windows 7 SP1 hingewiesen wird. Im Laufe der Woche werde ich dieses Update einmal installieren.
Ahaaaaaaa!...Siehst Du? Dann melde Dich doch bitte noch einmal, nachdem Du den Server upgedatet hast

Liebe Grüsse
Ralph
Bitte warten ..
Mitglied: ts-wela
23.07.2013 um 08:38 Uhr
Hallo Ralph.

Sorry, dass ich mich erst jetzt melde.

Das Problem besteht weiterhin. Der Terminalserver ist nun, genau wie der Win7-Client, mit den aktuellsten Updates versorgt. Zudem habe ich die Remote-App neu verteilt. Einmal als RDP-File und einmal als MSI-File.

Bei beiden Szenarien kommt nach wie vor die Fehlermeldung:

"Getrennte RemoteAPP"

"Dieser Computer kann keine Verbindung mit dem Remotecomputer herstellen"

"Auf dem Computer ist nicht genügend virtueller Speicher vorhanden. Schließen Sie die anderen Anwendungen, und stellen Sie die Verbindung erneut her."

So langsam bin ich echt ratlos... Im Netz gibt es 5 Win7-Clients und ca. 15 WinXP-Clients, doch nur dieser eine Client macht Probleme...
Gruß Ts
Bitte warten ..
Mitglied: ts-wela
30.07.2013 um 08:49 Uhr
Hallo zusammen!

Hat niemand eine Idee...?
Bitte warten ..
Mitglied: ts-wela
01.10.2013 um 10:46 Uhr
Hallo.

Leider haben wir das Problem immer noch nicht lösen können.

Folgendes haben wir bislang durchgeführt:

-virtuellen Arbeitsspeicher von Client und Server erhöht
-Arbeitsspeicher im Client erhöht
-Server und Client mit aktuellen Updates versorgt

Des Weiteren sollten wir laut Microsoft TechNet mal einen anderen User verwenden, da eventuell das Nutzerprofil "defekt" sein könnte.
Auch das hat nicht zum gewünschten Erfolg geführt.

Hier noch einmal die Daten des Clients und des Servers:

Windows 7 Prof. 32 bit SP1
3 GB RAM

Windows Server 2008 R2 Standard 64 bit
24 GB RAM

Hat denn niemand eine Lösung für das Problem? Andere Windows 7 Clients mit identischen Daten haben dieses Problem nicht. Auch die RDP-Version ist auf allen Clients gleich...


Vielen Dank für eure mithilfe!

Gruß ts
Bitte warten ..
Mitglied: templier
05.10.2013 um 18:21 Uhr
Zitat von ts-wela:
Hallo.

Leider haben wir das Problem immer noch nicht lösen können.
Das ist leider sehr unschön....

Folgendes haben wir bislang durchgeführt:

-virtuellen Arbeitsspeicher von Client und Server erhöht
Warum? Das hat damit nichts zu tun...

-Arbeitsspeicher im Client erhöht
Siehe oben (Arbeitsspeicher) hat damit auch nichts zu tun...

-Server und Client mit aktuellen Updates versorgt
Sehr gut - So gehört sich das...

Des Weiteren sollten wir laut Microsoft TechNet mal einen anderen User verwenden, da eventuell das Nutzerprofil "defekt"
sein könnte.
Auch das hat nicht zum gewünschten Erfolg geführt.
Es hätte mich jetzt sehr gewundert, das MS-Ratschläge zu einem Erfolg führen...


Hier noch einmal die Daten des Clients und des Servers:

Windows 7 Prof. 32 bit SP1
3 GB RAM

Windows Server 2008 R2 Standard 64 bit
24 GB RAM

Hat denn niemand eine Lösung für das Problem? Andere Windows 7 Clients mit identischen Daten haben dieses Problem nicht.
Auch die RDP-Version ist auf allen Clients gleich...

Prüfe hier bitte mal: Ob die Einstellungen des RDP-Protokolles auch für alle gleich sind. Analog dazu: Die Lokalen- und Gruppenrichtlinien.

Viele liebe Grüsse
Ralph
Bitte warten ..
Mitglied: ts-wela
08.10.2013 um 12:58 Uhr
Hallo Ralph.

Die Einstellungen sind indentisch.

Gruß ts
Bitte warten ..
Mitglied: templier
08.10.2013, aktualisiert um 15:23 Uhr
Sali ts,

ok - Wenn ja alles (angeblich) gleich ist auf dieser Maschine - Im vergleich zu den andern Maschinen - Dann würde ich nun die "Hardcore-Schiene" fahren:

- Backup des betreffenden Systems machen (Bsp.: Acronis, oder ähnliches).
- System neu und sauber aufsetzen.
- Schauen was danach passiert, respektive: Ob der besagte Fehler wieder auftritt.

Hier vermute ich nun einfach mal, das einige Einträge in der Registry absolut zerschossen sind. Und die alle zu suchen/angleichen macht weniger Sinn, wie das System ggf. neu und sauber Aufzusetzen. Zumal ihr ja offenbar mit GPO´s arbeitet. Und wenn man hier (über GPO´s) mal was "umstellt" kann es sein, das sich gewisse Registryeinträge nur noch manuell zurückstellen lassen.

Viele Grüsse
Ralph
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Windows Server
gelöst BackupExec 2016 Fehler beim Backup von Windows 2016 (1)

Frage von Looser27 zum Thema Windows Server ...

Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (21)

Frage von JayyyH zum Thema Switche und Hubs ...

Vmware
Veeam für VM Ware Backup Fehler (2)

Frage von JoergN1968 zum Thema Vmware ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...

Microsoft Office
Keine Updates für Office 2016 (11)

Frage von Motte990 zum Thema Microsoft Office ...