Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Gigabit LAN von Win7 zu XP Pro langsam

Frage Netzwerke LAN, WAN, Wireless

Mitglied: chr2002

chr2002 (Level 1) - Jetzt verbinden

17.04.2011, aktualisiert 18.10.2012, 7464 Aufrufe, 10 Kommentare

Hallo, ich habe folgendes Problem,

ich habe einen Supermicro Superserver 5013C-T als Fileserver mit Windows XP Pro laufen. Der Client ist ein Win 7 Asus Notebook.
Der Server hat folgende Konfiguration:

Intel P4 3,2 Ghz
2 GB Ram
2 Intel Pro 1000 MT Nic´s
Intel ICH5 Raidcontroller (Das System läuft auf RAID 0 / 128 stripe)

Die Daten vom Win7 sind egal, warum, schreibe ich später.

Wenn ich vom Win7 Client auf den Server kopiere, dann wird die Netzwerkkarte beider Rechner nur mit 12-22% ausgelastet (Mit dem Diagnosetool im Taskmanager von Windows ermittelt)
Wenn ich aber vom XP Server auf den Client kopiere, dann werden beide Karten mit 50-70% ausgelastet.


Jetzt dazu, warum die Win7 Konfiguration egal ist

Vorher hatte ich auf dem Server Windows Server 2008 laufen und das kopieren in beide Richtungen hat eine Netzwerkkartenauslastung von 50-70% ergeben.
Am Windows 7 kanns also nicht liegen.
Als ich den Windows Server 2008 laufen hatte, hatte ich allerdings auch noch kein Raid System, sondern habe beide SATA Platten im IDE Modus betrieben.
Denke, daran kanns auch nicht liegen, die Platten waren im IDE Modus an der SATA Backplane und im Raid 0 Mode sind sie ja auch an der selben Backplane und am selben Controller. Raid 0 sollte eher eine Steigerung der Leistung bringen.


Ich habe bereits alle relevanten Treiber aktualisiert. (Chipsatz, Raid, Nic)

Switch - HP Procurve 2524
Verkabelung (Cat6)
Dosen (Cat6)
Keystone Module im Patchpanel (Cat6)
Kabellänge vom Wohnzimmer (Win7) ins Büro (Server) ist maximal 19 Meter
Woran kann das liegen ? Am Win 7 wohl nicht, wenns zum Win Server 2008 ohne Probleme lief.

EDIT : Netio Daten :

Netio Server auf dem XP Rechner:

TCP connection established
Packet size 1k bytes: 73.80 MByte/s Tx, 61.48 MByte/s Rx.
Packet size 2k bytes: 61.81 MByte/s Tx, 67.33 MByte/s Rx.
Packet size 4k bytes: 93.37 MByte/s Tx, 72.30 MByte/s Rx.
Packet size 8k bytes: 88.44 MByte/s Tx, 73.20 MByte/s Rx.
Packet size 16k bytes: 94.60 MByte/s Tx, 72.75 MByte/s Rx.
Packet size 32k bytes: 66.03 MByte/s Tx, 73.51 MByte/s Rx.
Done.

Netio Server auf dem Win 7 Rechner:

TCP connection established. (Win7)
Packet size 1k bytes: 60.31 MByte/s Tx, 70.56 MByte/s Rx.
Packet size 2k bytes: 67.18 MByte/s Tx, 83.32 MByte/s Rx.
Packet size 4k bytes: 72.37 MByte/s Tx, 82.67 MByte/s Rx.
Packet size 8k bytes: 73.15 MByte/s Tx, 82.57 MByte/s Rx.
Packet size 16k bytes: 72.45 MByte/s Tx, 88.00 MByte/s Rx.
Packet size 32k bytes: 73.46 MByte/s Tx, 71.78 MByte/s Rx.
Done.

/EDIT

Kommt XP evtl mit Gigabit nicht richtig klar ?

Hoffe, jemand kann mir helfen.

Lg chris
Mitglied: Coreknabe
17.04.2011 um 23:08 Uhr
Hallo Chris,

was sagt denn NetIO? Würde ich mal installieren und schauen.
Bitte warten ..
Mitglied: chr2002
17.04.2011 um 23:39 Uhr
Habe die Netio Daten oben eingefügt, laut den Daten passt die Netzwerkverbindung in beide Richtungen.
Das wundert mich jetzt sehr, weils am Raid ja auch net liegen kann, mit Win Server 2008 gings ja auch.
Bitte warten ..
Mitglied: Coreknabe
18.04.2011 um 00:59 Uhr
Grundsätzlich ist Windows XP als Serversystem, wenn auch nur als Fileserver, großer Mist. Hast Du ne Möglichkeit, ne Windows-Server-Version zu testen? Oder ich habe auch sehr gute Erfahrungen mit Ubuntu (Server) als Fileserver gemacht.
Evtl. limitiert XP da was, ist eben kein Serversystem.
Bitte warten ..
Mitglied: horst98
18.04.2011 um 08:05 Uhr
Hi,

das XP-System ist standardmäßig so konfiguriert, dass optimale Leistung für die Anwendungsprogramme und nicht das System gegeben ist. Da gibt es in der Systemsteuerung eine Einstellung. Vielleicht probierst Du, die Optimierung für Prozesse im Hintergrund.

Systemsteuerung->System->Systemeigenschaften->Erweitert -->Hintergrunddienste

Damit kannst Du noch was erreichen. Wenn das nicht reicht, dann schließe ich mich meinem Vorredner an. XP ist kein Serversystem.
Bitte warten ..
Mitglied: cardisch
18.04.2011 um 08:20 Uhr
Hallo Chris,

zuerst finde ich Absolutwerte von mind. 60 MB/sec schon einmal gar nicht so übel, aber zweitens weisst du nie, was dir noch so dazwischen funkt (Virenscanner z.B.).
Und solange du keine "absolute" Gleichheit bei den Vergleichsystemen hast (in deinem Fall RAID zu IDE Platten) wirst du nie dieselben Werte erwarten dürfen. Denn das RAID (ein Pseudo-RAID übrigens) braucht Rechenkraft, die nutzt es von der CPU.
Und ein P4 ist keine Höllenrechenmaschine.
Ich gehe realistisch davon aus, dass die CPU Auslastung "zu hoch" ist und demnach dein "Server" die Daten nicht schnell genug ausliefern kann.
Bei einer einzelnen IDE Platte huschen die Daten per DMA direkt zur Netzwerkkarte und verursachen eine solche Last nicht.
Testweise kannst du ja auch mal bei Win7 die Indizierung abschalten, das könnte noch etwas bringen.
Fazit:
Leb´mit diesen "schlechten" Werten...

Gruß

Carsten
Bitte warten ..
Mitglied: miniversum
18.04.2011 um 08:23 Uhr
1. Versuche mal ob es was bringt wenn du im Geräte-Manager in den Eigenschaften der Netzwerkkarte die Geschwindigkeit nicht auf automatische Erkennung eingestellt hast (in der Regel die Standardeinstellung) sondern explizit auf 1gbit.
2. Hast du mal vershciedene Varianten beim Kopieren versucht? Also ansprechen des Servers über die ip Adresse oder den Namen? Als verbundenes Laufwerk oder direkt?
Bitte warten ..
Mitglied: aqui
18.04.2011 um 10:14 Uhr
XP kann mit GiGE so auch nicht zurechtkommen da der TCP Stack darauf nicht richtig angepasst ist. Insbesondere die TCP Windowsize die du unbedingt über die Registry anpassen musst:
http://www.heise.de/netze/TCP-IP-Tuning--/artikel/97619
bzw.
http://www.psc.edu/networking/projects/tcptune/
Zudem solltest du das Flow Control auf der HP ProCurve Gurke zwingend ausschalten.
Soviel zu den Netzwerk Grundlagen. Du solltest von dem sehr inneffizientem Kopieren über SMB/CIFS nicht allzuviel erwarten. Es ist eins der schlechtesten Protokolle für sowas, da nur sehr kleine Pakete verwendet werden. Damit ist die Durchschnittsleistung beim Kopieren durch den erheblichen Overhead immer sehr mager. FTP, iSCSI und NFS sind da aus Protokoll Sicht erheblich besser.
Bitte warten ..
Mitglied: chr2002
21.04.2011 um 11:27 Uhr
Danke für Eure vielen Tips,

ich habe alles versucht, hab den TCP Stack angepasst, hab in den Systemeinstellungen auf Hintergrunddienste umgestellt, das Ergebins war zwar etwas besser, aber nicht zufriedenstellend. Hab jetzt wieder Win Server 2008 drauf, und der Speed ist wieder da wo er hin soll Werde der Server jetzt ne Zeit so laufen lassen.Werde dann mal Windows Home Server testen.Wenns da auch lahmt, werd ich mich mit Linux befassen. Wollte zwar ne Windows Variante, aber Win Server 2008 ist einfach zu teuer für mich.
Bitte warten ..
Mitglied: cardisch
21.04.2011 um 11:49 Uhr
Dann setz´ den WHS nur mit potenter Hardware ein, ich habe eine Intel-Atom-NAS-Box (acer H340) und die IST langsam...
Bei XP hatte ich lesend schreibend ca 35-40 MB/Sek, bei Win7 lesend ca 20, schreibend ca 90 (jawohl, bei mir schreibt das Biest schneller als es liest ;-( )
Aber ob ein Core i7/WHS System wirklich schnell ist, weiss ich leider auch nicht.
Ich habe mich aufgrund des Preises mit der Leitung arrangiert, aber wenn ich mehr Geld zum ausgeben bereit gewesen wäre, hätte ich mir ne echte NAS-Box von Experten geholt (QNAP, Synologie, etc)..

Gruß

Carsten
Bitte warten ..
Mitglied: aqui
22.04.2011, aktualisiert 18.10.2012
Für die Unix Variante bietet sich dann FreeNAS an. Aus dem ISO Image eine CD brennen, installieren, fertig... Administration für Winblows Knechte einfach über das Web Interface.
Das hat alle File Sharing Protokolle fest an Board inklusive MS SMB/CIFS und hat mit der Performance kein Problem:
http://freenas.org/
bzw.
http://www.administrator.de/wissen/iscsi-server-%28target%29-mit-freena ...
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Router & Routing
Welcher Annex A Router mit VPN und Gigabit-LAN? (7)

Frage von kolloni zum Thema Router & Routing ...

Netzwerkgrundlagen
gelöst Kopiervorgang im Gigabit Heimnetzwerk mit 2 NICs langsam (20)

Frage von John.D zum Thema Netzwerkgrundlagen ...

Windows 7
Win7-Clients nach Microsoft-Updates langsam (4)

Frage von marc-1303 zum Thema Windows 7 ...

Windows Update
gelöst WSUS-Downloads im LAN extrem langsam seit Win-10-Anniversary-Update 1607 (1)

Frage von departure69 zum Thema Windows Update ...

Heiß diskutierte Inhalte
Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...

Exchange Server
DNS Einstellung - zwei feste IPs für Mailserver (15)

Frage von ivan0s zum Thema Exchange Server ...