Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Gnome oder KDE unter OpenBSD 5.6 installieren

Frage Sonstige Systeme

Mitglied: ms1970

ms1970 (Level 1) - Jetzt verbinden

12.11.2014, aktualisiert 09.12.2014, 3577 Aufrufe, 9 Kommentare

Hallo,

ich wollte mal in VirtualBox mit OpenBSD_5.6_i386 "rumspielen". Hab das System installiert und Windows X startet. Ping auf google usw. geht, also steht die Netzwerkverbindung.

Jetzt wollte ich mal Gnome installieren und hatte diese Anleitung gefunden:

export PKG_PATH=ftp://ftp.eu.openbsd.org/pub/OpenBSD/5.6/packages/i386/

pkg_add -v gnome
pkg_add -v gnome-extras

In /etc/rc.conf make sure You have this:
pkg_scripts=dbus_daemon

Edit /root/.xinitrc
And add the line:
exec gnome-session
reboot

startx


Doch wenn ich pkg_add -v gnome oder pkg_add gnome eingebe, passiert nichts. Er hängt dann.
Ich kenne mich mit Debian etwas aus, auch bin auch kein ganz blutiger Linux Anfänger, weiß auch, das BSD nicht Linux ist.

Schätze, ich mache irgendwas einfaches falsch. Kann mir jemand einen Tipp geben?

Der Pfad oben stimmt. Es gibt zwar keine Datei die gnome heisst, aber das ist doch hoffentlich egal, oder?

Viele Grüße
Maik

Mitglied: Gersen
12.11.2014 um 14:31 Uhr
Hallo,

hast Du mal versucht, die konkreten Pakete anzusprechen?
pkg_add ftp://ftp.eu.openbsd.org/pub/OpenBSD/5.6/packages/i386/gnome-session-3.12.1.tgz
und evtl.
pkg_add ftp://ftp.eu.openbsd.org/pub/OpenBSD/5.6/packages/i386/gdm-3.12.2.tgz
Gruß,
Gersen
Bitte warten ..
Mitglied: ms1970
28.11.2014 um 09:52 Uhr
Hallo Gersen,

leider passiert in der virtuallen Maschine nichts, (aktuelles Virtualbox).
Es ist wie wenn ich
pkg_add -v gnome

eingebe.
Kann es abbrechen, (hab es schon 5 Stunden laufen lassen, ohne das sich was getan hat).
Der viruelle Server hat Verbindung ins Internet. Hab ich kann irgendwie nichts nachinstallieren.
Wollte mal den Midnight Commander installieren, hat biser bei jedem Linux / BSD funktioniert, aber hier nicht.
Hatte OpenBSD von einem Image installiert und das habe ich bei der virtuellen Maschine ausgehangen, damit er beim booten icht immer von "CD" bootet.

Hilft das vielleicht bei der Fehlersuche?
Viele Grüße
Maik
Bitte warten ..
Mitglied: Gersen
28.11.2014 um 10:35 Uhr
Hallo Maik,

probier bitte mal, ob
a) pkg_check irgendeinen Fehler in der Paket-Datenbank findet (und bereinigt),
b) (falls es installiert ist) man mit "wget" einer der o.g. Pakete herunterladen kann.

Gruß,
Gersen
Bitte warten ..
Mitglied: ms1970
03.12.2014 um 15:31 Uhr
Hallo Gersen,

vielen Dank, der Befehl pkg_check funktioniert schon mal.:

Locating unknown directories: ok

wget ist leider nicht installiert.

gebe ich
pkg_add ftp://ftp.eu.openbsd.org/pub/OpenBSD/5.6/packages/i386/gnome-desktop-3 ...

ein passiert wie üblich gar nichts und er hängt, bis man abbricht, was dann immer genau diesen Fehler :

at /usr/libdata/per15/OpenBSD/AddDelete.pm line 40

auswirft.

Kenne mich einfach zu wenig mit openBSD aus. Vielliecht solte ich doch freeBSD nehmen.
Andereseits, wäre es schon reizvoll mal zu wissen, woran es jetzt scheitert. Es ist ja nicht nur GNOME, sondern auch MC, Apache2, egal was.

Viele Grüße
Maik
Bitte warten ..
Mitglied: Gersen
LÖSUNG 03.12.2014, aktualisiert 09.12.2014
Hi Maik,

lese grade hier über ein Problem, das sich ähnlich äußert. Hier wird geraten, /etc/pkg.conf auf die Variable "installpath" zu untersuchen - und ggf. die Datei zu löschen.

Vielleicht hilft es was...

Gruß,
Gersen
Bitte warten ..
Mitglied: ms1970
09.12.2014 um 13:45 Uhr
Hallo Gersen,
leider finde ich nirgendwo die pkg.conf Datei. Nicht in /etc/ und sonstwo auch nicht.

installpath=ftp://ftp.openbsd.org/pub/OpenBSD/5.6/packages/i386/

"nimmt" er ohne Fehler, aber das ist egal, es fehlt ja noch was machine / .-a ?? aber -a ist nicht erlaubt, oder war es vielleicht mal, aber jetzt nicht mehr.
Denke, ich gebe auf.
Es gibt zu viele verschiedene Hilfen, die alle irgendwie was ähnliches beschreiben, aber keine funktioniert.
Naja.
Viele Grüße
Maik
Bitte warten ..
Mitglied: ms1970
09.12.2014 um 15:02 Uhr
Hallo Gersen,

ich habe die virtuelle Maschine einfach nochmal installiert. Habe alles auf default gelassen. Einfach 100 mal enter und nur das Nötigste eingegeben wie das Password. Nach dem Neustart habe ich die "CD", also das image entfernt.
OpenBSD startete nicht die X-Windows? Oberfläche sondern in der Bash.
Hab pkg_add mc eingegeben... funktioniert.
Hab plg_add gnome eingegeben. .geht.
Er installiert jetzt. Die Fehlerursache weiß ich jetzt nicht, aber immerhin hab ich dann gleich eine VM OpenBSD mit Gnome.
Weiß nicht, was ich beim ersten Anlauf falsch gemacht habe. Muss irgendwas zerschossen haben.
Melde mich noch ob Gnome dann wirklich läuft.
Weiß noch nicht wie ich gnome dann starte. /etc/init.d/gdm start woh nicht?!
Viele Grüße
Maik
Bitte warten ..
Mitglied: ms1970
09.12.2014 um 15:24 Uhr
Während der Installation gab es viele viele Fehlermeldungen, die ich mir nicht alle merken konnte.

Als er fertig war hab ich :

gdm start
eingegeben. Danach kam:

gdm [21477]: Couldn´t connect to system bus: Could not connect: No such file or directory

Vielleicht sollte ich es einfach lassen. Ein Server OS braucht ja in der Regel keine grafische Oberfläsche. War nur so ein Schnellschuß. Zum Glück brauch ich das nicht .

Während der stundenlangen Sucherrei fand ich u.a. auch diesen Hinweis für OpenBSD 5.6. Bei 5.5 ging es noch?! Egal.

FTP is no longer an install option
The installer will now use HTTP as its file transfer protocol. All public mirrors will support this, of course, but if you have a local mirror, make sure it can serve files via HTTP.

Viele Grüße
Maik
Bitte warten ..
Mitglied: Gersen
13.12.2014, aktualisiert um 01:20 Uhr
Zitat von ms1970:
gdm [21477]: Couldn´t connect to system bus: Could not connect: No such file or directory

Es werden für GNOME (GDM) noch ein paar andere Dienste / Einstellungen in der /etc/rc.conf.local und ein Reboot benötigt. Beschrieben hier unter dem Satz "Gnome is really trivial to install on OpenBSD!"...

FTP is no longer an install option
The installer will now use HTTP as its file transfer protocol. All public mirrors will support this, of course, but if you have a
local mirror, make sure it can serve files via HTTP.

Aha, danke für den Tipp. Muss zugeben, dass ich das Ganze auch nicht mit 'nem FTP-Mirror ausprobiert hatte. Wenns HTTP gibt...

Gruß,
Gersen
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Exchange Server
gelöst Microsoft Excange Server 2007 auf Windows Server 2003 Installieren? (9)

Frage von Herbrich19 zum Thema Exchange Server ...

Apache Server
gelöst Raspberry Pi 3 Owncloud installieren (4)

Frage von bestelitt zum Thema Apache Server ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...