Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Google Chrome GPO Benutzerprofilproblem

Frage Netzwerke

Mitglied: Krueschi

Krueschi (Level 1) - Jetzt verbinden

10.03.2011 um 09:40 Uhr, 13961 Aufrufe, 9 Kommentare

Google Chrome per Gruppenrichtlinie verteilen und verwalten, Servergespeicherte Benutzerprofile, Windows Server 2003 Windows 7 Clients.

Hallo,

wie mein Titel hoffentlich schon ausdrückt, versuche ich Google Chrome ins Netzwerk zu integrieren.

Den MSI Installer habe ich bereits heruntergeladen und eingebunden. Die ADM ist auch als Vorlage hinzugefügt und Einstellungen wurden vorgenommen.
Das klappt auch alles soweit so gut.

Jetzt kommt mein Problem:

Das Benutzerprofil wird lokal gespeichert auf:

C:\Users\%USERNAME%\AppData\Local\Google\Chrome\User Data

Das ist von Chrome vorgegeben.

Da ich aber nun meine AppData per Ordnerumleitung auf den Server verschieben lasse, und anschließend die lokalen Profile per GPO löschen lasse, habe ich beim erneuten anmelden einen frisch installierten Chrome Browser.
Die Einstellungen sind vorhanden aber nur die, die auch von der Gruppenrichtlinie kommen.

Alle anderen sind verworfen. Allem Anschein nach wird

Nun die Frage: hab ich was falsch gemacht das der Local Ordner nicht mit verschoben wird oder muss irgendwas an der Gruppenrichtlinie geändert werden?
Kann man vielleicht was in der Chrome ADM einstellen? (Hab hierzu nichts gefunden.

Kennt jemand das Problem?

Vielen Dank schon mal vorab für eure Beiträge.
Mitglied: Krueschi
11.03.2011 um 09:03 Uhr
Scheint nicht an Google Chrome zu liegen sondern an der Ordnerumleitung. Hab das Problem mal reproduziert und bemerkt das der Fehler woanders auch auftaucht.
Deswegen schließe ich das Thema hier und mache ein neues zum anderen Thema auf.
Bitte warten ..
Mitglied: Krueschi
16.03.2011 um 14:23 Uhr
Nochmal als Anhang für die, die es Interessiert.

Es hatte mit dem Benutzerprofil von Google Chrome zu tun.

dies wird unter C:\User\Username\AppData\local\Google\Chrome\User Data gespeichert.

Bei der Ordnerumleitung, wird Local aber nicht mit rüber kopiert, sondern nur Roaming.
Problem ist Google bekannt: http://code.google.com/p/chromium/issues/detail?id=49601
Wenn ich es aber richtig verstanden hab, wird die Funktionen der Pfadänderung per GPO erst mit der Version Chrome 11 kommen.

Gruß
Bitte warten ..
Mitglied: justphil
16.09.2011 um 15:47 Uhr
Zitat von Krueschi:
Bei der Ordnerumleitung, wird Local aber nicht mit rüber kopiert, sondern nur Roaming.
Problem ist Google bekannt: http://code.google.com/p/chromium/issues/detail?id=49601
Wenn ich es aber richtig verstanden hab, wird die Funktionen der Pfadänderung per GPO erst mit der Version Chrome 11 kommen.

Gruß

Inzwischen existiert die GPO, leider funktionieren im Pfad zum Verzeichnis bei mir allerdings keine Platzhalter wie "%username%" oder "%appdata%", womit der Nutzen komplett passé ist. Kann dieses unschöne Verhalten jemand bestätigen?


EDIT: Manchmal ist man blind. Die ADM-Vorlagen verwenden eine eigene Syntax für Umgebungsvariablen, die HIER in Kommentar 22 stehen.
Bitte warten ..
Mitglied: Krueschi
16.09.2011 um 15:58 Uhr
Jap, kann ich.. da hätteste aber nur genau lesen müssen.. das wurde dokumentiert .

Es werden eigene Variablen verwendet:

ich benutze ${roaming_app_data}

im großen und ganzen sieht es bei mir in der GPO so aus:

${roaming_app_data}\Google\Chrome\

landet dann bei mir:

U:\Anwendungsdaten\Google\Chrome

Funktioniert auch ganz gut.. nur das ich bei mir das Problem habe das es Probleme mit dem Sandboxmode gib..
Kann Google Chrome mit den geänderten Benutzerprofilen nur mit dem --no-sandbox parametet starten.. dann ist auch fast alles ok außer, dass man keine Addons installieren kann.. dann kommt nämlich folgende Meldung :

"Erweiterung kann nicht entpackt werden. Damit die Erweiterung sicher entpackt werden kann, muss ein Pfad zu Ihrem Profilverzeichnis zur Verfügung stehen, der mit einem Laufwerkbuchstaben beginnt und keine Verknüpfung, keinen Bereitstellungspunkt und keine symbolische Verknüpfung enthält. Für Ihr Profil besteht kein solcher Pfad."

http://www.google.com/support/forum/p/chrome/thread?tid=2ba6cc9c7ed52da ...

Allerdings siehste anhand der Antrworten schon, dass das alles sehr perplex ist ^^

Ich mache regelmäßig updates und hoffe das es bald eine Lösung dafür gibt
Bitte warten ..
Mitglied: justphil
16.09.2011 um 16:03 Uhr
Danke Dir, bin vor 2 Minuten auch plötzlich drauf gekommen (Post editiert). Da war ich mit dem Posten etwas vorschnell. ^^
Bitte warten ..
Mitglied: Krueschi
16.09.2011 um 16:39 Uhr
Hehe

Aber hey.. sag mir mal bitte Bescheid, ob du auch das Sandboxproblem hast und ob du auch keine Addons installieren kannst

Gruß
Bitte warten ..
Mitglied: justphil
17.09.2011 um 10:04 Uhr
Hallo,


ja, das mit dem Sandbox-Argument kann ich bestätigen. Die Installation von Addons werde ich nächste Woche mal ausprobieren und kurz berichten.

Gruß zurück
Bitte warten ..
Mitglied: justphil
20.09.2011 um 13:26 Uhr
So,

ich habe eben mal auf zwei Test-Clients mit zwei Domänenbenutzern die Installation von Addons aus dem Chrome Web Store ausprobiert, was ohne Probleme funktioniert hat. Die Benutzer haben sich dann zur Sicherheit nochmal jeweils auf dem anderen Rechner eingeloggt, alles korrekt.

In meinem Fall ist momentan aber tatsächlich ein Laufwerksbuchstabe im Pfad vorhanden, er lautet: "C:\Dokumente und Einstellungen\${user_name}\Anwendungsdaten\Google\Chrome". Ich hatte zunächst auch den Pfad dort eingetragen, der direkt auf die entsprechende Serverfreigabe zeigt ("\\dc01\Benutzerdaten$\${user_name}\Anwendungsdaten\Google\Chrome"), da das Benutzerprofil aber nach einem Logout eh dort hingeschrieben wird, funktioniert's auch so problemlos.
Bitte warten ..
Mitglied: Krueschi
26.09.2011 um 12:43 Uhr
Hmm .. das ist jetzt sehr seltsam. und die Ordnerweiterleitung haste ja auch definitiv drinne..

Weil bei mir gehts nicht. .es kommt immer die o.g. Meldung.. hab schon einmal versucht es so wie du zu machen und die über C und dann den Roaming Apps weiter zu leiten, allerdings ignoriert er den Ordner aus welchen Gründen auch immer..

Es scheint bei mir als wenn %APPDATA% komplett neu geschrieben ist, auf U:\Anwendungsdaten\
Denn geb ich %APPDATA% ein komme ich auch sofort zu U:\Anwendungsdaten\

Allerdeings gibt es den Ordner C:\Users\%USERNAME%\AppData\Roming auch noch.. in dem sind auch Ordner drinne, von Microsoft etc.. und auch der neu weitergeleitete Google Chrome Ordner, allerdings ist das ja sinnfrei ;)
Bitte warten ..
Ähnliche Inhalte
Windows Server
Google Chrome via GPO Verteilen
gelöst Frage von mario89Windows Server11 Kommentare

Hallo Leute, aktuell habe ich ein größeres Problem den Browser "Google Chrome" bei mir zu verteilen. Problem ist, dass ...

Webbrowser
Google Chrome lädt Google Dienste nicht
Frage von r3volutionxxxWebbrowser3 Kommentare

Hallo Ich habe ein kleines Problem Zuhause benutze ich Google Chrome, wobei die Google Dienste nicht richtig funktionieren. OS: ...

Internet
Google Chrome - Access Denied
Frage von Grave111Internet4 Kommentare

Hallo zusammen, ich hätte mal eine Frage bezüglich dem Chrome Browser. Ich möchte auf ein WebIf eines Gerätes bei ...

Webbrowser
Google Chrome - Texte übereinander
gelöst Frage von AveiroCR7Webbrowser7 Kommentare

Guten Abend alle zusammen, bei mir werden die Texte bei Google Chrome übereinander angezeigt, sowas macht echt keine Freude ...

Neue Wissensbeiträge
Windows 10

Autsch: Microsoft bündelt Windows 10 mit unsicherer Passwort-Manager-App

Tipp von kgborn vor 8 StundenWindows 101 Kommentar

Unter Microsofts Windows 10 haben Endbenutzer keine Kontrolle mehr, was Microsoft an Apps auf dem Betriebssystem installiert (die Windows ...

Sicherheits-Tools

Achtung: Sicherheitslücke im FortiClient VPN-Client

Tipp von kgborn vor 9 StundenSicherheits-Tools

Ich weiß nicht, wie häufig die NextGeneration Endpoint Protection-Lösung von Fortinet in deutschen Unternehmen eingesetzt wird. An dieser Stelle ...

Internet

USA: Die FCC schaff die Netzneutralität ab

Information von Frank vor 23 StundenInternet3 Kommentare

Jetzt beschädigt US-Präsident Donald Trump auch noch das Internet. Der neu eingesetzte FCC-Chef Ajit Pai ist bekannter Gegner einer ...

DSL, VDSL

ALL-BM200VDSL2V - Neues VDSL-Modem mit Vectoring von Allnet

Information von Lochkartenstanzer vor 1 TagDSL, VDSL2 Kommentare

Moin, Falls jemand eine Alternative zu dem draytek sucht: Gruß lks

Heiß diskutierte Inhalte
TK-Netze & Geräte
VPN-fähige IP-Telefone
Frage von the-buccaneerTK-Netze & Geräte16 Kommentare

Hi! Weiss noch jemand ein VPN-fähiges IP-Telefon mit dem man z.B. einen Heimarbeitsplatz gesichert anbinden könnte? Habe nur einen ...

Hardware
Links klick bei Maus funktioniert nicht
gelöst Frage von Pablu23Hardware16 Kommentare

Hallo erstmal. Ich habe ein Problem mit meiner relativ alten maus jedoch denke ich nicht das es an der ...

Windows Server
Anmeldung direkt am DC nicht möglich
Frage von ThomasGrWindows Server16 Kommentare

Hallo, ich habe bei unserem Server 2016 Standard ein Problem. Keine Ahnung wie das auf einmal passiert ist. Ich ...

Windows Server
KMS Facts for Client configuration
Frage von winlinWindows Server12 Kommentare

Hey Leute, wir haben in unserem Netz nun einen neuen KMS Server. Haben Bestands-VMs die noch nicht aktiviert sind. ...