Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

GOTO in FOR-Schleife funktioniert nicht

Frage Entwicklung Batch & Shell

Mitglied: Larz

Larz (Level 2) - Jetzt verbinden

30.06.2010, aktualisiert 14:26 Uhr, 6723 Aufrufe, 2 Kommentare

Hallo zusammen,

ich habe ein Script, dass über den Zugriff auf die config.sys die Erreichbarkeit mehrerer Server prüft.
Dazu verwende ich eine FOR-Schleife, innerhalb der auf Sprungmarken verwiesen wird:

01.
for /f %%i in (servers_connected.ini) do ( 
02.
IF EXIST \\%%i\c$\CONFIG.SYS GOTO :ERREICHBAR 
03.
@ECHO Server: %%i 			nicht erreichbar>>"%LogfilePath%\servercheck.log"  
04.
goto :ENDE 
05.
:ERREICHBAR 
06.
@ECHO Server: %%i			OK>>"%LogfilePath%\servercheck.log" 
07.
:ENDE 
08.
)

Ist der Server erreichbar (also die Datei vorhanden), bekomme ich im Log den Eintrag

Server: SERVERNAME OK

Ist die Datei nicht vorhanden, bekomme ich jedoch

Server: SERVERNAME nicht erreichbar
Server: SERVERNAME OK

Ich verstehe nicht, warum der Sprung zum Ende (Zeile 4) nicht funktioniert... weiß jemand Rat?

Gruß
Larz
Mitglied: LotPings
30.06.2010 um 14:18 Uhr
Hallo Larz,
deine Überschrift sagt es ja schon,
macht aber auch nichts, denn deine Art das goto zu benutzen erzeugt allseits ungeliebten Spaghetti-Code.
Es gibt andere, besser lesbare Konstrukte mit Klammern.

01.
for /f %%i in (servers_connected.ini) do IF EXIST \\%%i\c$\CONFIG.SYS ( 
02.
  @ECHO Server: %%i			OK>>"%LogfilePath%\servercheck.log" 
03.
) Else ( 
04.
  @ECHO Server: %%i 			nicht erreichbar>>"%LogfilePath%\servercheck.log"  
05.
)
Gruß
LotPings
Bitte warten ..
Mitglied: Larz
30.06.2010 um 14:47 Uhr
Wunderbar, ich war schon etwas am verzweifeln...

Danke!

Gruß
Larz
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Batch & Shell
gelöst CMD: icacls in for-Schleife (2)

Frage von Lowrider614 zum Thema Batch & Shell ...

Batch & Shell
gelöst Batch Problem bei einer For Schleife (2)

Frage von Juergen42 zum Thema Batch & Shell ...

Batch & Shell
gelöst For Schleife kaputt? (5)

Frage von Peter32 zum Thema Batch & Shell ...

Batch & Shell
Batch: Variable Expansion in einer FOR-Schleife (9)

Frage von .Sessl zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (22)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...