Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

GPO Software wird nicht vollständig verteilt bei Windows 7

Frage Microsoft Windows Server

Mitglied: florian.rhomberg

florian.rhomberg (Level 1) - Jetzt verbinden

20.08.2010 um 10:14 Uhr, 11071 Aufrufe, 14 Kommentare

Ich habe ein merwürdiges Problem mit der Verteilung der Software per GPO unter Windows 7

Hallo!
Ich stelle derzeit etwa 100 PC von Windows XP auf Windows 7 um. Ich nutze die Softwareverteilung über GPO um 3/4 der Software auf die Computer zu verteilen. Es gibt zwei Gruppenrichtlinien dafür. Mein Problem ist, dass nicht alle MSI Pakete installiert werden. Allerdings gibt es in der Eriegnisanzeige keine Meldung, dass die Installation fehlschlägt. Vielmehr schaut es auch, dass der PC nicht die komplette Softwareliste von der GPO bekommt. Habe daher mit gpresult /H Report.html mir auf dem PC einen GPO Report erzeugen lassen. Und siehe da auch in dieser Liste taucht nur ein Teil der Software auf. Der einzige gemeinsame Nenner ist, dass immer die selben Softwarepakete nicht installiert werden. Nur leider sind das mehr als die Hälfte der benötigten Programme. Allerdings beschränken sich die fehlende Programme nicht auf eine Gruppenrichlinie sondern es werden Programme aus der Ersten und auch aus der Zweiten installiert. Ich habe daher probiert ob sich die Programme unter windows 7 manuell installieren lassen um ein Kompatibilitätsproblem auszuschließen. Auch hier gibt es keine Probleme.
Beide AD Controller sind sychron, habe das schon überprüft, die Windows XP Clients bekommen auch egal an welchem sie sich anmelden die richtige Softwareliste.
Woran kann das liegen? Hatte jemand ein ähnliches Problem?

Danke für eure Hilfe!
Florian
Mitglied: Nailara
22.08.2010 um 23:39 Uhr
Hi,

schau mal spasshalber nach, ob auf den Paketen irgendwo Filter gesetzt sind die sagen, dass die Pakete nur auf XP installiert werden dürfen. Das würde das merkwürdige Verhalten erklären....

CU
Bitte warten ..
Mitglied: DerWoWusste
22.08.2010 um 23:59 Uhr
Hi.
Die Ursache ist mit evtl., dass Du den Haken bei "Sprache ignorieren" nicht gesetzt hast in den Eigenschaften der fehlgeschlagenen Pakete.
group policy modeling am Server würde Dir sagen, warum.
Bitte warten ..
Mitglied: florian.rhomberg
27.08.2010 um 17:25 Uhr
Hallo!
Danke für die Antworten. Der Haken bei Sprache ignorieren war bei keiner Software gesetzt. Habe das jetzt korrigiert, kann es leider erst am Montag testen ob das der Fehler war.

@Nailara: Wo kann man bei Gruppenrichtlinien filter setzen, das höre ich zum ersten mal, ich kenn nur die Filter mi denen ich die Auswahl der Richtlinien einschränken kann. Wo gibt es einen Filter bei dem ich sagen kann ob eine Software nur auf XP installiert werden soll, oder nicht. Das wäre ja super wenn sowas möglich ist. Vielleicht kannst du mir das noch sagen, dann kann ich das auch testen.

Florian

PS: Laut Modellierung sollte eigentlich alle Software installiert werden. Allerdings war das meiner Meinung nach nie sehr zuverlässig.
Bitte warten ..
Mitglied: DerWoWusste
27.08.2010 um 18:58 Uhr
Die Filter von denne die Rede ist nennen sich wmi-Filter.
Bitte warten ..
Mitglied: florian.rhomberg
30.08.2010 um 17:38 Uhr
Hallo!
Das kleine Häckchen bei der Sprache ignorieren war tatsächlich die Ursache warum die Pakete nicht installiert worden sind.
@DerWoWusste: Vielen Dank für diesen goldigen Tipp!

Gruß,
Florian
Bitte warten ..
Mitglied: Gamester
17.02.2011 um 16:04 Uhr
Hi,

ich habe ein sehr ähnliches Problem und komme leider nicht weiter.

Ich versuche ein MSI Paket über ein GPO zu verteilen. Verteile ich das Paket per Benutzerkonfiguration funktioniert alles habe es in der Testumgebung mit Zuweisen und Veröffentlichen getestet. Funktioniert auf XP, Vista und Win7.

Ich möchte aber, dass die Verteilung über die Computerkonfiguration läuft. Hier funktionier XP und Vista einwandfrei. Nur bei Windows 7 will es einfach nicht klappen.

Ich habe in der GPO den Haken bei den Sprachen ignorieren gesetzt, und auch keine Filter angeschalten.

Wenn ich auf dem Win7 Client GPUPDATE ausführe kommt folgende Fehlermeldung:

The processing of Group Policy failed because of lack of network connectivity to
a domain controller. This may be a transient condition. A success message would
be generated once the machine gets connected to the domain controller and Group Policy has successfully processed.
If you do not see a success message for several hours, then contact your administrator.

To diagonse the failure, review the event log or run GPRESULT /H GPReport.html from
the command line to access information about Group Policy results.

Der Fehler aus dem GPReport lautet wie folgt:

Group Policy Infrastructure failed due to the error listed below.
The network is not present or not started.
Note: Due to the GP Core failure, none of the other Group Policy components processed their policy. Consequently, status information for the other components is not available.
Additional information may have been logged. Review the Policy Events tab in the console or the application event log for events between 17.02.2011 15:32:57 and 17.02.2011 15:33:10.

Im eventviewer steh das selbe drin wie oben.

Langsam weiß ich nicht mehr was ich machen soll.

Hat jemand vielleicht eine Idee?
Bitte warten ..
Mitglied: DerWoWusste
17.02.2011 um 16:51 Uhr
Teste zunächst, ob andere GPOs ziehen.
Bitte warten ..
Mitglied: florian.rhomberg
17.02.2011 um 18:34 Uhr
Hallo!
So wie ich die Fehlermeldung intepretiere kann dein Client die GPO nicht laden weil er keine Verbindung hat. Ich kann mit vorstellen, dass die Ursache vielleicht darin liegt, dass beim Netzwerk der falsche Ort angegeben wurde, der Ort muss Domänennetzwerk sein sonst passen die Freigaben nicht. Überprüfe das unter "Netzwerk- und Freigabecenter" unter Windows 7.
Bitte warten ..
Mitglied: meronax
14.04.2011 um 14:49 Uhr
Vielen dank DerWoWusste, auch mir hat der Tipp geholfen!
Bitte warten ..
Mitglied: Mirage93
09.11.2011 um 15:11 Uhr
Hi Leute,

ich hab das Problem das ich keine Software über die gpo verteilt bekomm gestern ging alles einwandfrei und heute wollt ichs noch mal testen und es geht nicht mehr.
Weis einer woran das liegen kann??

Lg
Bitte warten ..
Mitglied: florian.rhomberg
09.11.2011 um 16:38 Uhr
Hallo!

1. Willst du das am selben Computer machen?
Das geht nicht auch wenn du die Software händisch deinstallierst glaubt das AD, dass die Software noch immer drauf ist. Du müsstest also den Computer aus der Domain nehmen und wieder neu hinzufügen, dann sollte es wieder gehen.

2. Befindet sich der Computer in der richtigen OU?
3. Wenn du die lokale Ereignisanzeige löscht den Computer neu startest und dann die Anzeige überprüfst steht dort etwas über die MSI Pakete?
4. Hast du schon mit gpupdate /force den Computer gezwungen die Richtlinien nochmals manuell zu laden?

Liebe Grüße,
Florian
Bitte warten ..
Mitglied: Mirage93
10.11.2011 um 09:06 Uhr
HI,

Ja ich hab das am selben Pc probiert, kann man dme AD irgendwie sagen das er überprüfen soll ob die Software da noch drauf ist und wenn nicht das er es installieren soll??

Ja der Rechner ist in der richtigen OU
Wegen der Ereignisanzeige muss ich mal schaun das habe ich nich nicht überprüft.
Das mit dem gpupdate/force habe ich schon mehrmals versucht.
Er sagt mir dann immer das ich mich Neu Anmelden soll und er die Richtlinie dann ausführen wird, aber es passiert trotzdem nichts.

Lg

Patrick
Bitte warten ..
Mitglied: florian.rhomberg
10.11.2011 um 09:56 Uhr
Nimm den Computer mal aus der Domain raus und dann wieder rein und schau ob es dann geht.

Liebe Grüße,
Florian
Bitte warten ..
Mitglied: Mirage93
10.11.2011 um 11:31 Uhr
ok mach ich

und danke schon mal


LG

patrick
Bitte warten ..
Ähnliche Inhalte
Windows 10
Anmeldescript wird nicht per GPO verteilt
gelöst Frage von DarkScabsWindows 105 Kommentare

Hallo Zusammen, ich möchte ein Batch-File beim Anmelden ausführen lassen. Ich habe auch schon eine GPO erstellt (diese ist ...

Windows Server
Drucker wird nicht mehr über GPO verteilt
Frage von matzespensWindows Server1 Kommentar

Alle Drucker werden bei uns am Server installiert und anschließend über den Druckserver und die Gruppenrichtlinienobjekte an die Clients ...

Windows Userverwaltung
Windows 7 GPO für Anpassen
Frage von 14634Windows Userverwaltung2 Kommentare

HAllo zusammen, kurz zur Struktur: - AD 2008 R2 - Windows 7 32bit wenn ich auf den Desktop bin, ...

Windows 7
Windows 7 - Netzwerkkartenproblem Software
Frage von grillinator95Windows 714 Kommentare

Hallo liebe Community, ich kann die Netzwerkkarten nicht mehr sehen > Weiter's kann ich unter Adaptereinstellungen auf einer einzelnen ...

Neue Wissensbeiträge
MikroTik RouterOS

Mikrotik - Lets Encrypt Zertifikate mit MetaROUTER Instanz auf dem Router erzeugen

Anleitung von colinardo vor 4 StundenMikroTik RouterOS4 Kommentare

Einleitung Folgende Anleitung ist aus der Lage heraus entstanden das ein Kunde auf seinem Mikrotik sein Hotspot Captive Portal ...

Sicherheit

Sicherheitslücke in HP-Druckern - Firmware-Updates stehen bereit

Information von BassFishFox vor 4 StundenSicherheit

Ein weiterer Grund, dass Drucker keinerlei Verbindung nach "auswaerts" haben sollen. Unter Verwendung spezieller Malware können Angreifer aus der ...

Administrator.de Feedback

Entwicklertagebuch: Die Startseite wurde überarbeitet

Information von admtech vor 7 StundenAdministrator.de Feedback6 Kommentare

Hallo Administrator User, mit dem Release 5.7 haben wir unsere Startseite überarbeitet und die Beiträge und Fragen voneinander getrennt. ...

Vmware

VMware Desktopprodukte sind verwundbar

Information von Penny.Cilin vor 11 StundenVmware

Die VMware-Anwendungen zum Umgang mit virtuellen Maschinen Fusion, Horizon Client und Workstation sowie die Plattform NSX sind verwundbar. Davon ...

Heiß diskutierte Inhalte
Visual Studio
Vb.net-Tool zum Erzeugen einer Outlook-E-Mail
Frage von ahstaxVisual Studio24 Kommentare

Hallo, ich möchte gerne ein vb.net-Tool schreiben, das am Ende eine Outlook-E-Mail erzeugt. Grundsätzlich ist mir klar, wie das ...

Windows Netzwerk
Netzwerk Neustrukturierung
Frage von IT-DreamerWindows Netzwerk16 Kommentare

Hallo verehrte Community und Admins, bei uns im Haus steht eine Neustrukturierung an. Dafür benötige ich von euch ein ...

Windows Server
RDP macht Server schneller???
Frage von JaniDJWindows Server16 Kommentare

Hallo Community, wir betrieben seit geraumer Zeit diverse virtuelle Maschinen und Server mit Windows Server 2012. Leider haben wir ...

Windows 10
Windows 10 dunkler Bildschirm nach Umfallen
Frage von AkcentWindows 1015 Kommentare

Hallo, habe hier einen Windows 10 Rechner der von einem User umgefallen wurde (Beine übers Knie, an den PC ...