Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

GPO Starup-Skript wird ausgeführt - Befehl-Syntax OK - Zugriff verweigert? Office 2007

Frage Microsoft Windows Installation

Mitglied: semase

semase (Level 1) - Jetzt verbinden

19.10.2011 um 14:23 Uhr, 4897 Aufrufe, 1 Kommentar

Zur zentralen Software-Verteilung von Office 2007 werden bekannterweise keine MSI-Pakete mehr benutzt, deshalb soll dieses nun Script-Basierend ablaufen.

Das manuelle Ausführen des von mir erstellten Scripts (unter dem Benutzer Administrator) läuft einwandfrei,
beim Starten per GPO (Computereinstellungen .... Skript -- Start) will es jedoch einfach nicht.
Habe schon viel Debugged, aber ich komme nicht hinter den entsprechenden Fehler.

Umgebung:
Windows Server 2003 --> Mehrere Standorte
Clients Win XP / Win7


Eigentlich sollte es ja alles recht einfach sein.

Seit Office 2007 soll die installation (gemäß TECHNET) über ein Startup-Script ablaufen und fertig...
Selbiges gilt mit dem setup.exe-"Switch" /uninstall.


In unserem besonderen Fall wurde Office 2007 Enterprise leider per Hand (historisch bedingt) installiert,
und da nun auf Office 2010 der nächste Schritt erfolgen soll, dachte ich mir ich deinstalliere davor Office 2007.
--> Hintergrund ist, dass wir bislang immer nur 32-Bit Editionen installiert haben (trotz teilweise 64bit Win7) und mein neues Installationsscript für Office 2010
bei den 64 bit-Betriebssystemen auch entsprechend hier installiert. --> Wenn jedoch ein 32bit drauf ist, kann kein Upgrade durchgeführt werden usw. Lange rede kurzer Sinn... OFFICE 2007 soll zuvor runter.

Habe - um das ganze SILENT zu machen - die XML-Datei angepasst, die Software auf unser Software-Share gelegt (von hier installieren wir normalerweise per MSI) und eine BAT-Datei erstellt die das ganze Aufruft.

Die BAT sieht in etwa so aus:

echo %date% %time% %computername% Setup start with error code --script before runned--. >> \\10.49.1.100\Softwareverteilung\officeVLC\log.log
start /wait \\10.49.1.100\Softwareverteilung\officeVLC\setup.exe /config \\10.49.1.100\Softwareverteilung\officeVLC\Enterprise.WW\config_uninstall.xml /uninstall enterprise
echo %date% %time% %computername% Setup ended with error code --script after runned--. >> \\10.49.1.100\Softwareverteilung\officeVLC\log.log
pause


Wie Ihr seht habe ich mir sowohl schon kleine LOGs schreiben lassen, um zu sehen ob das ganze geht, als auch die PAUSE.
Die GPO ist natürlich so eingestellt das sie aufs Netzwerk wartet, Scripts asynchron ausgeführt werden, parallel ausgeführt werden, sichtbar ausgeführt werden usw.


Wenn ich das Script handisch (mit einem Benutzer --> Administrator) an einem Client ausführe funktioniert das ganze super.


Wenn die GPO beim Systemstart das ganze macht --> Script wird gestartet und ausgeführt, aber die Befehle die ihr oben seht werden mit "Zugriff verweigert" quittiert, deswegen auch das PAUSE um das zu sehen was der Fehler ist usw.
--> Na klar dacht ich mit liegt an den Zugriffsberechtigungen auf das Share, diese sind jedoch sowohl als Freigabe als auch NTFS für Domänencomputer und testhalber JEDER entsprechend gesetzt.


Ich kriege noch die Krise. Sitze mittlerweile seit 2 Tagen dran.
Woran liegt es? Was mache ich falsch? Was übersehe ich?
Habe davor noch nichts per Script installieren lassen, aber eigentlich kann das doch nicht so schwer sein ;)



Danke


P.S.: Wenn ich das Script bei der Benutzeranmeldung ausführen lasse, funktioniert alles bestens (aber normale User sind keine ADMINs wegen Softwaredeinstallation) und ich kann mich nicht an 600 Systme anmelden (alla Turnschuh-Admin)
Mitglied: semase
22.10.2011 um 08:43 Uhr
Ich denke ich hab die Lösung gefunden.

Ich hatte im Skript immer die IP-Adresse oder NETBIOS-Namen genommen. Dieser steht dem PC aber anscheinend zum Auflösung und Sachgerechten Aushandling/Übermittlung der System-Credentials beim anmelden noch nicht zur Verfügung.

Kaum geändert auf den FQDN und nen DHCP-Client zum Testen verwendet (sonst wird nämlich auch nicht aufs Netz gewartet --> es sollte wohl besser "Auf IP-Adresse warten" lauten, die bei meinem Test-PC halt leider fixiert war) und schon funktioniert es ;)

Vermutlich hängen die Credentials mit dem per DHCP standarisierten/übertragenen DNS-Suffix zusammen (sozusagen reliktmäßige Auflösung der Credentials aus LDAP-Zeit), da ich einen englischen Foren-Eintrag gelesen hatte, das jemand dies mit ner GPO (Computer-->Windows-->Netzwerk-->DNS-Suffix oder so ähnlich anhängen) gelöst hat.


Man lernt eben doch nie aus.


P.S.: Ich bin zwar kein Skript-Freak, aber die Install-Methode finde ich trotzdem super. Lasse mir jetzt zum Status-Test eines Clients nen eigenen Registry-Softwarebaum erstellen/auslesen und bin sofort an einem zentralen Punkt über die installierte Software informiert. (den Schalter baue ich nun auch in die MSI-Pakete mit ein oder in die jeweilige GPO als Mini-Skript nach erfolgreicher Installation).
Errors lass ich mir in LOGS schreiben die ich nach nem Rollout prüfe und das erleichtert mir das Monitoring enorm.

--> Deployment-Software war aus Kostengründen nicht gewünscht und die meisten brauchen dazu auch noch nen Agent (auch Freeware) der dann im Systemkontext im Hintergrund die ganze Zeit mitläuft.


Ein geiles Tool zum Debug war hier tatsächlich PSexec von SYSINTERNALS.
Hat mich über nen Telnet Emulation zumindest auf die richtige Spur gebracht --> denn wenn PC hochgefahren ist, geht ja IP und NETBIOS und alle Netzwerkdienste des Clients laufen auch schon sauber.


Hoffe ich konnte mit dem Erfahrungsbeitrag jemanden in Zukunft helfen.

@Moderatoren: wäre froh über eure Verifizierung.


Grüße
Bitte warten ..
Ähnliche Inhalte
Exchange Server
GPO - Logon-Skript wird nicht ausgeführt
Frage von Der-PhilExchange Server4 Kommentare

Hallo! Seit heute werden meine Logon-Skripte, die ich über GPOs festlege nicht mehr gestartet. AD-Domaincontroller laufen unter Windows 2012 ...

Windows Server
GPO Zugriff verweigert 0x80070005
gelöst Frage von xbast1xWindows Server29 Kommentare

Hallo zusammen, seit unsere Daten auf dem Netz inkl. Freigaben auf ein neues Storage übertragen wurden erhalten alle Clients ...

Windows Server
GPO zum Deinstallieren von Office Update wird nicht ausgeführt
Frage von lordofremixesWindows Server15 Kommentare

Hallo zusammen, nach langem Hin und Her habe ich durch gestern auch durch administrator.de folgenden Befehl als Batch Datei ...

Batch & Shell
CMD Befehl mit Anführungszeichen - Syntax Error
gelöst Frage von agowa338Batch & Shell7 Kommentare

Hallo, Ich kämpfe gerade mit der Syntax eines etwas komplexeren Befehls, der Befehl ist folgender: cmd.exe /C "schtasks /create ...

Neue Wissensbeiträge
Apple

IOS 11.2.1 stopft HomeKit-Remote-Lücke

Tipp von BassFishFox vor 10 StundenApple

Das Update für iPhone, iPad und Apple TV soll die Fernsteuerung von Smart-Home-Geräten wieder in vollem Umfang ermöglichen. Apple ...

Windows 10

Windows 10 v1709 EN murkst bei den Regionseinstellungen

Tipp von DerWoWusste vor 15 StundenWindows 10

Dieser kurze Tipp richtet sich an den kleinen Personenkreis, der Win10 v1709 EN-US frisch installiert und dabei die englische ...

Webbrowser

Kein Ton bei Firefox Quantum über RDP

Tipp von Moddry vor 15 StundenWebbrowser

Hallo Kollegen! Hatte das Problem, dass der neue Firefox bei mir auf der Kiste keinen Ton hat, wenn ich ...

Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 1 TagInternet4 Kommentare

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registrierung von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
Häufig Probleme beim Anmelden in WLAN
Frage von mabue88LAN, WAN, Wireless15 Kommentare

Hallo zusammen, in einem Netzwerk gibt es relativ häufig (1-2 mal pro Woche) Probleme mit der WLAN-Verbindung. Zunächst mal ...

Windows Server
SMBv1 deaktivieren führte zur Katastrophe, keine Domänenanmeldung mehr
Frage von Freak-On-SiliconWindows Server14 Kommentare

Servus; Habe Mist gebaut. Umgebung: Server 2012R2 Domäne 2x DC ~10 Memberserver (2012R2 und 2008R2) ~100 Windows 8 Clients ...

Windows XP
Windows XP Aktivieren geht nicht
Frage von tetikmiroWindows XP13 Kommentare

Hallo Ich habe einen Windows XP mit einen vCenter Converter umgezogen auf eine ESXI. Soweit funktioniert dies auch ohne ...

Grafikkarten & Monitore
2x 4K Monitore an einer GraKa betreiben
gelöst Frage von JollyJumper83Grafikkarten & Monitore10 Kommentare

Hallo liebe IT-Gemeinde, ich bin auf der Suche nach einer kostengünstigen GraKa für meinen Präsentations-PC. Wir möchten in unserem ...