Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

GPO - Windows 7 - Startskript läuft noch nach Loginvorgang

Frage Microsoft Windows 7

Mitglied: Machiavelli

Machiavelli (Level 1) - Jetzt verbinden

21.01.2013, aktualisiert 18:52 Uhr, 6141 Aufrufe, 4 Kommentare

Hallo Administratoren,

ich stehe vor einem nicht "schwerwiegendem" Problem in unserer Umgebung.

Vorab: DC Server 2k8R2, Clients 90% Win7, 10% WinXP

Wir haben ein Startskript, das eine CMD aufruft und Standardsoftware über einen Dritthersteller aktualisiert. Funktioniert auch einwandfrei.

Allerdings lässt Windows 7 eine Anmeldung zu, obwohl das Startskript noch nicht fertig ist. Dann läuft im Hintergrund noch das Startskript, während das Loginskript startet, was natürlich zu extremen Leistungseinbußen führt.

Unter Windows XP wird erst das Startskript vollständig ausgeführt. Erst wenn das beendet ist, wird der Loginvorgang ermöglicht. Sowas hätte ich auch gerne für Windows 7.

Wie kann ich Windows 7 sagen, dass der Loginvorgang erst nach beenden der Startskripts ausgeführt wird?

Der Schalter "Bei Anmeldung und Neustart auf das Netzwerk warten" ist aktiv. Unter Windows 7 bringt das aber rein gar nichts. Hier wird ja "nur" auf die Netzwerktreiber gewartet und nicht darauf, dass die Startskripts beendet sind. Das "Bitte warten..." steht ja auch da, wenn der Schalter aktiv ist, allerdings wird der Login kurz danach wieder ermöglicht obwohl das Startskript noch läuft.

Irgendwelche Ideen?

Freundliche Grüße
Mitglied: redder
21.01.2013, aktualisiert um 16:06 Uhr
Hallo Machiavelli,
schau mal in den Gruppenrichtlinien unter Computerkonfiguration/Administrative Vorlagen/System/Skripts/Anmeldeskripts gleichzeitig ausführen

-Wenn du das aktivierst sollten die Skripte erst durchlaufen bevor es weitergeht.

EDIT: Hab mich bei deiner Frage verlesen... Evtl. die Einstellung Computerkonfiguration/Administrative Vorlagen/System/Skripts/Startskripts asynchron ausführen deaktivieren?

LG redder
Bitte warten ..
Mitglied: Machiavelli
21.01.2013 um 16:13 Uhr
Anmeldeskripts gleichzeitig ausführen würde auch zum Erfolg führen denk ich, allerdings wird dann der Desktop für den User erst dargestellt, wenn das Logonscript fertig ist (was wirklich lang dauern kann und unnötig ist).

Die Funktion "Asynchron ausführen" hab ich grad DEaktiviert und werds gleich testen. Obwohl es ja in der Beschreibung heißt, dass es egal ist ob die Funktion "nicht konfiguriert" oder "deaktiviert" ist.

Meld mich gleich wieder dazu.
Bitte warten ..
Mitglied: Machiavelli
21.01.2013 um 18:52 Uhr
Update:

Das war eindeutig die Lösung, vielen Dank!

Darauf muss man mal kommen, dass "nicht konfiguriert" tatsächlich was anderes ist als "deaktiviert", obwohl es in der Beschreibung eindeutig steht!

Weißt du zufällig auch, wie ich sichtbar darstelle was gerade passiert beim Startskript? Das "Bitte warten..." ist ja schön und gut, aber bei Serverbetriebssystemen steht ja eindeutig da welche Gruppenrichtlinie gerade ausgeführt wird.

Vielen dank nochmal und beste Grüße
Bitte warten ..
Mitglied: redder
22.01.2013 um 12:09 Uhr
Gruppenrichtlinien/Computerkonfiguration/Richtlinien/Administrative Vorlagen/System/Ausführliche im Vergleich zu normalen Meldungen aktivieren.

LG redder
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(1)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Windows Server
Startmenü über GPO Windows 10 - DC 2008 R2 (1)

Frage von dekztar zum Thema Windows Server ...

Windows 10
Windows 10 Update aktiv trotz GPO Windows Server 2008 R2 (4)

Frage von winIT3264 zum Thema Windows 10 ...

Windows Server
Windows Update WLan GPO (1)

Frage von Micki zum Thema Windows Server ...

Heiß diskutierte Inhalte
DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (9)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...

Backup
Clients als Server missbrauchen? (9)

Frage von 1410640014 zum Thema Backup ...