Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Grafikphänomen - Ausgabe hält an, macht erst weiter nach verschieben auf Monitor 2

Frage Microsoft

Mitglied: DerWoWusste

DerWoWusste (Level 5) - Jetzt verbinden

11.04.2012, aktualisiert 22:48 Uhr, 3366 Aufrufe, 9 Kommentare

...nein hier ist nichts vergurkt, es ist eine frische Installation...

Moin die Kollegen!

Wer mir hier helfen kann, bekommt einen Oscar.
Ein neuer Laptop eines Kollegen (win7 enterprise x64 englisch sp1, aktuelle Treiber) zeigt ein sonderbares Phänomen: eine selbstprogrammierte Simulation rechnet laufend Bewegungsabläufe aus und stellt diese auch (in 2D) währenddessen dar, es läuft also eine Art in Realtime berechneter Film ab. Der Laptop hat zwei Ausgänge - HDMI und VGA -, das Problem tritt genau dann auf, wenn man VGA nutzt.

Nach wenigen Minuten (reproduzierbar, wenn auch nicht exakt zur selben Zeit) bleibt das Bild stehen, was alles andere als erwünscht ist, denn auch die Berechnung bleibt stehen und die soll fertig werden.

Dies passierte auf seinem alten Laptop nicht (andere Hardware und Vista x64).

Der Witz ist nun, dass man die Sache wieder in Gang bringen kann, indem man das Simulationsfenster auf einen anderen Monitor schickt (mit Ultramon), egal ob HDMI oder interner Schirm - es geht sofort weiter und kann auch wieder zurück auf VGA geschickt werden und läuft dann selbst dort.

Ich schätze mal, dass seine Programmierkünste daran Schuld sind, aber... was kann überhaupt die Wurzel allen Übels sein?

Problem ist: er führt dies häufig extern vor und Beamer haben nicht selten noch nur einen VGA-Eingang...
Mitglied: mak-xxl
11.04.2012 um 11:12 Uhr
Moin DWW,

Zitat von DerWoWusste:
Der Witz ist nun, dass man die Sache wieder in Gang bringen kann, indem man das Simulationsfenster auf einen anderen Monitor
schickt (mit Ultramon), egal ob HDMI oder interner Schirm - es geht sofort weiter und kann auch wieder zurück auf VGA
geschickt werden und läuft dann selbst dort.

Tritt nach dem Verschieben der Effekt erneut auf? Nutzt die Simulation DirectX? Kann die Zeitspanne durch veränderte VGA-Auflösung signifikant beeinflusst werden?

Freundliche Grüße von der Insel - Mario
Bitte warten ..
Mitglied: DerWoWusste
11.04.2012 um 11:50 Uhr
Hallo mak-xxl und danke für die Anteilnahme.
Der Simulant antwortet: die Simulation nutzt kein DirektX und friert auch bei VGA-Auflösung 800x600 schnell ein! Nach dem Verschieben tritt der Effekt nach einigen Minuten erneut auf.

Könnte nvidia Optimus daran Schuld sein? Kann man leider nicht deaktivieren.
Bitte warten ..
Mitglied: mak-xxl
11.04.2012 um 11:58 Uhr
Moin DWW,

da Du zum Notebook wenig geschrieben hast - ich vermute ein Throttling-Problem (sofern Sandy Bridge CPU etc. pp.)

Freundliche Grüße von der Insel - Mario
Bitte warten ..
Mitglied: DerWoWusste
11.04.2012 um 12:41 Uhr
Notebook ist ein Dell Vostro 3750 mit I7 (echter Quad mit Hyperthr.). Werde zunächst mal andere Graka-Treiber testen.
Was kann man gegen Throttling tun? Wie sage ich denn dem Grafiksystem "nimm immer die starke (Optimus)"? Bei der CPU kann ich das ja noch testen, indem ich sie auslaste... na gut, könnte man bei der Graka auch, wenn man nebenbei einfach 3-D-Grafiken bewegt. So könnte ich zumindest für einen test sagen: "Gethrottelt wurde hier nicht".

Mal schauen.
Bitte warten ..
Mitglied: mak-xxl
11.04.2012 um 12:59 Uhr
Moin DWW,

das Kühlsystem im 3750 ist aber 'knapp auf Kante' - da wird wohl immer gethrottelt. Evtl. hast Du Muße, das Ganze mal im reinen Akkubetrieb zu testen - und evtl. mal mit dem Standard Intel-VGA-Treiber von Win7.

Freundliche Grüße von der Insel - Mario
Bitte warten ..
Mitglied: DerWoWusste
11.04.2012 um 14:14 Uhr
Hi.

Andere Treiber brachten keine Besserung.
Vielleicht hast Du noch einen Tipp: wir haben als Workaround beschlossen, dass wir für externes Präsentieren für Beamer mit VGA-Eingang einen HDMI2VGA-Adapter mitgeben. Nun gibt es digital2analog-Konverter oder aber Kabel wie dieses http://www.adaptare.de/blog/hdmi-vga-kabel-das-raetsel-ist-geloest-und- ... ohne Konverter, welche nur gehen an Laptops, deren HDMI-Ausgang sich auf Analogbetrieb umschalten lässt - davon hab ich noch nie gehört
->Wie stelle ich fest, ob der Vostro das Umschalten beherrscht?
->Wo stellt man um, im Bios?
Bitte warten ..
Mitglied: mak-xxl
11.04.2012 um 16:11 Uhr
Moin DWW,

das tut mir sehr leid, aber ich kann nicht mit Sicherheit sagen, ob und wo sich das analog/digital umschalten lässt - solches drang noch nicht bis an meine Ohren.
Als Konverter für solche Fälle empfehle ich diesen hier - bitte prüfen, ob am Dell der Stecker passt, der ist recht klobig.

Freundliche Grüße von der Insel - Mario
Bitte warten ..
Mitglied: DerWoWusste
11.04.2012 um 18:13 Uhr
Was soll's. Ich nehm einfach mal genau den Adapter und das Problem sollte aus der Welt sein.
Danke!
Bitte warten ..
Mitglied: DerWoWusste
13.04.2012 um 13:26 Uhr
Aargh - zu früh auf gelöst geklickt. Auch mit diesem Adapter das selbe Problem. Ich versteh nur Bahnhof. Woher weiß denn bitte das System, dass nun ein analoges Endgerät dahintersteht und weshalb verhält es sich anders?
Bitte warten ..
Ähnliche Inhalte
Exchange Server
Exchange + Outlook 365 - Absturz beim Verschieben von Ordnern

Frage von JackNukem zum Thema Exchange Server ...

Grafikkarten & Monitore
Monitor defekt?! (5)

Frage von blade999 zum Thema Grafikkarten & Monitore ...

Batch & Shell
gelöst Echo Ausgabe ohne Variablenauflösung (9)

Frage von bartek76 zum Thema Batch & Shell ...

Neue Wissensbeiträge
Google Android

Cyanogenmod alternative Downloadquelle

(5)

Tipp von Lochkartenstanzer zum Thema Google Android ...

Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(5)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Statische Routen mit Shorewall, ISC-DHCP Server konfigurieren für Android Devices (25)

Frage von terminator zum Thema LAN, WAN, Wireless ...

Server
gelöst Wie erkennen, dass nur deutsche IPs Zugang zu einer Website haben? (22)

Frage von Coreknabe zum Thema Server ...

Hardware
16-20 Port POE Switch mit VLAN (19)

Frage von thomasreischer zum Thema Hardware ...

Windows Server
Exchange HyperV Prozessorlast (18)

Frage von theoberlin zum Thema Windows Server ...