Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Grobe Installationsprobleme SLES9 mit HP ProLiant ML350 G6

Frage Linux

Mitglied: Pascal84

Pascal84 (Level 1) - Jetzt verbinden

14.04.2010 um 11:05 Uhr, 6475 Aufrufe, 1 Kommentar

Hallo,
mir wurde die - für mich - schwierige Aufgabe übertragen ein vorgefertigtes SLES9 auf neuer Hardware zu installieren. Da ich mit diesen Dingen noch sehr wenig bis gar keine Erfahrung habe, bitte ich hier um Hilfe. Ich werde versuchen die Problematik so genau wie möglich zu beschreiben. Weitere Informationen stelle ich, falls benötigt, gerne zur Verfügung.

Relevante Informationen zur Hardware:
HP ProLiant ML350 G6 Tower Server
XEON E5506 CPU 2,13 GHz
2x SAS 2,5" 146 GB Festplatten am P410i als RAID1 Verbund
Integrierter HP Smart Array P410i Raid Controllor
DVD Laufwerk am SATA Port
(Kein IDE Port und auch kein Floppy Laufwerk vorhanden)

Informationen zum Betriebssystem:
Es ist eine vorgefertigte Installations-DVD, bei der alle für uns nötigen Programme und Einstellungen gleich mit installiert werden. Der verwendete Kernel ist 2.6.5-7.97-smp. Ausserdem besitze ich auch noch ein ISO-Image von der eben erwähnten Installations-DVD. Gleich vorweg bemerkt: Ich habe keine Möglichkeit, an eine neuere OS-Version (SLES9 mit höherem Patchlevel oder gar SLES10 oder 11) heranzukommen. Ich wurde also dazu angehalten, den ProLiant mit dieser DVD bzw. diesem Kernel zum laufen zu bekommen. Noch eine Info am Rande: Mit dieser DVD wurden auch schon erfolgreich Server vom Typ HP ProLiant ML350 G5 - ebenfalls mit SAS-Controller (E200i) installiert. Hierzu waren auch manuelle nacharbeiten nötig, leider ist der betreffende Mitarbeiter mittlerweile aus dem Unternehmen ausgeschieden und hat keine detaillierte Anleitung oder genauere Infos hinterlassen.


Beschreibung der Problematik:
Das Booten von der DVD erfolgt noch ohne Probleme. SLES Installationsmenü erscheint (Installation oder. MEM-Test ist auszuwählen, weiters kann Auflösung, Sprache, etc. wie üblich eingestellt werden) Menüpunkt Installation wird angewählt, Loading Linux Kernel erscheint, RAM-Disk wird geladen, Hardware Detection usw. und dann das erste Problem:
"Could not find the SUSE Linux Enterprise Server 9 Installation CD.
Activation manual Setup program"
Sprich, das System erkennt das DVD Laufwerk am SATA-Port nicht.
Sieht für mich so aus als würde der entsprechende SATA-Treiber fehlen. An diesem Punkt steht es leider für mich schon mal an. Soweit ich weiß bzw. das in Erfahrung bringen konnte, müsste ich den entsprechenden Treiber in die initrd einfügen und eine neue Installations-DVD brennen. Ihr seht wahrscheinlich an diesem Punkt schon das ich hier wirklich noch sehr wenig Erfahrung habe... Bisher gelang es mir auch noch nicht, herauszufinden welchen Treiber ich benötige bzw. welcher SATA-Controller beim ML350 G6 verbaut ist, auf der HP-Seite finde ich dazu auch keine Informationen. Auch wenn ich den Treiber nun bereits hätte, wüsste ich bis dato auch noch nicht die Vorgehensweise bzw. die Schritte die nötig sind um ihn korrekt in die Installations-DVD bzw. in die initrd einzubauen...

Wahrscheinliche weitere Problematik
Da ich ja dann ins manual setup program Falle, habe ich mich dort natürlich auch umgesehen. Unter System-Informationen > Festplatten / CD-ROMs kommt die Meldung "Bislang wurden weder Festplatten noch CD-ROM Laufwerke..." was mich zu dem Schluss bringt, das auch der SAS-Controller nicht richtig erkannt wird. Ich denke ich werde also, selbst wenn ich das SATA-DVD-Laufwerk zum "laufen" bekomme (oder auf ein externes USB-DVD-Laufwerk ausweiche), mit dem P410i Controller eine ähnliche Treiberproblematik haben.

Puuh... Bevor das jetzt ein noch längere Aufsatz wird, warte ich erstmal eine erste Reaktion ab und hoffe auf Antworten zu meiner Problematik.
Ich möchte im vorhinein schonmal ein großes und herzliches DANKE für jegliche Hilfe anbringen, ihr habt sicher schon gemerkt, dass ich in diesen (für mich) komplexen Dingen noch sehr wenig Erfahrung habe. Aber ich möchte ja dazu lernen

Freundliche Grüße an alle Leser
Pascal
Mitglied: Pascal84
14.04.2010 um 16:49 Uhr
Update:

Ich habe mir heute ein externes DVD-Laufwerk (USB) besorgt - mit diesem konnte ich zumindest bei der Installation schonmal bis zum login booten und mich als root anmelden. Soweit so gut, die einzige Problematik ist jetzt nur noch einen passenden Treiber für den SAS-Controller HP Smart Array P410i aufzutreiben, der mit dem Kernel 2.6.5-7.97 funktioniert. Da leider auf der HP-Smart-Start CD nur Treiber für SLES10 und SLES11 vorhanden sind, habe ich auf der HP-Seite gesucht und wurde auch fündig unter

Link zum Treiber

Dort sieht nun alles danach aus, als ob die Unterstützung für den HP Smart Array P410i bei der neuesten Treiberversion hinzugefügt wurde. Alles gut und schön... nur hab ich jetzt das Problem dass allem anschein nach mein "alter" Kernel nicht unterstützt wird:

Supported kernels
2.6.5-7.308 - SUSE LINUX Enterprise Server 9 SP 4 (x86)


Natürlich habe ich mir trotzdem das file runtergeladen, das enthaltene .dd mit mount -o loop dateiname.dd /media/floppy gemounted und versucht mittels insmod cciss.ko den Treiber einzufügen:
insmod: error inserting 'cciss.ko': -1 Invalid module format
war die Antwort. Wenn ich das richtig sehe, liegt das genau daran, dass mein "alter" kernel nicht supported wird...

So. Die obligatorische Frage reduziert sich nun auf:

Habe ich denn gar keine Chance diesen Controller mit meiner Kernel-Version zum laufen zu kriegen?

Freundliche Grüße an alle Leser
Pascal
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
SAN, NAS, DAS
ISCSI Adapter für HP Proliant ML350 G6 fehlt (5)

Frage von mexx zum Thema SAN, NAS, DAS ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (16)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Festplatten, SSD, Raid
SSD für HP ProLiant Gen9 (10)

Frage von Noah12 zum Thema Festplatten, SSD, Raid ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...